<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v18.9 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Friday, June 3: &#039;The Boys&#039; Are Back for More Mayhem on Prime Video</title>
	<meta name="description" content="This season will explore the history of the world’s first superhero team during World War II and expand upon the government’s surveillance of the supes." />
	<link rel="canonical" href="https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Friday, June 3: &#039;The Boys&#039; Are Back for More Mayhem on Prime Video" />
	<meta property="og:description" content="This season will explore the history of the world’s first superhero team during World War II and expand upon the government’s surveillance of the supes." />
	<meta property="og:url" content="https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/" />
	<meta property="og:site_name" content="Channel Guide Magazine" />
	<meta property="article:publisher" content="https://www.facebook.com/ChannelGuideMagazine" />
	<meta property="article:published_time" content="2022-06-03T11:00:46+00:00" />
	<meta property="article:modified_time" content="2022-06-02T17:13:38+00:00" />
	<meta property="og:image" content="https://www.channelguidemag.com/wp-content/uploads/2022/06/TheBoysSn3BB.jpg" />
	<meta property="og:image:width" content="1030" />
	<meta property="og:image:height" content="438" />
	<meta property="og:image:type" content="image/jpeg" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Channel Guide Staff" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="13 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.channelguidemag.com/#website","url":"https://www.channelguidemag.com/","name":"Channel Guide Magazine","description":"Our writers comment on the state of TV","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.channelguidemag.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/#primaryimage","url":"https://www.channelguidemag.com/wp-content/uploads/2022/06/TheBoysSn3BB.jpg","contentUrl":"https://www.channelguidemag.com/wp-content/uploads/2022/06/TheBoysSn3BB.jpg","width":1030,"height":438,"caption":"The Boys Prime Video"},{"@type":"WebPage","@id":"https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/#webpage","url":"https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/","name":"Friday, June 3: 'The Boys' Are Back for More Mayhem on Prime Video","isPartOf":{"@id":"https://www.channelguidemag.com/#website"},"primaryImageOfPage":{"@id":"https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/#primaryimage"},"datePublished":"2022-06-03T11:00:46+00:00","dateModified":"2022-06-02T17:13:38+00:00","author":{"@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f"},"description":"This season will explore the history of the world’s first superhero team during World War II and expand upon the government’s surveillance of the supes.","breadcrumb":{"@id":"https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/"]}]},{"@type":"BreadcrumbList","@id":"https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.channelguidemag.com/"},{"@type":"ListItem","position":2,"name":"TV News","item":"https://www.channelguidemag.com/tv-news/"},{"@type":"ListItem","position":3,"name":"Friday, June 3: &#8216;The Boys&#8217; Are Back for More Mayhem on Prime Video"}]},{"@type":"Person","@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f","name":"Channel Guide Staff","image":{"@type":"ImageObject","inLanguage":"en-US","@id":"https://www.channelguidemag.com/#/schema/person/image/","url":"https://secure.gravatar.com/avatar/68b6c70392ac45a38a16ac89e1b612bb?s=96&d=blank&r=g","contentUrl":"https://secure.gravatar.com/avatar/68b6c70392ac45a38a16ac89e1b612bb?s=96&d=blank&r=g","caption":"Channel Guide Staff"},"url":"https://www.channelguidemag.com/tv-news/author/staff/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Feed" href="https://www.channelguidemag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Comments Feed" href="https://www.channelguidemag.com/comments/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.5.3 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-435360-2"  data-cfasync="false" data-wpfc-render="false" type="text/javascript" async></script>
			<script data-cfasync="false" data-wpfc-render="false" type="text/javascript">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</script>
				<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.channelguidemag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=ba7d5d3f19d692056d92cb59b901ca80"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.channelguidemag.com/wp-includes/css/dist/block-library/style.min.css?ver=ba7d5d3f19d692056d92cb59b901ca80' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://www.channelguidemag.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.channelguidemag.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=ba7d5d3f19d692056d92cb59b901ca80' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='media-credit-css'  href='https://www.channelguidemag.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/style.css?ver=ba7d5d3f19d692056d92cb59b901ca80' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine-child/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans:300,400,400italic,600,700,700italic%7cMontserrat:300,400,400italic,600,700,700italic' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.9.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.5.3' id='monsterinsights-frontend-script-js'></script>
<script data-cfasync="false" data-wpfc-render="false" type="text/javascript" id='monsterinsights-frontend-script-js-extra'>/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.channelguidemag.com","hash_tracking":"false","ua":"UA-435360-2","v4_id":""};/* ]]> */
</script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/www.channelguidemag.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/www.channelguidemag.com\/wp-json\/wordpress-popular-posts","ID":186062,"token":"4939f4016c","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.5.1' id='wpp-js-js'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3' id='mh-scripts-js'></script>
<link rel="https://api.w.org/" href="https://www.channelguidemag.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.channelguidemag.com/wp-json/wp/v2/posts/186062" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.channelguidemag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.channelguidemag.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p7FdZg-Mp0' />
<link rel="alternate" type="application/json+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2022%2F06%2F03%2Ffriday-june-3-the-boys-prime-video-season-3%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2022%2F06%2F03%2Ffriday-june-3-the-boys-prime-video-season-3%2F&#038;format=xml" />
            <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style>
            <style type='text/css'>img#wpstats{display:none}</style>
	<style type="text/css">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</style>
<style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Montserrat", sans-serif; }
body { font-family: "Droid Sans", sans-serif; }
</style>
<link rel="amphtml" href="https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/amp/"><link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-270x270.png" />


<script src="https://cmp.osano.com/16BcscRpZUDCE2Y0Z/0b6a2128-f6bd-4fa8-b909-5ed16896e933/osano.js"></script>



<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
var mapping2 = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot2= googletag.defineSlot('/4370989/CGM-lead-bottom-flex', [320,50], 'div-gpt-ad-1426776676899-0').
defineSizeMapping(mapping2).
addService(googletag.pubads()).
setCollapseEmptyDiv(true);
var mapping = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot1= googletag.defineSlot('/4370989/cgm-lead-flexible-top', [320,50], 'div-gpt-ad-1426776676899-1').
defineSizeMapping(mapping).
addService(googletag.pubads());

googletag.defineSlot('/4370989/Medium_Rectangle_2_internal_ads', [300, 250], 'div-gpt-ad-1426776676899-2').addService(googletag.pubads());
googletag.defineSlot('/4370989/Medium_Rectangle_300x250', [300, 250], 'div-gpt-ad-1426776676899-3').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-186062 single-format-standard mh-boxed-layout mh-right-sb mh-loop-layout2 mh-widget-layout2" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<a class="mh-header-image-link" href="https://www.channelguidemag.com/" title="Channel Guide Magazine" rel="home">
<img class="mh-header-image" src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png" height="139" width="496" alt="Channel Guide Magazine" />
</a>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-99135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99135"><a href="/tv-listings/">TV Listings</a></li>
<li id="menu-item-151619" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-151619"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a>
<ul class="sub-menu">
	<li id="menu-item-99133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99133"><a href="https://www.channelguidemag.com/movies-tv/">Movies on TV</a></li>
	<li id="menu-item-154098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154098"><a href="https://www.channelguidemag.com/tv-news/category/vod/">New to On Demand &#038; DVD</a></li>
</ul>
</li>
<li id="menu-item-151620" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151620"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-99134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-99134"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports on TV</a>
<ul class="sub-menu">
	<li id="menu-item-152175" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152175"><a href="https://www.channelguidemag.com/sports-on-tv/">This Week&#8217;s Schedule</a></li>
</ul>
</li>
<li id="menu-item-151622" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151622"><a href="/network-contacts/">How to contact a Network</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-customer-service-container"><ul id="menu-customer-service" class="menu"><li id="menu-item-151605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">SUBSCRIBE / RENEW / MORE</a>
<ul class="sub-menu">
	<li id="menu-item-151606" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li id="menu-item-151607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li id="menu-item-151608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li id="menu-item-181202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-181202"><a href="https://www.channelguidemag.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-151609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li id="menu-item-156378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-151616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-151617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-151618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>

<div class="mh-wrapper clearfix">
<span class='mh-best-bets-caption'>TV Best Bets</span>	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content"><article id="post-186062" class="post-186062 post type-post status-publish format-standard has-post-thumbnail hentry category-tv-best-bets">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Friday, June 3: &#8216;The Boys&#8217; Are Back for More Mayhem on Prime Video		</h1>
		<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2022/06/">June 3, 2022</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.channelguidemag.com/tv-news/author/staff/">Channel Guide Staff</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/" rel="category tag">TV Best Bets</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Friday, June 3: &#8216;The Boys&#8217; Are Back for More Mayhem on Prime Video</span></span></span>
</div>
	</header>
		<div class="entry-content clearfix"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-186062" class="share-facebook sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-186062" class="share-pinterest sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-186062" class="share-twitter sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<figure class="entry-thumbnail">
<img src="https://www.channelguidemag.com/wp-content/uploads/2022/06/TheBoysSn3BB-678x381.jpg" alt="The Boys Prime Video" title="TheBoysSn3BB" />
<span class="media-credit">Prime Video</span></figure>
<h3>ALSO SEE: <a href="https://www.tvinsider.com/1031206/nascar-2022-tv-schedule-fox-nbc-sports/" target="_blank" rel="noopener">2022 NASCAR TV Schedule on FOX Sports and NBC</a></h3>
<p><strong>All Times Eastern. <a href="https://www.pbs.org/" target="_blank" rel="noopener">PBS</a> programming varies regionally.</strong></p>
<h2>Friday, June 3</h2>
<p><strong><a href="https://www.tvinsider.com/show/the-boys/" target="_blank" rel="noopener">The Boys</a><br />
Prime Video<br />
Season Premiere!</strong><br />
You won’t find spontaneously exploding heads in the MCU. This violent, profane and subversive superhero series based on the bestselling comic by Garth Ennis and Darick Robertson is back for more raucous misadventures (and, possibly, exploding heads) in Season 3. The ensemble cast of characters includes a small group of vigilantes working to impede and expose beloved superheroes who project a wholesome, patriotic image to the public but covertly act in ways unbecoming of those who claim to be dedicated to the common good. Hughie (Jack Quaid), Billy (Karl Urban), Mother’s Milk (Laz Alonso), Kimiko (Karen Fukuhara) and Frenchie (Tomer Capone) are the ragtag vigilantes. The “supes” include Starlight (Erin Moriarty), Homelander (Antony Starr), A-Train (Jessie T. Usher) and The Deep (Chace Crawford). This season will explore the history of the world’s first superhero team during World War II and expand upon the government’s surveillance of the supes. New cast members include Jensen Ackles (Soldier Boy), Laurie Holden (Crimson Countess) and Sean Patrick Flanery (Gunpowder). — <em>Paul Doro</em></p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/K-8VYKUZYiw?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></p>
<p><strong>Physical<br />
Apple TV+<br />
Season Premiere!</strong><br />
In Season 2 of the dark comedy set in the 1980s, Sheila Rubin (Rose Byrne) has successfully launched her first fitness video, only to encounter some new and bigger obstacles in her path. She is torn between loyalty to her husband (Rory Scovel) and the values he represents, and a dangerous attraction to someone else. And since she’s no longer the only game in town, she finds herself having to outrun some fierce new competitors on the road to building a full-fledged fitness empire. Joining Byrne, Scovel and other returning members of the ensemble cast is newcomer Murray Bartlett, who plays Vinnie Green, a charismatic fitness instructor, weight-loss guru and pioneer of the late-night infomercial. New episodes are available Fridays.</p>
<p><strong>Shining Girls<br />
Apple TV+<br />
Season Finale!</strong><br />
The Elisabeth Moss-led thriller concludes its first season.</p>
<p><strong>Trixie Motel<br />
discovery+<br />
New Series!</strong><br />
Drag superstar Trixie Mattel expands her outrageously fun empire into the hospitality industry in this eight-episode series that follows her as she and her team embark on a massive overhaul of a ramshackle mid-century motel in Palm Springs to turn it into what Mattel says will be the “gaggiest, most iconic motel that has ever existed.” Helping her out are famous friends including Bravo reality star Lisa Vanderpump, comedian Nicole Byer, actor/musician Zooey Deschanel, <em>Property Brothers </em>costar Jonathan Scott and drag queen/partner in crime Katya. Two episodes are available today; subsequent new episodes are available Fridays.</p>
<p><strong>Hollywood Stargirl<br />
Disney+<br />
Original Film!</strong><br />
This sequel to the 2020 Disney+ film <em>Stargirl</em> follows the journey of free spirit Stargirl Caraway (Grace VanderWaal), a silver-voiced teen whose simple acts of kindness work magic in the lives of others, out of Mica, Arizona, and into a bigger world of music, dreams and possibilities. When her mother, Ana (Judy Greer), is hired as the costume designer on a movie, they relocate to Los Angeles, where Stargirl quickly becomes involved with an eclectic assortment of characters. They include aspiring filmmaking brothers Evan (Elijah Richardson) and Terrell (Tyrel Jackson Williams); Mr. Mitchell (Judd Hirsch), one of Stargirl’s neighbors; and Roxanne Martel (Uma Thurman), a musician whom Stargirl admires. Along with starring in the lead role, singer-songwriter VanderWaal also wrote and performs the original song “Figure It Out.”</p>
<p><strong>Fire Island<br />
Hulu<br />
Original Film!</strong><br />
This romantic comedy inspired by <em>Pride and Prejudice</em> is set on the famous titular gay recreational destination. Joel Kim Booster (who also wrote and executive produced the film), Bowen Yang, Conrad Ricamora, James Scully and Margaret Cho lead the cast.</p>
<p><strong>Floor Is Lava<br />
Netflix<br />
Season Premiere!</strong><br />
Season 2 of the competition series features bigger obstacles, higher stakes and even hotter lava. New this season is a huge and very slippery volcano that takes things to the next level.</p>
<p><strong>Interceptor<br />
Netflix<br />
Original Film!</strong><br />
In this action thriller, military captain JJ Collins (Elsa Pataky) finds herself in charge of a lone missile interceptor base in the middle of the Pacific after she is wrongfully drummed out of her dream job at the Pentagon. When a simultaneous coordinated attack threatens the base, Collins comes face-to-face with Alexander Kessel (Luke Bracey), a former U.S. intelligence officer intent on carrying out an unthinkable plan. With only minutes on the clock, Collins must use her years of tactical training and military expertise to stop Kessel and his mercenaries.</p>
<p><strong>The Platinum Jubilee of Queen Elizabeth II<br />
FOX News Channel, 5am Live</strong><br />
FOX News Channel&#8217;s coverage of the Queen Elizabeth II’s Platinum Jubilee continues with this live special hosted by Ainsley Earhardt, Martha MacCallum and Piers Morgan from Park Plaza Westminster Bridge in London. The broadcast features the service of Thanksgiving at St. Paul’s Cathedral.</p>
<p><strong>Star of the Month: Judy Garland<br />
TCM, beginning at 1pm<br />
Catch a Classic!</strong><br />
Every Friday this month on Turner Classic Movies, enjoy several hours of classic performances from Frances Ethel Gumm — better known as iconic actress/singer Judy Garland. Today’s initial lineup includes more than 12 hours of seven titles representing some of Garland’s earliest work. It begins, appropriately, with her film debut in the 1936 college-set musical comedy <em>Pigskin Parade</em>, which featured the teenage Garland billed way below other cast members like Stuart Erwin and her future <em>Wizard of Oz</em> costar Jack Haley. Up next is Garland’s second film, <em>Broadway Melody of 1938</em>, a 1937 musical that remains most notable for her rendition of the song “You Made Me Love You (I Didn’t Want to Do It),” a tribute to Clark Gable that turned the 15-year-old actress into an overnight sensation. Garland continued her rise to the top in 1938 with tonight’s next two films: the musical <em>Everybody Sing</em>, in which she had second billing between Allan Jones and Fanny Brice; and the musical comedy <em>Listen, Darling</em>, which featured her leading a cast that also includes Freddie Bartholomew, Mary Astor and Walter Pidgeon. Following that is <em>Babes in Arms</em>, a coming-of-age Broadway musical that, along with <em>The Wizard of Oz</em>, was one of the films that made 1939 the year Garland truly became a superstar. For her work in those classics, the 17-year-old was honored at the 1940 Oscar ceremony with the Academy Juvenile Award “for her outstanding performance as a screen juvenile during the past year.” <em>Babes in Arms</em> costars Best Actor Oscar nominee Mickey Rooney. This was the second of Garland and Rooney’s memorable onscreen pairings, and the duo team up again in today’s final two musicals, which were follow-ups of sorts to <em>Babes in Arms</em>. <em>Babes on Broadway</em> (1941) was directed by famed choreographer Busby Berkeley, but Garland’s big solo numbers were helmed by uncredited future legend Vincente Minnelli, who would go on to memorably direct the actress in classics like <em>Meet Me in St. Louis</em>. He and Garland were also married from 1945-51, and were parents to a daughter who became a singing and acting icon in her own right: Liza Minnelli. The day concludes with the 1940 Garland/Rooney musical <em>Strike Up the Band</em>.</p>
<p><strong>Flashback Friday<br />
AMC, beginning at 8pm</strong><br />
Every Friday in June, AMC takes us back to some favorite films from our past. Tonight’s double feature includes the Dan Aykroyd and John Candy classic <em>The Great Outdoors</em>, followed by Sean Penn’s memorable turn as stoner Jeff Spicoli in <em>Fast Times at Ridgemont High</em>.</p>
<p><strong>The Villains of Valley View<br />
Disney Channel, beginning at 8pm<br />
New Series!</strong><br />
When teenage supervillain Havoc (Isabella Pappas) stands up to the head of the League of Villains, her family is forced to change their identities and relocate to a sleepy Texas suburb. With the help of her effervescent new neighbor Hartley (Kayden Muller-Janssen), Havoc — going incognito as “Amy” — must somehow hide her superpowers and quell her villainous nature in favor of something she and the rest of her family have fought against all their lives: being normal.</p>
<p><strong>The Wedding Planners<br />
UPtv, beginning at 8pm<br />
New Series!</strong><br />
This Canadian drama has been streaming on the UP Faith &amp; Family service and now makes its linear debut on UPtv. The series follows siblings Paige, James and Hannah Clarkson (Kimberly-Sue Murray, Michael Seater and Madeline Leon), who come together after their beloved mother (played by Michelle Nolden in flashback scenes) suddenly passes away. They look to honor her legacy while being true to themselves as they wrestle with managing her business: planning elegant, personal weddings. Two hourlong episodes air each Friday night this month.</p>
<p><strong>Ultra Violet &amp; Black Scorpion<br />
Disney Channel, beginning at 9pm<br />
New Series!</strong><br />
Violet Rodriguez (Scarlett Estevez), an everyday Mexican American teen, is chosen by a magical luchador mask that transforms her into Ultra Violet, a superhero fighting crime alongside her luchador uncle, Cruz de la Vega (J.R. Villarreal), also known as Black Scorpion. Although Cruz takes Violet under his wing to teach her the responsibilities of her special powers, she doesn&#8217;t always see eye-to-eye with him when it comes to his methods for capturing crooks. In the meantime, she must keep her superhero identity secret from her parents and her older brother Santiago (Brandon Rossel), as well as her friends and schoolmates. However, she does lean on one close confidante: her best friend Maya Miller-Martinez (Zelia Ankrum), who provides advice and assists with documenting Ultra Violet’s adventures on social media.</p>
<p><strong>Guy’s All-American Road Trip<br />
Food Network, 9pm<br />
New Series!</strong><br />
Guy Fieri, his wife, Lori, and his sons, Hunter and Ryder, load up their RV and hit the road with a caravan of campers full of family friends for an unforgettable trip. Their journey up the coast is filled with big adventure, fun competitions and unbelievable meals, as the Fieris and their friends make their way from Northern California through Oregon and into Washington.</p>
<p><strong>American Masters: “Joe Papp in Five Acts”<br />
PBS, 9pm</strong><br />
Enter the world of Joe Papp, New York’s streetwise champion of the arts. As founder of The Public Theater and Free Shakespeare in the Park, and producer of groundbreaking plays such as <em>Hair</em> and <em>A Chorus Line</em>, Papp recognized the role art could play in building a more democratic, inclusive society. The story of Papp’s great accomplishments, and his often tumultuous personal history, is told by the artists he helped create — and, in some cases, tried to destroy — including Meryl Streep, James Earl Jones and Martin Sheen.</p>
<p><strong>P-Valley<br />
Starz, 9pm<br />
Season Premiere!</strong><br />
Season 2 of the drama about Pynk, a strip club in the Mississippi Delta, follows its struggles to remain open during a pandemic, a battle for the throne and the possibility of some new blood shaking up the locker room.</p>
<p><strong>Beyond the CANVAS: “Art, to Change the World”<br />
PBS, 10:30pm</strong><br />
Uncover hidden history and see how creators use art to advocate for good and change in the world.</p>
<h3>Saturday, June 4</h3>
<p><strong>Tennis: French Open: Women’s Final<br />
NBC, 9am Live</strong><br />
The Suzanne Lenglen Cup is on the line as the final two ladies in the bracket face off on the red clay court of Roland-Garros for the French Open women’s singles title.</p>
<p><strong>Van Go<br />
Magnolia Network, 12pm<br />
New Series!</strong><br />
This series follows Chewy Design Co. owner Brett Lewis as he renovates vans into tiny homes on the road, innovating creative solutions and tackling the many challenges that come with custom-outfitting each vehicle for his clients’ lifestyles. The series kicks off with two back-to-back half-hour episodes today.</p>
<p><strong>Super Dad<br />
Magnolia Network, 1pm<br />
Season Premiere!</strong><br />
DIY expert Taylor Calmus is back for Season 2 of his series in which he helps dads realize their kids’ backyard dreams. Back-to-back half-hour episodes will air each week. In the season premiere, “Crazy About Camping,” a father of three enlists Taylor’s help to create a structure in the woods near his home for his kids. Then, in “Shooting for the Stars,” a veteran and father of three asks Taylor to build an out-of-this-world play structure, complete with a bridge, climbing wall and homemade rocket launcher.</p>
<p><strong>MLB Baseball<br />
FOX, beginning at 7pm Live</strong><br />
Saturday’s primetime regional MLB game on FOX features either the L.A. Angels at the Philadelphia Phillies or the St. Louis Cardinals at Chicago Cubs.</p>
<p><strong>Murdoch Mysteries: “Bloodlines” &amp; “Patriot Games”<br />
Ovation, beginning at 7pm</strong><br />
In “Bloodlines,” Violet Hart (Shanice Banton) investigates when a protester dies at an event in support of rights for people of color. Then, in “Patriot Games,” Murdoch (Yannick Bisson) investigates when a Japanese spy is found dead in a Korean family’s cellar.</p>
<p><strong>Planet Earth: Dynasties II: “Cheetah”<br />
BBC America, 8pm</strong><br />
On Zambia’s plains, a cheetah mother and her three growing daughters must travel thousands of kilometers every year to roam their vast territory searching for food. New challenges arise as the wet season arrives and floodwaters advance in the new episode “Cheetah.”</p>
<p><strong>Hidden Gems<br />
Hallmark Channel, 8pm<br />
Original Film!</strong><br />
While prepping for her sister’s wedding, Addie (Hunter King) loses her grandmother’s ring in the waters of Hawaii. She hires dive instructor Jack (Beau Mirchoff) to search for her lost treasure. They immediately clash with each other when Addie insists she go on the pursuit with Jack. Once they come to an agreement, Jack ends up serving as Addie’s tour guide of the island’s hidden gems.</p>
<p><strong>Buried in Barstow<br />
Lifetime, 8pm<br />
Original Film!</strong><br />
Hazel King (Angie Harmon) is no ordinary ex-assassin. Having wielded a gun since age 15, the trained killer now runs a local desert-town diner and has an adult daughter (Lauren Richards) to protect. But the past is hard to outrun, and Hazel shies away from nothing as shady characters arrive in town to take her up on her particular skill set. Also stars Kristoffer Polaha.</p>
<p><strong>Transplant: “Between”<br />
NBC, 8pm</strong><br />
Mags (Laurence Leboeuf) is flooded by memories of her own health struggles as a child while fighting to save a baby with a heart defect; with his performance still being closely scrutinized, Bash (Hamza Haq) remotely treats a cluster of patients with an undiagnosed illness in Aleppo; and Dr. Curtis’ (Ayisha Issa) personal and professional lives collide. <em>Transplant </em>will be preempted next Saturday and returns with a new episode on Saturday, June 18.</p>
<p><strong>Special Theme: Follow the Thread: “When Fashion and Costume Collide”<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Each Saturday evening in June, Turner Classic Movies’ “Follow the Thread” special theme will spotlight a double feature of films associated with a particular theme having to do with fashion in memorable Hollywood productions. Tonight’s lineup is a twin bill of movies that are notable examples of times when fashion designers and costume designers, who generally have distinct goals and responsibilities, have had to work together with their artistry to make a film. These collaborations haven’t always been easy (or friendly), but the output was often stunning, as it was in tonight’s productions. Up first is <em>Stage Fright</em> (1950), the Alfred Hitchcock-helmed mystery starring Marlene Dietrich as a glamorous high-society singer. The costume designer was Milo Anderson, known for creating Joan Crawford’s waitress uniform in <em>Mildred Pierce</em>, the chorus girl costumes in <em>42nd Street</em> and Lana Turner’s tight sweater in <em>They Won’t Forget</em> (the reason Turner became famous as “The Sweater Girl”). Anderson was a pro, but Dietrich insisted that her costumes be designed by the legendary Christian Dior’s fashion house. Hitchcock and studio head Jack Warner didn’t like the idea, but the star insisted (her phrase “No Dior, no Dietrich” became famous) and, ultimately, both relented. The result was an exquisite assortment of dresses, jackets and gowns that made Dietrich stand out. Her much younger costar, Jane Wyman, was distraught because she looked so unsophisticated in comparison. Following that is the iconic 1954 romantic comedy <em>Sabrina</em>, starring Audrey Hepburn. Few actresses have been as associated with fashion as Hepburn was, and it was this film that started her path toward becoming a style icon. Famed costume designer Edith Head was responsible for the costumes in the film and had already started sketching dresses for the actress when she learned that Hepburn actually wanted to wear “real” Paris clothing once her character transforms from a shy girl into a sophisticated and confident woman. Hepburn went to Paris, where she found a collection of dresses designed by Hubert de Givenchy that she thought was right for her character. Head was disappointed to be left with the much less glamorous wardrobe, but the contrast was perfect for the movie. <em>Sabrina</em> went on to win the Oscar for its costumes, but in accepting the award, Head never mentioned Givenchy’s contribution.</p>
<p><strong>Renovation Goldmine: “Islands and Pool Houses”<br />
HGTV, 10pm</strong><br />
Joe and Meg Piercy rescue a couple from their dated kitchen by rethinking the floor plan, amping up the style and upcycling their existing furniture. Then, the duo come up with a colorful and swanky design for a pool house, a rare perk in Chicago.</p>
<h3>Sunday, June 5</h3>
<p><strong>Tennis: French Open: Men’s Final<br />
NBC, 9am Live</strong><br />
The second Grand Slam tournament on the tennis calendar wraps up with the French Open men’s singles final at Roland-Garros in Paris.</p>
<p><strong>Golf: U.S. Women’s Open: Final Round<br />
NBC, 3pm Live</strong><br />
The national champion of women’s golf is crowned at Pine Needles Lodge &amp; Golf Club in Southern Pines, North Carolina.</p>
<p><strong>NASCAR Cup Series: Enjoy Illinois 300<br />
FS1, 3:30pm Live</strong><br />
The Cup Series comes to World Wide Technology Raceway near St. Louis for the first Enjoy Illinois 300, featuring top drivers Joey Logano, Ryan Blaney, Chase Elliott, Martin Truex Jr. and Kyle Larson competing for 240 laps around the 1.25-mile oval.</p>
<p><strong><a href="https://www.tvinsider.com/1033728/ntt-indycar-series-2022-tv-schedule-nbc-sports/" rel="noopener" target="_blank">NTT IndyCar Series</a>: Chevrolet Detroit Grand Prix<br />
USA Network, 3:30pm Live</strong><br />
Pato O’Ward, Alex Palou, Scott McLaughlin, Josef Newgarden and other IndyCar contenders compete on 2.35-mile, 13-turn temporary street circuit on Detroit’s Belle Isle.</p>
<p><strong>Our Dream Wedding<br />
UPtv, 7pm<br />
Original Film!</strong><br />
A commitment-shy woman (Rachel Hendrix) tries on her grandma’s “magical” wedding veil and is transported to her future, where she and her long-term boyfriend (James Austin Kerr) are happily married with two beautiful children. Is she ready to take the veil off and take on what comes next?</p>
<p><strong>DOA at the PTA<br />
Lifetime, 8pm<br />
Original Film!</strong><br />
Hoping to get more involved at her daughter’s new middle school, Gail joins the PTA, only to find it run by power-hungry mom Vanessa, who has a penchant for backstabbing. Stars Brianna Cohen, Jonathan Stoddard and Alissa Filoramo.</p>
<p><strong>2022 MTV Movie &amp; TV Awards<br />
MTV, 8pm Live</strong><br />
MTV’s annual celebration of movies and TV returns. The network is combining what had last year been separate ceremonies that aired over two evenings — the <em>MTV Movie &amp; TV Awards</em> for scripted titles and <em>Movie &amp; TV Awards: UNSCRIPTED</em> for reality programming — into what the network is calling “a one-night-only global event,” starting with the two-hour <em>Movie &amp; TV Awards</em> and followed by the <em>UNSCRIPTED</em> event. <em>Spider-Man: No Way Home</em> leads the <em>Movie &amp; TV Awards</em> field of films with seven nominations, while <em>Euphoria</em> has the most among TV nominees with six. Vanessa Hudgens hosts the Movie &amp; TV Awards ceremony, which will also be simulcast across several other linear cable channels in the Viacom family: BET, BET Her, CMT, Comedy Central, The CW, Logo, MTV2, Nick at Nite, Paramount Network, Pop, TV Land and VH1.</p>
<p><strong>Fathers on Film — Part 1<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Each Sunday night in June, including Father’s Day, Sunday, June 19, Turner Classic Movies celebrates big-screen dads with a double feature of memorable films about fathers and fatherly figures. Tonight’s initial twin bill kicks off with Vincente Minnelli’s 1950 Best Picture Oscar-nominated comedy classic <em>Father of the Bride</em>, starring Best Actor Oscar nominee Spencer Tracy as a harried man prepping for his daughter’s (Elizabeth Taylor) walk down the aisle. The film also received an Oscar nomination for its screenplay by Frances Goodrich and Albert Hackett, who adapted Edward Streeter’s novel. Up next is that movie’s 1951 sequel, <em>Father’s Little Dividend</em>, which re-teams the stars, writers and director in a tale about Tracy’s character now coming to grips with becoming a grandfather.</p>
<p><strong>LEGO Masters Sneak Peek: Jurassic World<br />
FOX, 8:30pm</strong><br />
The new season of <em>LEGO Masters</em> debuts this fall, but fans can get a sneak preview of the <em>Jurassic World Dominion</em>-themed episode in this special featuring a guest appearance by star Chris Pratt and velociraptor Blue.</p>
<p><strong>Fear the Walking Dead<br />
AMC, 9pm<br />
Season Finale!</strong><br />
With a season that saw a significant purge of several central characters, there’s still true fear there could be more bloodletting as we head into the finale. While Alicia has terminal health problems that make her character’s survival questionable, the actress who plays her — Alycia Debnam-Carey — is also set to film a Hulu series this summer, which could conflict with the shooting of the eighth season. We’re hoping she holds on until the end!</p>
<p><strong>Watergate: Blueprint for a Scandal<br />
CNN, beginning at 9pm<br />
New Series!</strong><br />
This month marks the 50th anniversary of the infamous break-in that led to the Watergate political scandal that took down President Richard Nixon’s administration. With this four-part series, CNN reexamines the whole Watergate affair with an immersive look inside Nixon’s inner circle and the schemes that took place behind closed doors. Much of the story is told firsthand by John Dean, former White House counsel to President Nixon, who divulges more than he ever could under oath and sheds new light on the scandal. The docuseries begins with its first two hourlong episodes airing back-to-back tonight, and concludes with two episodes next Sunday, June 12.</p>
<p><strong>Billy the Kid: “Fate”<br />
EPIX, 9pm</strong><br />
Billy (Tom Blyth) bumps into a new character named Pat Garrett (Alex Roe), who is riding with Jesse (Daniel Webber) and the 7 Rivers Gang. Billy joins them, but lawmakers are already closing in. The gang plans to flee to Lincoln County, but not before Billy fulfills one last promise.</p>
<p><strong>The Great Food Truck Race<br />
Food Network, 9pm<br />
Season Premiere!</strong><br />
Each week, food truck teams roll into a new city and spend a frantic weekend competing to see which group can sell the most food. The last team standing wins the $50,000 grand prize. Hosted by Tyler Florence.</p>
<p><strong>Duncanville<br />
FOX, 9pm</strong><br />
Two new episodes of the animated comedy air tonight. In “Annie v. Fun,” Annie (voice of Amy Poehler) makes a stand against Teen Zone after she feels gouged by their prices. Then in “Throw Mamma From the Brain,” Duncan (also voiced by Poehler) sees Annie naked and visits a hypnotist to try to erase the image from his memory.</p>
<p><strong>Battle on the Beach<br />
HGTV, 9pm<br />
Season Premiere!</strong><br />
In the premiere episode, Taniya Nayak, Ty Pennington and Alison Victoria will guide their teams through a kitchen and dining room overhaul that will set the tone for each beachfront property’s transformation. Judges Bryan and Sarah Baeumler will be on hand to determine the winner.</p>
<p><strong>2022 MTV Movie &amp; TV Awards: UNSCRIPTED<br />
MTV, 10pm Live</strong><br />
The ceremony that celebrates all things reality television returns, featuring four new categories: Best Reality Return, Best Music Documentary, Best Reality Romance and Best Reality Star. <em>RuPaul’s Drag Race</em> leads this year’s nominees with four nods. TV host and multimedia personality Tayshia Adams (<em>The Bachelorette</em>) hosts the event, which will also be simulcast across several other linear cable channels in the Viacom family: BET, BET Her, CMT, Comedy Central, Logo, MTV2, Nick at Nite, Paramount Network, Pop, TV Land and VH1.</p>
<p><strong>Jurassic Greatest Moments: From “Jurassic Park” to “Jurassic World”<br />
NBC, 10pm</strong><br />
Ahead of this Friday’s theatrical release of <em>Jurassic World: Dominion</em>, this hourlong special takes a look back at the most memorable moments from the previous films in the <em>Jurassic Park</em> and <em>Jurassic World</em> franchises.</p>
<p><strong>Beachfront Bargain Hunt<br />
HGTV, 10:30pm<br />
Season Premiere!</strong><br />
Season 29 of the series about people searching for coastal homes debuts with “Renters Become Buyers in Ocean City, Maryland.” In it, a Philadelphia family looks for an affordable property in the waterfront paradise of Ocean City, Maryland, preferably one that overlooks the bay with room for a future boat.</p>
<p><strong>Ziwe<br />
Showtime, 11pm</strong><br />
In the midseason finale of her variety series, the comedian celebrates LGBTQ+ Pride Month with drag queen Katya Zamolodchikova and <em>Happy Endings </em>actor Adam Pally. Also, she learns how to vogue!</p>
<h3>Monday, June 6</h3>
<p><strong>London Kills<br />
Acorn TV<br />
Season Premiere!</strong><br />
The British police procedural returns for Season 3, again using its cutting-edge documentary style to dramatize the experiences of an elite murder investigation squad in central London. As the season opens, the detectives investigate the fatal stabbing of a young man. It soon becomes clear that his killer has access to confidential police intelligence; are they looking for one of their own? Detective Sergeant Vivienne Cole (Sharon Small) is forced to appeal to her ex-husband — a detective superintendent — for help, but he is murdered before he can pass on any information. When the team track down the killer, Cole is forced to face demons she buried long ago, and, as a result, she and Detective Inspector David Bradford (Hugo Speer) end up crossing a line. All five Season 3 episodes are available today.</p>
<p><strong>Bill Burr Presents: Friends Who Kill<br />
Netflix</strong><br />
In this special recorded during the Netflix Is a Joke comedy festival held in May, comedian Bill Burr curates a showcase of stand-up comics featuring Michelle Wolf, Jimmy Carr, Steph Tolev, Joe Bartnick, Jeff Ross, Dave Attell, Ian Edwards, Dean Delray, Jessica Kirson and Ronny Chieng.</p>
<p><strong>The Wonderful World of Disney: Brave<br />
ABC, 8pm</strong><br />
Merida, an impulsive young lady and daughter to King Fergus and Queen Elinor, is determined to carve her own path in life. Defying the age-old and sacred customs, Merida’s actions inadvertently unleash chaos and anger from the other Scottish lords, and in the process, she stumbles upon an eccentric and wise old woman who grants her ill-fated wish. The ensuing peril forces Merida to discover the true meaning of bravery in order to undo a beastly curse before it’s too late.</p>
<p><strong>Roswell, New Mexico<br />
The CW, 8pm<br />
Season Premiere!</strong><br />
Season 4 of the romantic sci-fi drama begins with scientist Liz (Jeanine Mason) happily teaching, and her alien love Max (Nathan Dean) consulting on a string of bank robberies. The CW announced that this will be the show&#8217;s final season.</p>
<p><strong>American Ninja Warrior<br />
NBC, 8pm<br />
Season Premiere!</strong><br />
The competition series returns for Season 14 with elite athletes competing on the world’s most difficult obstacle courses. Hosts Matt Iseman, Akbar Gbajabiamila and Zuri Hall are back to call the early-round action in San Antonio and Los Angeles, with the national finals in Las Vegas. The new season will mark the return of the lowered age requirement, which opens the door to competitors as young as 15 years old. A top prize of $1 million will go to the winner who can conquer all four stages at the National Finals in Las Vegas.</p>
<p><strong>Special Theme: LGBTQ Directors<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
June is Pride Month, and each Monday evening Turner Classic Movies will be airing lineups of movies directed by filmmakers who are/were gay, lesbian, bisexual or otherwise on the LGBTQ spectrum. Some worked during times when societal prejudices compelled them to hide their sexual identities, while others have been open and out, even during less-accepting eras. Many used their creative talents to depict rarely, if ever, seen stories of characters like themselves onscreen in sometimes open and groundbreaking, and sometimes more subtle, ways, while also bringing their unique perspectives and empathies to stories considered more mainstream. Tonight’s initial lineup features nine films from LGBTQ directors made during the 1930s, ’40s and ’50s: <em>Death Takes a Holiday</em> (1934, directed by Mitchell Leisen); <em>Dance, Girl, Dance</em> (1940, directed by Dorothy Arzner, with dance sequences choreographed by Arzner’s longtime partner, Marion Morgan); <em>In Which We Serve</em> (1942, written and codirected by Noël Coward, who earned an Oscar nomination for his screenplay); <em>Riptide</em> (1934, cowritten and directed by Edmund Goulding); <em>Waterloo Bridge</em> (1931, directed by James Whale); <em>The Women</em> (1939, directed by George Cukor); <em>Now, Voyager</em> (1942, directed by Irving Rapper); <em>Easy to Love</em> (1953, directed by Charles Walters); and <em>The Night of the Hunter</em> (1955, directed by Charles Laughton).</p>
<p><strong>The Family Chantel<br />
TLC, 8pm<br />
Season Premiere!</strong><br />
Five years into marriage, Chantel and Pedro have hit a rough patch. The only thing they can agree on is that they need to take serious steps to save their love. Nicole has made a clean break with Alejandro and is focusing on herself and her future. She’s even entered the Miss Dominican Republic pageant and is training hard until a surprise visit from Alejandro throws her off her game. Inspired by a success story she saw on social media, Winter is going through with bariatric weight loss surgery in Tijuana, Mexico. With newfound confidence, she’s also looking for new love post-Jah. River decides it’s time to leave the nest and turns to Pedro for support. Pedro’s relationship with his mother and sister is still strained, which isn’t helping the two families bury the hatchet after last season’s visit to the Dominican Republic. While Chantel and Pedro are struggling to save their marriage, will their families rally to support them or end up hammering the final nail in the coffin?</p>
<p><strong>In the Dark<br />
The CW, 9pm<br />
Season Premiere!</strong><br />
Murphy (Perry Mattfeld) has a tough time adjusting to life in prison in the Season 4 premiere &#8220;Ball&#8217;s in Your Court.&#8221; The CW announced that this will be the show&#8217;s final season.</p>
<p><strong>Irma Vep<br />
HBO, 9pm<br />
New Series!</strong><br />
In this lurid crime thriller, a disillusioned American actress (Alicia Vikander) goes to France to star in a remake of the silent film classic <em>Les Vampires</em>.</p>
<p><strong>People Magazine Investigates<br />
Investigation Discovery, 9pm; also streams on discovery+<br />
Season Premiere!</strong><br />
The two-hour Season 6 premiere of this true-crime docuseries uncovers the horrific triple murder and double kidnapping of the Groene family that rattled an idyllic lakefront community in Coeur D’Alene, Idaho.</p>
<p><strong>#TextMeWhenYouGetHome<br />
Lifetime, 9pm<br />
New Series!</strong><br />
A hashtag that became a viral, worldwide movement (and also the title of this series) following the 2021 death of Sarah Everard in the U.K. sparked global awareness, anger, and a conversation around the vulnerability and lack of safety women feel while in public alone. Each episode of this true-crime docuseries follows the case of an innocent woman who has been abducted, harmed or even murdered by someone on what was an otherwise average day in her life.</p>
<p><strong>Sleeping With a Killer<br />
Lifetime, 10pm<br />
New Series!</strong><br />
<em>Sleeping With a Killer</em> examines real-life cases where jealousy pushes individuals to do the unthinkable. The 26-episode U.K. docuseries (formerly known as <em>Green Eyed Killers</em>) focuses on ordinary people who have tragic endings at the hands of husbands, wives, former friends and lovers.</p>
<p><strong>Weakest Link: “Who Comes in Second When They Play Solitaire?”<br />
NBC, 10pm</strong><br />
A new episode of the Jane Lynch-hosted game show airs as the series moves into its new time slot beginning tonight.</p>
<p><strong>Seeking Sister Wife<br />
TLC, 10pm<br />
Season Premiere!</strong><br />
The new season will document the lives of five polygamous families as they navigate the challenges of actively searching for and courting potential new sister wives. Returning couple Dannielle and Garrick Merrifield are still waiting for Roberta to join them in Colorado while Sidian and Tosha Jones are long-distance dating potential Filipino sister wife Arielle. Newcomers Steve and Brenda Foley have decided to begin their polygamist journey again and this time with a much younger potential sister wife. Nick, April and Jennifer Davis live a polygamous relationship with a twist; although the women consider themselves to both be Nick’s wives, April and Jennifer are legally married to each other, but have taken Nick’s last name to solidify their family unit. They hope to expand their family and are courting a potential third sister wife. Lastly, the Epps family, Marcus, Taryn and India, are a plural family actively seeking another wife to join their group, but they have to overcome some growing pains.</p>
<p><strong>Miz &amp; Mrs<br />
USA Network, beginning at 11pm<br />
Season Premiere!</strong><br />
The reality series returns for Season 3. It offers a glimpse into the life of married WWE superstars Mike “The Miz” Mizanin and Maryse Mizanin as they balance their careers with family life, including raising two toddlers. In the season premiere, Mike wrestles with making a decision when he gets an unexpected opportunity to do <em>Dancing With the Stars</em>, while Maryse deals with the aftermath of ousting her mother, Marjo, from their house. Two back-to-back half-hour episodes air tonight.</p>
<h3>Tuesday, June 7</h3>
<p><strong>The Barking Murders<br />
BritBox<br />
U.S. Exclusive Series!</strong><br />
This three-part drama sheds light on the crimes of Stephen Port (portrayed by Stephen Merchant), who murdered four young gay men in London. The series focuses on the victims’ loved ones, who tirelessly fought to uncover the truth, and the investigation that finally brought a dangerous killer to justice. It also goes beneath the headlines to deliver a new perspective on the story, revealing missed opportunities by the police and looking at the devastating impact these crimes had on both the victims’ loved ones and on the wider gay community in London.</p>
<p><strong>That’s My Time With David Letterman<br />
Netflix</strong><br />
This is the first of six specials recorded at May’s Netflix Is a Joke comedy festival in which David Letterman invites some of the hottest up-and-coming stand-up artists to perform a five-minute set and then sit down for a chat. Each installment will spotlight one comedian; featured performers are Rosebud Baker, Phil Wang, Sam Morril, Brian Simpson, Robin Tran and Naomi Ekperigin.</p>
<p><strong>Treasure Island<br />
MOVIES!, 6am<br />
Catch a Classic!</strong><br />
This 1934 production was the first sound film adaptation of Robert Louis Stevenson’s classic 1883 adventure novel set on the swashbuckling high seas of the mid 18th century, and it remains one of the most impressively thrilling takes on the story. Jackie Cooper stars as young Jim Hawkins, whose discovery of a treasure map leads him to a group of pirates and a voyage to the titular island filled with hidden riches, unaware that the buccaneers’ captain, Long John Silver (Wallace Beery), plans to steal the loot for himself after it is found. Victor Fleming directed the film, which also stars Lionel Barrymore, Lewis Stone and Nigel Bruce.</p>
<p><strong>Life Below Zero: First Alaskans: “In Perfect Balance”<br />
Nat Geo, 8pm</strong><br />
During an extremely harsh winter, the Indigenous peoples of Alaska work hard to endure. Marvin collects sea urchins during a minus tide; Daniel and Chase search for driftwood along the coast to provide heat for their new garage; Jody combats the severe winter weather in order to complete her daily chores; and Tig and Louise are on the hunt for a bull moose to fill their freezer and feed their family.</p>
<p><strong>America’s Got Talent: “Auditions 2”<br />
NBC, 8pm</strong><br />
The auditions continue with creator and executive producer Simon Cowell at the judges’ table along with Heidi Klum, Howie Mandel, Sofia Vergara and host Terry Crews. Variety acts featuring contestants of all ages audition for the chance to win the $1 million prize. The Golden Buzzer is back, allowing a lucky act the chance to go directly to the live shows to compete for America’s vote.</p>
<p><strong>All Rise<br />
OWN, 8pm<br />
Season Premiere!</strong><br />
After being canceled at CBS, legal drama <em>All Rise</em> now moves to a new network. The season premiere picks up six months after the events of the sophomore finale and will bring about new beginnings for these judges, prosecutors and public defenders. We return on election night as Judge Lola Carmichael (Simone Missick) awaits the results of her campaign; Emily (Jessica Camacho) returns from Puerto Rico with renewed drive and purpose about her career; and Luke (J. Alex Brinson) continues to shake things up through his work in the public defender’s office.</p>
<p><strong>Dateline: Unforgettable<br />
Oxygen, 8pm<br />
Season Premiere!</strong><br />
Correspondents of NBC’s <em>Dateline</em> choose more memorable stories and explain what makes them so hard to forget in Season 2 of this docuseries.</p>
<p><strong>MLB Baseball: L.A. Dodgers at Chicago White Sox<br />
TBS, 8pm Live</strong><br />
Freddie Freeman leads the L.A. Dodgers against Tim Anderson and the Chicago White Sox to start a three-game set at Guaranteed Rate Field.</p>
<p><strong>The Chase: “When They Go Low, She Goes Highness”<br />
ABC, 9pm</strong><br />
Victoria “The Queen” Groce makes her return as the featured chaser. She faces a professor, chemical engineer and debate coach in a trivia battle.</p>
<p><strong>Dancing With Myself: “Better When We’re Dancing”<br />
NBC, 10pm</strong><br />
A grandma, an active-duty serviceman, a video game creator and nine other contestants enter the <em>Dancing With Myself</em> pods to battle it out over six dance challenges set by celebrity creators Shakira, Nick Jonas and Liza Koshy. Camille Kostek hosts.</p>
<h3>Wednesday, June 8</h3>
<p><strong>Hungry for Answers<br />
discovery+<br />
New Series!</strong><br />
Scholar, restaurateur and cookbook author Caroline Randall Williams hosts this food show that ambitiously strives to serve up a healthy dose of history with each delicious bite and sip that are explored. Over four episodes, Williams travels the country unraveling fascinating, essential and often untold Black stories behind some of America’s classic and emblematic food and spirits. From the spicy, crisp flavors of Nashville hot chicken to the warm, dulcet taste of Tennessee whiskey, Williams is out to uncover the origin stories of these quintessential American offerings, as well as surface the truth when it comes to the equity — or, in most cases, inequity — regarding the recognition and reward, or lack thereof, for the true founding contributors throughout history. All four episodes are available today.</p>
<p><strong>Ms. Marvel<br />
Disney+<br />
New Series!</strong><br />
This latest small-screen live-action entry in the Marvel Cinematic Universe (MCU) follows Kamala Khan, a relatively new (making her first appearance in 2013) but popular Marvel Comics character who was the first Muslim superhero to headline a comic book at the company, taking on the mantle of Ms. Marvel. In the six-episode series, Iman Vellani portrays Kamala, a 16-year-old Pakistani American growing up in Jersey City. A great student and voracious fan-fiction scribe with an oversized imagination, she has a special affinity for superheroes, particularly Captain Marvel, but struggles to fit in at home and at school — that is, until she gets superpowers of her own. Life should be easier as a superhero, right? Aramis Knight portrays a young man named Kareem, aka Red Dagger, a vigilante crime-fighter who in the comics has a romantic connection with Kamala. Beyond its stand-alone action, this series will also be setting up the MCU’s big-screen <em>Captain Marvel</em> sequel <em>The Marvels</em>, which is slated to hit theaters next summer, with Vellani reprising her Kamala Khan/Ms. Marvel role alongside Brie Larson’s Carol Danvers/Captain Marvel. New episodes are available Wednesdays.</p>
<p><strong>Baby Fever<br />
Netflix<br />
New Series!</strong><br />
This Danish romantic dramedy centers around Nana (Josephine Park), a fertility doctor, and the clients she meets and treats … and lies to. While drunk, Nana inseminates herself with her ex-boyfriend’s sperm and begins a chain reaction of catastrophes big and small. Her rash move leads to pregnancy, and Nana now has to figure out how to eventually explain her condition and win back her ex, who doesn’t seem interested in getting back with her.</p>
<p><strong>Hustle<br />
Netflix<br />
Original Film!</strong><br />
Adam Sandler’s latest starring role in a Netflix original film comes in this sports drama in which he plays down-on-his-luck basketball scout Stanley Sugarman. After discovering Bo Cruz (Juancho Hernangómez), a once-in-a-lifetime player with a rocky past, while traveling abroad, Stanley takes it upon himself to bring the phenom to the States without his team’s approval. Against the odds, Stanley and Bo have one final shot to prove they have what it takes to make it in the NBA. Queen Latifah, Ben Foster and Robert Duvall also star.</p>
<p><strong>“Thin Man” MOVIES!<br />
MOVIES!, beginning at 3:30pm<br />
Catch a Classic!</strong><br />
Spend your late afternoon and evening with Nick and Nora Charles (William Powell and Myrna Loy) — the witty, hard-drinking, fun-loving, high-society couple who often find themselves embroiled in solving mysteries — and their lovable dog Asta in this lineup featuring all six of the classic comedy/mystery <em>Thin Man </em>films, beginning with the 1934 original, <em>The Thin Man</em>. The marathon also includes <em>After the Thin Man</em> (1936), <em>Another Thin Man</em> (1939), <em>Shadow of the Thin</em> <em>Man</em> (1941), <em>The Thin Man Goes Home</em> (1944) and <em>Song of the Thin Man</em> (1947).</p>
<p><strong>Let’s Make a Deal Primetime<br />
CBS, 8pm</strong><br />
Wayne Brady hosts this primetime edition of the game show featuring a costume extravaganza and over $500,000 in cash and prizes up for grabs.</p>
<p><strong>The Flash<br />
The CW, 8pm</strong><br />
Series star Danielle Panabaker directs what showrunner Eric Wallace calls “an intense episode.” The electromagnetic-powered Allegra (Kayla Compton) “literally saves the day on her own,” while Barry (Grant Gustin) is out of town chasing down another meta.</p>
<p><strong>MasterChef: Back to Win: “Audition Battles (Part 3)”<br />
FOX, 8pm</strong><br />
With only six aprons left, the judges round out auditions and give a lucky few chefs a chance to return to the kitchen in the new episode “Audition Battles (Part 3).”</p>
<p><strong>Married at First Sight: Rules of Marriage<br />
Lifetime, 8pm</strong><br />
In this two-hour special episode, hosts Briana Myles Morales and Beth Bice explore the do’s and don’ts of having a successful marriage by reflecting on unforgettable highlights and lowlights from the first 14 seasons of <em>Married at First Sight</em>.</p>
<p><strong>Into the Wild New Zealand: “Untamed West”<br />
Smithsonian Channel, 8pm</strong><br />
See what it takes to survive the unique environmental conditions on the West Coast of New Zealand’s South Island. From alpine parrots to shy penguins to stealth geckos, discover the wildlife hiding out by the towering mountains, rainforests and rough seas of New Zealand’s West Coast.</p>
<p><strong>NBA Finals: Game 3: Golden State at Boston<br />
ABC, 9pm Live</strong><br />
The best-of-seven-game NBA Finals series shifts to Boston as the Celtics face the Golden State Warriors in Game 3 tonight on ABC.</p>
<p><strong>So You Think You Can Dance: “The Big Cut — Choreography Round”<br />
FOX, 9pm</strong><br />
The fourth week of auditions continues as some dancers move forward to the choreography round and some go home in the new episode “The Big Cut — Choreography Round.”</p>
<p><strong>The Janes<br />
HBO, 9pm; also streams on HBO Max</strong><br />
In the spring of 1972, police raided an apartment on the South Side of Chicago, where seven women who were part of a clandestine network were arrested. Using code names, fronts and safe houses to protect themselves and their work, the accused had built an underground network for women seeking safe, affordable, illegal abortions. They called themselves “Jane.” Offering firsthand accounts from the women at the center of the group, many speaking on the record for the first time, <em>The Janes</em> tells the revelatory story of a group of unlikely outlaws. Defying the state legislature that outlawed abortion, the Catholic Church that condemned it and the Chicago Mob that was profiting from it, the members of “Jane” risked their personal and professional lives to support women with unwanted pregnancies. The film is directed by Oscar nominee Tia Lessin (<em>Trouble the Water</em>) and Emmy nominee Emma Pildes (<em>Jane Fonda in Five Acts</em>).</p>
<p><strong>Bargain Block<br />
HGTV, 9pm<br />
Season Premiere!</strong><br />
Home-renovation experts/couple Keith Bynum and Evan Thomas tackle their next round of run-down houses in Detroit. First up, two homes that are next door to each other get remodels inspired by a Hamptons cottage<br />
and the Art Deco decadence of <em>The Great Gatsby</em>.</p>
<p><strong>Forged in Fire: “Sergeant Hayden’s Sword” &amp; “Championship Polearms”<br />
History, beginning at 9pm</strong><br />
Two back-to-back hourlong episodes of the competition series air tonight. First, in “Sergeant Hayden’s Sword,” four smiths are given only a small sliver of high-carbon steel and a whole lot of mild steel to forge a knife. After their knives are tested, the two surviving smiths return home to re-create a sword credited with helping win a war: Sgt. William Hayden’s sword. Then, in “Championship Polearms,” judge Dave Baker revisits five of the most intense championship rounds featuring the top polearms to come out of the forge.</p>
<p><strong>The Deep End<br />
Freeform, 10pm<br />
Season Finale!</strong><br />
For three years, cameras followed controversial spiritual leader and wellness guru Teal Swan, whose unconventional methods claim to heal psychological ailments. In the conclusion of this four-part docuseries scrutinizing her practice, new revelations fracture her inner circle.</p>
<p><strong>Buy It or Build It: “A Home in One”<br />
HGTV, 10pm</strong><br />
Two fashionable newlyweds looking for their dream home call on Chris and Calvin LaMont to help them find it. While Chris has in mind an enormous older home that’s loaded with potential, Calvin thinks his sweet lot could accommodate their lengthy wish list.</p>
<h3>Thursday, June 9</h3>
<p><strong>American Gangster: Trap Queens<br />
BET+<br />
New Episodes!</strong><br />
Season 3 of the docuseries narrated by Lil’ Kim returns with five all-new episodes. <em>Trap Queens</em> offers epic, tragic and significant cautionary tales of women who were seduced by the allure of the underworld to become ultimate crime bosses.</p>
<p><strong>The Book of Queer: “Sashay It Forward”<br />
discovery+</strong><br />
Actor/comedian Margaret Cho narrates this episode that features stories about Leonardo da Vinci, Michelangelo, Ma Rainey, Alan Turing, Sally Ride and Lynn Conway.</p>
<p><strong>Dr. Delirium &amp; the Edgewood Experiments<br />
discovery+</strong><br />
From 1955 to 1975, the U.S. Army Chemical Corps conducted classified human subject research on thousands of soldiers at the Edgewood Arsenal facility in Maryland. The purpose was to evaluate the impact of potent, mind-altering chemical warfare agents on military personnel as an alternative to traditional mortal combat. Today, many of these soldiers believe that the military broke the law and engaged in a decades-long coverup to hide the truth about what really happened to them at Edgewood. Through shocking, never-before-seen footage of the drug experiments, along with exclusive, firsthand accounts from both the mastermind behind the research and the soldiers who participated in it, this documentary seeks to uncover the true story.</p>
<p><strong>My Daughter Joined a Cult<br />
discovery+<br />
New Series!</strong><br />
This series charts the rise, fall and alleged crimes of controversial cult leader Nithyananda through the eyes of abused survivors, former devotees and a father trying to save his daughter from the cult’s clutches.</p>
<p><strong>Undiscovered: Finding Amelia<br />
discovery+</strong><br />
It is one of the greatest unsolved mysteries in American history: Amelia Earhart’s 1937 disappearance while attempting to be the first woman to fly around the world. Credible theories remain unproven, and decades of searching have turned up nothing. But now, a team says it has irrefutable evidence pointing to Earhart’s final resting place and is launching an expedition to finally bring her home.</p>
<p><strong>Legendary<br />
HBO Max<br />
Season Finale!</strong><br />
The 10-episode third season comes to an end. The series brings ballroom’s ever-influential culture to a global stage, following fabulously talented voguing houses as they ignite the runway at extravagant balls showcasing their skill, style and stamina for a shot at the $100,000 grand prize. Multi-award-winning actress and singer Keke Palmer and MC/host Dashaun Wesley, along with judges Leiomy Maldonado, Jameela Jamil and Law Roach, will crown another “Legendary” house.</p>
<p><strong>Roadrunner: A Film About Anthony Bourdain<br />
HBO Max</strong><br />
Morgan Neville directed this documentary that follows the life and journey of cultural explorer, writer and chef Anthony Bourdain, highlighting his transformation from line cook to a celebrated globe-trotter and renowned television host.</p>
<p><strong>Rhythm + Flow France<br />
Netflix<br />
New Series!</strong><br />
In this music competition series, French-speaking rap stars Niska (Paris), Shay (Brussels) and SCH (Marseille) seek breakout talent in their local towns. Aspiring artists will explore everything from freestyling to rap battles, and making a music video to writing and producing an original track, in pursuit of their dreams and a 100,000-euro prize. New episodes are available weekly.</p>
<p><strong>Stand Out: An LGBTQ+ Celebration<br />
Netflix</strong><br />
One of the many comedy shows that Netflix taped at this year’s nearly two-week-long Netflix Is a Joke: The Festival celebration in April and May, this special promises to cover the largest ever gathering of LGBTQ+ comics. Headliners at the event included Eddie Izzard, Margaret Cho, Sandra Bernhard, Tig Notaro and Wanda Sykes.</p>
<p><strong>Queer as Folk<br />
Peacock<br />
New Series!</strong><br />
This drama is a vibrant reimagining of the groundbreaking 1999-2000 British TV series that was also remade in America with a Showtime series that ran from 2000-05. This latest incarnation explores a diverse group of friends in New Orleans whose lives are transformed in the aftermath of a tragedy. Devin Way, Fin Argus, Jesse James Keitel, CG, Johnny Sibilly and Ryan O’Connell lead the cast. Guest stars will include Kim Cattrall, Juliette Lewis and Ed Begley Jr., among others. Creator/executive producer/writer/director Stephen Dunn says that New Orleans was chosen as the setting for this revival because it features “one of the most unique queer communities in North America. … I am immensely proud that the new series is comprised of an electric ensemble of fresh characters that mirror the global audience. If there’s one person who is able to see <em>Queer as Folk</em> and feel less alone … our job is done. … I am honored that Russell T. Davies, the creator of the original series, entrusted me to continue this legacy.” For his part, Davies says, “I am very proud of what we achieved in 1999, but in queer years, that was a millennium ago! As a community, we’ve radicalized, explored, opened up and found new worlds … and there was so much to be said. Stephen pitched a brand-new version of <em>Queer as Folk</em> with so much imagination, insight and, crucially, joy that I simply couldn’t resist. I thought it was about time the title belonged to a whole new generation.”</p>
<p><strong>Backstage With Katherine Ryan<br />
Prime Video<br />
New Series!</strong><br />
This series blends world-class stand-up comedy with behind-the-scenes access as host Katherine Ryan invites both the biggest and the most exciting new names from the world of comedy to perform onstage and hang out backstage at London’s famed Roundhouse venue. All six episodes are available today.</p>
<p><strong>MasterChef: Junior Edition: “The Semi-Final”<br />
FOX, 8pm</strong><br />
The three remaining young chefs must compete in front of a live audience, and they’ll face added pressure from a surprise visit by their loved ones in the new episode “The Semi-Final.” The chefs have one hour to prepare a dish inspired by their families for each judge, but only two chefs will move on to the finale.</p>
<p><strong>TCM Spotlight: Revisionist Westerns: “Sam Peckinpah”<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Tonight’s look at classic Revisionist Westerns presents a lineup of four films from one of the pioneers of that film subgenre: director Sam Peckinpah, whose visually innovative and explicit depictions of action and violence, and unconventional characters and storytelling, heralded the beginning of a new era for movies as a whole, and especially for Westerns. The evening starts with Peckinpah’s second film, <em>Ride the High Country</em> (1962), led by Randolph Scott and Joel McCrea, which was particularly unusual for its time. Because of that, it is perhaps not surprising that it was pretty much ignored in the United States at the time of its release. It did become a success in Europe, however, and foreign critics appreciated Peckinpah’s reworking of the Western genre. It has since become regarded as one of his finest works. Following that is <em>The Ballad of Cable Hogue</em> (1970), starring Jason Robards and Stella Stevens, which not only subverts Western archetypes but also traditional expectations from a Peckinpah film, with its almost comedic tale featuring little violence. Up next is perhaps one of Peckinpah’s most familiar works, 1969’s <em>The Wild Bunch</em>, which <em>does</em> notoriously contain plenty of violence. William Holden, Ernest Borgnine, Robert Ryan and Edmond O’Brien headline the cast of the movie, which earned Peckinpah a shared Oscar nomination for his screenplay cowritten with Walon Green and Roy N. Sickner. Tonight’s final Peckinpah film is <em>Pat Garrett and Billy the Kid</em> (1973), which follows aging Old West lawman Garrett (James Coburn), who is hired to bring down outlaw — and his old friend — Billy the Kid (Kris Kristofferson in one of his earlier film acting roles). Among the things that make this movie stand out among Westerns is its musical score and songs composed by Bob Dylan; the soundtrack earned a Grammy nomination and introduced the classic Dylan tune “Knockin’ on Heaven’s Door.”</p>
<p><strong>Heartland: “Sins of a Father”<br />
UPtv, 8pm</strong><br />
After a break-in at Heartland, unwelcome memories of his father flood Jack (Shaun Johnston); Amy (Amber Marshall) and Logan (Drew Davis) work with a wild horse; and Tim (Chris Potter) and Parker (Ava Tran) form an unlikely duo to find the stolen goods.</p>
<p><strong>Windy City Rehab: “Suburban Stunner”<br />
HGTV, 9pm</strong><br />
Alison Victoria helps a Chicago family navigate the city’s tough building codes and materials shortages as she turns their outdated home into a suburban stunner that is sure to become the envy of the whole neighborhood.</p>
<p><strong>Alone: “The Law of the Land”<br />
History, 9pm</strong><br />
As Labrador’s winter draws near, the participants split their time between building their permanent shelters and getting food to replenish their burned calories. While some start to settle in, many participants struggle, as one allows an opportunity to slip through their fingers, one braces for a deadly encounter, and another comes to grips with true survival.</p>
<p><strong>Rat in the Kitchen<br />
TBS, 9pm</strong><br />
The competing cooks try to guess who among them is sabotaging the vegetarian dishes chef Ludo Lefebvre and host Natasha Leggero request for this week’s challenge. Side of paranoia guaranteed.</p>
<p><strong>Mystic: “The Sacrifice”<br />
UPtv, 9pm</strong><br />
At the stables’ Family Fun Day, the kids compete with rival Dulmoth Park. Meanwhile, when Issie’s (Macey Chipping) visions become hard to ignore, her reckless behavior endangers her future at the stables.</p>
<p><strong>Brat Loves Judy<br />
WE tv, 9pm<br />
Season Premiere!</strong><br />
The docuseries following iconic rapper and <em>Growing Up Hip Hop: Atlanta</em> star Da Brat and her girlfriend Jesseca “Judy” Dupart returns for a second season as the couple continue to forge their own path while maintaining a strong partnership.</p>
<p><strong>Kings of Pain: “Big Biting Lizards”<br />
History, 10:35pm</strong><br />
Adam and Caveman Rob get bitten by one lizard whose venom — but not its ability to latch on and tear flesh — is in doubt, and another whose venom is notoriously painful. The shocking results set new records for the Pain Index.</p>
<h3>Friday, June 10</h3>
<p><strong>Hollywood Houselift With Jeff Lewis<br />
Amazon Freevee<br />
New Series!</strong><br />
Renowned house flipper and interior designer Jeff Lewis is back in this new series that follows him as he helps some of Hollywood’s most familiar faces transform their spaces. Celebrity clients featured in Season 1 include Anthony Anderson, Fortune Feimster, Lamorne Morris, Roselyn Sanchez, Mira Sorvino and Wilmer Valderrama. The first three episodes are available today; subsequent new episodes are available Fridays.</p>
<p><strong>For All Mankind<br />
Apple TV+<br />
Season Premiere!</strong><br />
The sci-fi drama set in an alternate history in which the Soviet Union beat the U.S. in the space race to the moon makes another giant leap in its 10-episode third season. The new season flashes ahead to the 1990s and the race to set foot on Mars. Apple TV+ says the U.S. and Soviet Union’s Red Planet plans will be challenged by “an unexpected new entrant with a lot to prove and even more at stake.” Edi Gathegi joins the regular cast, alongside returning stars Joel Kinnaman, Shantel VanSanten, Jodi Balfour, Sonya Walger, Krys Marshall, Coral Peña and Wrenn Schmidt.</p>
<p><strong>Lovely Little Farm<br />
Apple TV+<br />
New Series!</strong><br />
In this live-action/animated hybrid series for kids and families from the producer of <em>Teletubbies</em>, sisters Jill (Levi Howden) and Jacky (Kassidi Roberts) love and nurture all the animals on their farm nestled in lavender fields. Being a young farmer isn’t easy, but every day brings these siblings adventure and a chance to grow. Helping bring those adventures to life is computer-generated technology courtesy of the special effects wizards at Industrial Light &amp; Magic. The series has also partnered with Dr. Gail Melson, a leader in the field of human-animal interaction, who worked with the executive producers to develop the show based on her research into children’s relationships with animals, nature and emerging technologies.</p>
<p><strong>90 Day Fiancé: Love in Paradise<br />
discovery+<br />
Season Premiere!</strong><br />
Season 2 of the reality series follows three new and two returning couples with so much at stake, they risk more than just a broken heart as they put their relationships with family and friends on the line. The season includes not only brand-new sultry locations, but also two LGBTQ+ couples, a first for the <em>90 Day</em> franchise.</p>
<p><strong>Beyond Infinity: Buzz and the Journey to “Lightyear”<br />
Disney+</strong><br />
Ahead of the latest Disney/Pixar feature film release, <em>Lightyear</em>, which hits theaters next Friday, June 17, this special explores the evolution of Buzz Lightyear from toy to human in the making of the movie. Dive into the origin and cultural impact of the Space Ranger, the art of designing a new “human Buzz” and the challenges faced by the <em>Lightyear</em> crew along the way.</p>
<p><strong>The Card Counter<br />
HBO Max<br />
Feature Film Exclusive!</strong><br />
Oscar Isaac, Tiffany Haddish, Tye Sheridan and Willem Dafoe lead this crime drama/revenge thriller written and directed by Paul Schrader and executive produced by Martin Scorsese. It tells the story of an ex-military interrogator turned gambler haunted by the ghosts of his past decisions.</p>
<p><strong>Dirty Daddy: The Bob Saget Tribute<br />
Netflix</strong><br />
Recorded in May at the Netflix Is a Joke comedy festival, this special finds Bob Saget’s friends and family celebrating his life in comedy.</p>
<p><strong>First Kill<br />
Netflix<br />
New Series!</strong><br />
Based on the short story by Victoria “V.E.” Schwab, who is also a writer and executive producer, this drama begins when it becomes time for teenage vampire Juliette (Sarah Catherine Hook) to make her first kill so she can take her place among a powerful vampire family. She sets her sights on a new girl in town named Calliope (Imani Lewis). But much to Juliette’s surprise, Calliope is a vampire hunter from a family of celebrated slayers. Both find that the other won’t be so easy to kill and, unfortunately, way too easy to fall for. Elizabeth Mitchell and Aubin Wise also star.</p>
<p><strong>Peaky Blinders<br />
Netflix<br />
Season Premiere!</strong><br />
The final season of the British gangster drama set in Birmingham, England, circa the 1910s, ’20s and ’30s will be missing Helen McCrory, who played Aunt Polly, after the actress tragically died of cancer in April 2021. Season 6 does a deep dive into the soul of gang leader Tommy Shelby (Cillian Murphy) and explores how far he has to go before he can get out of the criminal life. Tom Hardy, Stephen Graham, Natasha O’Keeffe, Paul Anderson, Sophie Rundle, Finn Cole, Sam Claflin and Anya Taylor-Joy costar.</p>
<p><strong>Fairfax<br />
Prime Video<br />
Season Premiere!</strong><br />
The adult animated comedy returns, with all eight Season 2 episodes available today. The series follows the misadventures of four middle schoolers looking to earn their place in the culture. Guest voices this season include Billy Porter, Zoey Deutch, Yvette Nicole Brown, Guy Fieri and John Leguizamo, among others.</p>
<p><strong>Offseason<br />
Shudder<br />
Exclusive Film!</strong><br />
In this horror film, upon receiving a mysterious letter that her mother’s grave site has been vandalized, Marie (Jocelin Donahue) quickly returns to the isolated offshore island where her late mother is buried. When she arrives, she discovers that the island is closing for the offseason, with the bridges raised until spring and leaving her stranded. With one strange interaction with the local townspeople after another, Marie soon realizes that something is not quite right in this small town. She must unveil the mystery behind her mother’s troubled past in order to make it out alive.</p>
<p><strong>Ten Percent<br />
Sundance Now<br />
Season Finale!</strong><br />
In the first-season finale of the British comedy, personal pressures reach a boiling point, while professionally, the American boss plans to visit London, where a high-profile client is expected to be landing a massive franchise role. David Harewood guest-stars.</p>
<p><strong>Star of the Month: Judy Garland (100th Birthday)<br />
TCM, beginning at 6am<br />
Catch a Classic!</strong><br />
In commemoration of what would have been singing/acting legend Judy Garland’s 100th birthday (she was born Frances Ethel Gumm in Grand Rapids, Minnesota, on June 10, 1922; she died in London on June 22, 1969, at age 47), Turner Classic Movies is supersizing its Friday June salute to the star with a 24-hour lineup of 12 films. Today’s schedule features, in order: <em>Little Nellie Kelly</em> (1940); <em>Ziegfeld Girl</em> (1941); <em>Presenting Lily Mars</em> (1943); <em>Girl Crazy</em> (1943); <em>For Me and My Gal</em> (1942); <em>The Pirate</em> (1948); <em>In the Good Old Summertime</em> (1949); <em>The Wizard of Oz </em>(1939); <em>The Wonderful Wizard of Oz: 50 Years of Magic</em> (1990), a documentary about the making of <em>The Wizard of Oz</em>; <em>Meet Me in St. Louis</em> (1944); <em>The Clock</em> (1945); and <em>Judgment at Nuremberg</em> (1961).</p>
<p><strong>Charmed<br />
CW, 8pm<br />
Series Finale!</strong><br />
In the final episode of the drama about witches, “The End Is Never the End,” Mel (Melonie Diaz), Maggie (Sarah Jeffery) and Kaela (Lucy Barrett) must fight a cabal of foes coalescing to bring down the Power of Three. The battle finds them up against an ancient evil that has been dormant since the dawn of magic. This powerful dark force — the Lost One — will be the ultimate test of the strength of the newly discovered sisterhood, forcing them to rekindle their connection, or face the destruction of magic itself.</p>
<p><strong>Couples Therapy<br />
Showtime, 8pm<br />
Season Finale!</strong><br />
The docuseries that gives viewers an authentic look at weekly therapy sessions closes out Season 3, as Dr. Orna Guralnik guides couples through honest confrontation with each other about real-life struggles.</p>
<p><strong>The Wedding Planners: “Champagne Dreams, Beer Budget” &amp; “Big Italian Wedding”<br />
UPtv, beginning at 8pm</strong><br />
In “Champagne Dreams, Beer Budget,” Hannah (Madeline Leon) and James (Michael Seater) guide a sweet but impractical young couple through making their budget wedding dreams come true, while Paige (Kimberly-Sue Murray), conflicted about an offer to buy the business, realizes that wedding planning is going to the dogs. Then, in “Big Italian Wedding,” James and Hannah back a bride and groom caught between their own wedding vision and family traditions, as Paige runs point at the Hartbridge Bridal Show and scrambles for new business.</p>
<p><strong>Gold Rush: Dave Turin’s Lost Mine<br />
Discovery Channel, 9pm</strong><br />
Hardscrabble gold miner Dave Turin and his team arrive at their new Glacier Creek claim in Alaska, where dig rigors include aging local machinery (their newer equipment is stuck in transit). Rookie miner Andrew Stefalo gets the chance to test his mettle.</p>
<p><strong>Guy’s All-American Road Trip<br />
Food Network, 9pm</strong><br />
Guy Fieri’s caravan journey through the Pacific Northwest continues. Tonight’s itinerary includes family vs. family mini golf and go-karting and plenty of meal breaks: crab and cod fresh from the water, a ceviche celebration, a Chinese feast and a rainy-day chili.</p>
<p><strong>A Tiny Audience<br />
HBO Latino, 9:30pm; also streams on HBO Max<br />
Season Finale!</strong><br />
Season 3 of the music series concludes with a tribute to legendary Cuban American singer Celia Cruz. Jon Secada, Silvestre Dangond, Alejandra Guzmán and Cimafunk celebrate Cruz’s musical legacy by putting their personal spins on “Guantanamera,” “Te Busco,” “La Negra Tiene Tumbao” and “Pa’ La Paloma.”</p>
<p><strong>The Great Soul Food Cook-Off<br />
OWN, 10pm<br />
Season Finale!</strong><br />
The final three chefs have three hours to prepare a four-course meal, but one of them doesn’t have a prayer &#8230; despite a very memorable blessing from judge Melba Wilson.</p>
<h3>Saturday, June 11</h3>
<p><strong>Amy Schumer’s Parental Advisory<br />
Netflix</strong><br />
This showcase of stand-up comedians is curated by Amy Schumer and was recorded during May’s Netflix Is a Joke comedy festival. Featured performers are Lil Rel Howery, Chris Distefano, Christina P, Ron Funches, Rachel Feinstein and Jaye McBride.</p>
<p><strong>“E.T. the Extra-Terrestrial” 40th Anniversary Marathon<br />
Syfy, beginning at 1pm<br />
Catch a Classic!</strong><br />
Forty years ago today, on June 11, 1982, Steven Spielberg’s Best Picture Oscar-nominated <em>E.T. the Extra-Terrestrial</em> made its debut in theaters and became an instant blockbuster, surpassing <em>Star Wars</em> to become, at the time, the highest-grossing film in history (it’s still currently at No. 24 among the highest-grossing U.S. releases ever). The charming, exciting and emotional tale about a boy (Henry Thomas) who befriends a stranded alien and helps him find a way back home while avoiding the pursuit of government agents and scientists won plenty of hearts and four Academy Awards, including ones for its visual effects by Carlo Rambaldi, Dennis Muren and Kenneth Smith that brought E.T. to life, and its stirring musical score by John Williams. Thanks to Melissa Mathison’s Oscar-nominated screenplay, and Best Director nominee Spielberg’s ability to solicit wonderful performances from his child stars — including Robert MacNaughton and a 6-year-old Drew Barrymore along with Thomas — <em>E.T.</em> has endured as a classic whose magic not even an infamous 1982 Atari 2600 video game adaptation nor an ill-advised 20th anniversary “special edition” release of the film in 2002 could tarnish. If you want to experience or reexperience that magic, kick back and open up a bag of Reese’s Pieces as Syfy offers four consecutive airings of the movie starting this afternoon and into the later evening (this marathon will be followed by a broadcast of 1996’s <em>Independence Day</em>, for those of you who prefer your cinematic extraterrestrials a little more mean-spirited). <em>— Jeff Pfeiffer</em></p>
<p><strong>MLB Baseball<br />
FS1 &amp; FOX, beginning at 4pm Live</strong><br />
FS1 airs the Oakland A’s at the Cleveland Guardians, followed by regional MLB action on FOX with either the Chicago Cubs at the N.Y. Yankees or the L.A. Dodgers at the San Francisco Giants.</p>
<p><strong>Horse Racing: Belmont Stakes<br />
NBC, 5pm Live</strong><br />
Can lightning strike twice for Kentucky Derby winner Rich Strike? The 154th Belmont Stakes takes place today at Belmont Park in Elmont, New York.</p>
<p><strong>Murdoch Mysteries: “Brother Can You Spare a Crime” &amp; “Pendrick’s Planetary Parlor”<br />
Ovation, beginning at 7pm</strong><br />
In “Brother Can You Spare a Crime,” Murdoch (Yannick Bisson) suspects someone in a vagrant encampment robbed and killed a young woman. Then, in “Pendrick’s Planetary Parlor,” Murdoch investigates after a murder is transmitted over James Pendrick’s (Peter Stebbings) new invention.</p>
<p><strong>Planet Earth: Dynasties II: “Hyena”<br />
BBC America, 8pm</strong><br />
A clan of hyenas must pull together to survive on the plains of Zambia in the new episode “Hyena.” The clan will need to hold onto its seemingly desolate territory until the wildebeest return.</p>
<p><strong>Caribbean Summer<br />
Hallmark Channel, 8pm<br />
Original Film!</strong><br />
Jade (Heather Hemmens), a morning news producer, is forced to take a vacation after an embarrassing gaffe during a live broadcast. She arrives to a relaxing Caribbean island, but Jade’s trip gets off to a rocky start thanks to a snafu involving the house she rented for her stay. Serendipitously, Jade manages to turn things around and begins a romantic Caribbean adventure with the legitimate owner of the house, a mysterious man named Ford (Ser’Darius Blain). As Jade slowly lets her guard down and welcomes all that the island, its people and her handsome host have to offer, her heart and job come into direct conflict when she finds out the true backstory of the man she’s falling for — and it’s a career-defining scoop.</p>
<p><strong>Dirty Little Secret<br />
Lifetime, 8pm<br />
Original Film!</strong><br />
Inspired by true events, <em>Dirty Little Secret</em> follows 17-year-old Lucy (Lizzie Boys), who has been painfully isolated from her peers for years, refusing to let anyone near her house in order to hide her family secret — the overwhelming mountain of items filling every crevice of space in her home. She quietly plans her escape to college while managing her mother Joanna’s (Melissa Joan Hart) hoarding disorder. Outwardly a highly functioning nurse, Joanna maintains the dysfunction in their home with an obsessive grip, but after a tragedy, Lucy must decide if she will hide her mother’s secret, or expose it to the world.</p>
<p><strong>NBC Movie of the Week: “Despicable Me 3”<br />
NBC, 8pm</strong><br />
Steve Carrell, Kristen Wiig, Trey Parker and Miranda Cosgrove are among the voice cast of this 2017 entry in the computer-animated <em>Despicable Me </em>family film franchise.</p>
<p><strong>Special Theme: Follow the Thread: “Turning Points: Character Transformation Through Clothing”<br />
TCM, beginning at 8pm</strong><br />
Tonight’s double feature of classic movies notable for their use of fashion in their stories demonstrates how sometimes the evolution of a character is the central theme of a film, and how clothing is often an important tool to highlight the changes that are taking place. Characters can be transformed through the costumes they wear, signifying a new direction in life. That is certainly evident in this evening’s first film, <em>Now, Voyager</em> (1942). Best Actress Oscar nominee Bette Davis leads this drama as Charlotte Vale, a woman who was unwanted as a child, yet continued to live with her abusive, tyrannical mother. Her character is seen early on with a closeup on her legs as she descends down a staircase wearing thick, white stockings and a pair of flat, black, matronly shoes. Soon the audience sees her in a frumpy dress and glasses, clearly establishing her as meek, unattractive and lacking confidence. On the advice of kinder people in her orbit, who fear she’s about to have a nervous breakdown, Charlotte spends time in a sanitarium, where she is transformed. But instead of going back home to her mother, she decides to take a long cruise — and it’s here, in her first public appearance, where viewers once again see a closeup of her feet. This time, she’s wearing stylish heels, a clear contrast to her initial appearance. From then on, Charlotte’s wardrobe helps tell the story of her metamorphosis into a strong and confident woman. Tonight’s second feature, the Best Picture Oscar-nominated 1982 romantic comedy <em>Tootsie</em>, quickly establishes main character Michael Dorsey (Best Actor Oscar nominee Dustin Hoffman) as a self-absorbed and uncooperative (and unemployed) actor. He desperately needs a job and sees there’s a role for a woman, so he decides to put on a dress and try out for the part. Once he puts on women’s clothing, he is forced to live a different life, one in which people treat him differently, with less respect and with more emphasis on appearance. He develops more of an understanding of women’s experiences in our culture, becoming a more sensitive and empathetic person in the process.</p>
<p><strong>First Blood<br />
A&amp;E, 9pm<br />
New Series!</strong><br />
This 10-episode true crime docuseries examines some of America’s most notorious serial killers through the prism of their first known kills to reveal what drove them the moment when violent fantasy and curiosity became a devastating reality. The premiere episode, “Aileen Wuornos: The Damsel of Death, ” covers Florida’s Wuornos, who committed her first murder in 1989 and went on to kill seven people.</p>
<p><strong>Everything But the House: “Barbies and Baseball Cards”<br />
HGTV, 9pm</strong><br />
A couple is ready to downsize now that their kids have moved away, but generations of stuff has this family home packed to the rafters. Lara Spencer and her team hope to find enough valuable items on this treasure hunt that these homeowners can retire in style.</p>
<p><strong>Critter Fixers: Country Vets<br />
Nat Geo Wild, 9pm<br />
Season Finale!</strong><br />
Season 3 concludes with “The Chicken and Waffles,” which finds the docs at Critter Fixer trying to save the life of a giant Burmese python; performing a risky emergency C-section on a dog whose puppies are in danger; and warding off parasites to keep them from decimating an entire herd of goats. Plus, a cat bugs out from an encounter with a wasp, and a dog and chicken lose the spring in their steps.</p>
<p><strong>Panic 9-1-1<br />
A&amp;E, 10pm<br />
Season Premiere!</strong><br />
Season 3 of the docuseries that uses real audio from 9-1-1 calls to let viewers experience every harrowing and terrifying moment of the callers’ ordeals kicks off with “I’m Dying,” which tells three stories. A woman fights for her life when her estranged husband starts shooting at her through the front door; the brakes on a young mother’s vehicle suddenly stop working on a busy highway; and a family returns home from vacation to hear a frightening sound coming from the woods.</p>
<p><strong>Renovation Goldmine: “Functional for the Fam”<br />
HGTV, 10pm</strong><br />
Meg and Joe Piercy help an overwhelmed couple take on their major home renovation and fill the spaces with plenty of customized pieces. Then, they work their magic on a couple’s truckload of inherited furniture to upgrade their home office and son’s bedroom.</p>
<p><strong>Heartland Docs, DVM: “Thanks for the Mammaries”<br />
Nat Geo Wild, 10pm</strong><br />
Dr. Ben diagnoses a pet rat with the sniffles, and when a goat has a stinky situation, Dr. Erin gets to the bottom of it. Elsewhere, Dr. Erin removes mysterious mammary lumps from a hunting dog while Dr. Ben repairs a calf’s hernia. Together, they run to the rescue when a family’s horse sustains a head injury. They also decide to adopt a new family member: a cute border collie named Hank.</p>
	</div>
		<div id="text-771362228" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94"><img src="https://www.channelguidemag.com/wp-content/uploads/2020/05/CG-Ad_Save-66_728x90_Perry.jpg" /></a></div>
		</div></article><div id="comments" class="mh-comments-wrap">
</div>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.channelguidemag.com/tv-news/2022/06/02/thursday-june-2-celtics-warriors-nba-finals-2022-tv-schedule/" rel="prev"><img width="80" height="60" src="https://www.channelguidemag.com/wp-content/uploads/2022/05/NBAFinals2022BB-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="NBA Finals 2022" loading="lazy" srcset="https://www.channelguidemag.com/wp-content/uploads/2022/05/NBAFinals2022BB-80x60.jpg 80w, https://www.channelguidemag.com/wp-content/uploads/2022/05/NBAFinals2022BB-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="185899" data-permalink="https://www.channelguidemag.com/tv-news/2022/06/02/thursday-june-2-celtics-warriors-nba-finals-2022-tv-schedule/nbafinals2022bb/" data-orig-file="https://www.channelguidemag.com/wp-content/uploads/2022/05/NBAFinals2022BB.jpg" data-orig-size="1030,438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;NBA&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="NBAFinals2022BB" data-image-description="" data-image-caption="" data-medium-file="https://www.channelguidemag.com/wp-content/uploads/2022/05/NBAFinals2022BB-300x128.jpg" data-large-file="https://www.channelguidemag.com/wp-content/uploads/2022/05/NBAFinals2022BB-1024x435.jpg" /><span class="media-credit"  style="max-width: 80px">NBA</span><span>Previous</span><p>Thursday, June 2: Celtics vs. Warriors in 2022 NBA Finals on ABC</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://www.channelguidemag.com/tv-news/2022/06/03/angie-harmon-buried-in-barstow-interview-lifetime/" rel="next"><img width="80" height="60" src="https://www.channelguidemag.com/wp-content/uploads/2022/06/BuriedInBarstow2BB-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Buried in Barstow LIfetime" loading="lazy" srcset="https://www.channelguidemag.com/wp-content/uploads/2022/06/BuriedInBarstow2BB-80x60.jpg 80w, https://www.channelguidemag.com/wp-content/uploads/2022/06/BuriedInBarstow2BB-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="186115" data-permalink="https://www.channelguidemag.com/tv-news/2022/06/03/angie-harmon-buried-in-barstow-interview-lifetime/buriedinbarstow2bb/" data-orig-file="https://www.channelguidemag.com/wp-content/uploads/2022/06/BuriedInBarstow2BB.jpg" data-orig-size="1030,438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Lifetime&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="BuriedInBarstow2BB" data-image-description="" data-image-caption="" data-medium-file="https://www.channelguidemag.com/wp-content/uploads/2022/06/BuriedInBarstow2BB-300x128.jpg" data-large-file="https://www.channelguidemag.com/wp-content/uploads/2022/06/BuriedInBarstow2BB-1024x435.jpg" /><span class="media-credit"  style="max-width: 80px">Lifetime</span><span>Next</span><p>Don&#8217;t Mess With Mama: Angie Harmon Plays an Ex-Assassin in Lifetime&#8217;s &#8216;Buried in Barstow&#8217;</p></a></div>
</nav>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="search-2" class="mh-widget widget_search"><form role="search" method="get" class="search-form" action="https://www.channelguidemag.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="text-771362232" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362225" class="mh-widget widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Subscribe</span></h4>			<div class="textwidget"><p><center><a id="order-button" href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&amp;publ=CG&amp;key=IZX2Y91"><img loading="lazy" class="wp-image-184602 size-medium aligncenter" src="https://www.channelguidemag.com/wp-content/uploads/2022/05/CGMCoverJune2022.jpg" alt="" width="300" height="392" /></a></center><br />
<span style="display: block; font: 100% Montserrat; margin: 0 auto; max-width: 250px;">The most complete TV listings and best recommendations delivered right to your door — every month.</span></p>
</div>
		</div><div id="mh_magazine_custom_posts-10" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">In This Issue</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-186113 post type-post status-publish format-standard has-post-thumbnail category-drama category-interview category-archive category-preview tag-14479 tag-carousel tag-lifetime">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2022/06/03/angie-harmon-buried-in-barstow-interview-lifetime/" title="Don&#8217;t Mess With Mama: Angie Harmon Plays an Ex-Assassin in Lifetime&#8217;s &#8216;Buried in Barstow&#8217;">
										Don&#8217;t Mess With Mama: Angie Harmon Plays an Ex-Assassin in Lifetime&#8217;s &#8216;Buried in Barstow&#8217;									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2022/06/">June 3, 2022</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2022/06/03/angie-harmon-buried-in-barstow-interview-lifetime/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-185944 post type-post status-publish format-standard has-post-thumbnail category-5-questions-with category-drama category-archive category-preview tag-14479 tag-own">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2022/05/27/5-questions-simone-missick-all-rise-own/" title="5 Questions With Simone Missick of OWN&#8217;s &#8216;All Rise&#8217;">
										5 Questions With Simone Missick of OWN&#8217;s &#8216;All Rise&#8217;									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2022/05/">May 27, 2022</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2022/05/27/5-questions-simone-missick-all-rise-own/#comments" class="mh-comment-count-link" >1</a></span>
</div>
							</div>
						</li>			</ul></div><div id="text-771362226" class="mh-widget widget_text">			<div class="textwidget"><div style="background-color:  #FF9245; font: 170% Montserrat; font-weight:bold; margin: 10px 0 0; padding: 5px 0; text-align: center;"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94" id="order-button">ORDER NOW!</a></div></div>
		</div><div id="text-771362234" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div>
<div id="wpp-6" class="mh-widget popular-posts">
<h4 class="mh-widget-title"><span class="mh-widget-title-inner">Popular Posts</span></h4>            <div class="wpp-widget-placeholder" data-widget-id="wpp-6"></div>
            
</div>
<div id="text-771362192" class="mh-widget widget_text">			<div class="textwidget"><center><!-- Medium_Rectangle_300x250 -->
<div id='div-gpt-ad-1426776676899-3'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1426776676899-3'); });
</script>
</div></center>

</div>
		</div><div id="text-771362233" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362223" class="mh-widget widget_text">			<div class="textwidget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#e8e8e8; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://channelguidemag.us4.list-manage.com/subscribe/post?u=a2d9de00dacb27b8907ecc15a&amp;id=6990079feb" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2 style="color: #f47d2a;">Email sign up!</h2>
Follow your favorite writers and/or get weekly updates to the best on TV.<br /><br />
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group input-group">
    <ul><li><input type="checkbox" value="1" name="group[2865][1]" id="mce-group[2865]-2865-0"><label for="mce-group[2865]-2865-0">5toWATCH Weekly eNewsletter</label></li>
    <li><input type="checkbox" value="131072" name="group[6821][131072]" id="mce-group[6821]-6821-0"><label for="mce-group[6821]-6821-0">Ryan Berenz posts</label></li>
<li><input type="checkbox" value="262144" name="group[6821][262144]" id="mce-group[6821]-6821-2"><label for="mce-group[6821]-6821-2">Barb Oates posts</label></li>
<li><input type="checkbox" value="524288" name="group[6821][524288]" id="mce-group[6821]-6821-3"><label for="mce-group[6821]-6821-3">Jeff Pfeiffer posts</label></li>
</ul>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_a2d9de00dacb27b8907ecc15a_6990079feb" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[6]='ADDRESS';ftypes[6]='address';fnames[7]='KEYCODE';ftypes[7]='text';fnames[3]='SUBID';ftypes[3]='text';fnames[4]='VERSION';ftypes[4]='text';fnames[5]='EXPISSUE';ftypes[5]='text';fnames[8]='EXPYEAR';ftypes[8]='text';fnames[9]='ACTIVEMO';ftypes[9]='number';fnames[10]='SFGNO';ftypes[10]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
<!--End mc_embed_signup--></div>
		</div>	</aside>	</div>
    </div>
<footer class="mh-footer" id="footer-override">
	<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
					<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-1">
				<div id="text-771362230" class="mh-footer-widget widget_text">			<div class="textwidget"><p><img alt="Channel Guide Logo" src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png" /></p>
</div>
		</div><div id="mh_magazine_social-3" class="mh-footer-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-container"><ul id="menu-social-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>				</nav></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-2">
				<div id="nav_menu-4" class="mh-footer-widget widget_nav_menu"><div class="menu-top-menu-footer-container"><ul id="menu-top-menu-footer" class="menu"><li id="menu-item-151599" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-151599"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a></li>
<li id="menu-item-151600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151600"><a href="/movies-tv/">Movies On TV</a></li>
<li id="menu-item-151601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151601"><a href="/tv-listings/">TV Listings</a></li>
<li id="menu-item-151602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151602"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports</a></li>
<li id="menu-item-151603" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151603"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-151604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151604"><a href="https://www.channelguidemag.com/tv-news/category/binge-watching/">Binge Watching</a></li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-3">
				<div id="nav_menu-5" class="mh-footer-widget widget_nav_menu"><div class="menu-customer-service-container"><ul id="menu-customer-service-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">SUBSCRIBE / RENEW / MORE</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-181202"><a href="https://www.channelguidemag.com/contact-us/">Contact Us</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-4">
				<div id="text-771362218" class="mh-footer-widget widget_text">			<div class="textwidget"><p><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&amp;publ=CG&amp;key=IZX2Y93"><img src="https://www.channelguidemag.com/wp-content/uploads/2020/05/CG-Ad_Save-66_300x250_Snowpiercer.jpg" alt="Subscribe and Save" /></a></p>
</div>
		</div>			</div>
			</div>
</footer>
	<div class="mh-footer-mobile-nav"></div>
	<nav class="mh-footer-nav">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-publications-container"><ul id="menu-publications" class="menu"><li id="menu-item-151610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-151610"><a href="https://www.channelguidemag.com/">Channel Guide Magazine</a></li>
<li id="menu-item-151611" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151611"><a href="http://www.ondishmag.com">OnDISH Magazine</a></li>
<li id="menu-item-151612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151612"><a href="http://www.iwantmytvmagazine.com/">TV Weekly</a></li>
<li id="menu-item-151613" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151613"><a href="http://www.tvguidemagazine.com/">TV Guide Magazine</a></li>
<li id="menu-item-151614" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151614"><a href="http://www.view-mag.com/">VIEW Magazine</a></li>
<li id="menu-item-151615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151615"><a href="http://www.remindmagazine.com/">REMIND Magazine</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">@ 2020 Channel Guide Magazine</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.channelguidemag.com\/tv-news\/2022\/06\/03\/friday-june-3-the-boys-prime-video-season-3\/":186062};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/tv-news/2022/06/03/friday-june-3-the-boys-prime-video-season-3/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.channelguidemag.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.9.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202222.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.9.1',blog:'113259570',post:'186062',tz:'-5',srv:'www.channelguidemag.com'} ]);
	_stq.push([ 'clickTrackerInit', '113259570', '186062' ]);
</script>
</body>
</html>