<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v17.2.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Sunday, Oct. 3: Tom Brady Faces His Former Team on &#039;Sunday Night Football&#039;</title>
	<meta name="description" content="Tampa Bay Buccaneers quarterback Tom Brady returns to Gillette Stadium to lead the Bucs against his former team, the New England Patriots." />
	<link rel="canonical" href="https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Sunday, Oct. 3: Tom Brady Faces His Former Team on &#039;Sunday Night Football&#039;" />
	<meta property="og:description" content="Tampa Bay Buccaneers quarterback Tom Brady returns to Gillette Stadium to lead the Bucs against his former team, the New England Patriots." />
	<meta property="og:url" content="https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/" />
	<meta property="og:site_name" content="Channel Guide Magazine" />
	<meta property="article:publisher" content="https://www.facebook.com/ChannelGuideMagazine" />
	<meta property="article:published_time" content="2021-10-03T11:00:06+00:00" />
	<meta property="article:modified_time" content="2021-10-01T16:25:31+00:00" />
	<meta property="og:image" content="https://www.channelguidemag.com/wp-content/uploads/2021/01/Buccaneers_Brady_1020_BB.jpg" />
	<meta property="og:image:width" content="1030" />
	<meta property="og:image:height" content="438" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Channel Guide Staff" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="29 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.channelguidemag.com/#website","url":"https://www.channelguidemag.com/","name":"Channel Guide Magazine","description":"Our writers comment on the state of TV","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.channelguidemag.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/#primaryimage","inLanguage":"en-US","url":"https://www.channelguidemag.com/wp-content/uploads/2021/01/Buccaneers_Brady_1020_BB.jpg","contentUrl":"https://www.channelguidemag.com/wp-content/uploads/2021/01/Buccaneers_Brady_1020_BB.jpg","width":1030,"height":438},{"@type":"WebPage","@id":"https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/#webpage","url":"https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/","name":"Sunday, Oct. 3: Tom Brady Faces His Former Team on 'Sunday Night Football'","isPartOf":{"@id":"https://www.channelguidemag.com/#website"},"primaryImageOfPage":{"@id":"https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/#primaryimage"},"datePublished":"2021-10-03T11:00:06+00:00","dateModified":"2021-10-01T16:25:31+00:00","author":{"@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f"},"description":"Tampa Bay Buccaneers quarterback Tom Brady returns to Gillette Stadium to lead the Bucs against his former team, the New England Patriots.","breadcrumb":{"@id":"https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/"]}]},{"@type":"BreadcrumbList","@id":"https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.channelguidemag.com/"},{"@type":"ListItem","position":2,"name":"TV News","item":"https://www.channelguidemag.com/tv-news/"},{"@type":"ListItem","position":3,"name":"Sunday, Oct. 3: Tom Brady Faces His Former Team on &#8216;Sunday Night Football&#8217;"}]},{"@type":"Person","@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f","name":"Channel Guide Staff","image":{"@type":"ImageObject","@id":"https://www.channelguidemag.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/68b6c70392ac45a38a16ac89e1b612bb?s=96&d=blank&r=g","contentUrl":"https://secure.gravatar.com/avatar/68b6c70392ac45a38a16ac89e1b612bb?s=96&d=blank&r=g","caption":"Channel Guide Staff"},"url":"https://www.channelguidemag.com/tv-news/author/staff/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Feed" href="https://www.channelguidemag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Comments Feed" href="https://www.channelguidemag.com/comments/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.0.1 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-435360-2"  type="text/javascript" data-cfasync="false" async></script>
			<script type="text/javascript" data-cfasync="false">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</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.channelguidemag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=c7b5b4d1a6be1ddfc8885d67d1e1244b"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.channelguidemag.com/wp-includes/css/dist/block-library/style.min.css?ver=c7b5b4d1a6be1ddfc8885d67d1e1244b' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://www.channelguidemag.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.channelguidemag.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=c7b5b4d1a6be1ddfc8885d67d1e1244b' type='text/css' media='all' />
<link rel='stylesheet' id='media-credit-css'  href='https://www.channelguidemag.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.4.2' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/style.css?ver=c7b5b4d1a6be1ddfc8885d67d1e1244b' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine-child/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans:300,400,400italic,600,700,700italic%7cMontserrat:300,400,400italic,600,700,700italic' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.1' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.channelguidemag.com","hash_tracking":"false","ua":"UA-435360-2","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.0.1' id='monsterinsights-frontend-script-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/www.channelguidemag.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/www.channelguidemag.com\/wp-json\/wordpress-popular-posts","ID":182724,"token":"571e6ee0fb","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.4.2' id='wpp-js-js'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3' id='mh-scripts-js'></script>
<link rel="https://api.w.org/" href="https://www.channelguidemag.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.channelguidemag.com/wp-json/wp/v2/posts/182724" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.channelguidemag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.channelguidemag.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p7FdZg-Lxa' />
<link rel="alternate" type="application/json+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2021%2F10%2F03%2Fsunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2021%2F10%2F03%2Fsunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc%2F&#038;format=xml" />
        <style>
            @-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }
        </style>
        <style type="text/css">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</style>
<style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Montserrat", sans-serif; }
body { font-family: "Droid Sans", sans-serif; }
</style>
<link rel="amphtml" href="https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/amp/"><link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-270x270.png" />


<script src="https://cmp.osano.com/16BcscRpZUDCE2Y0Z/0b6a2128-f6bd-4fa8-b909-5ed16896e933/osano.js"></script>



<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
var mapping2 = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot2= googletag.defineSlot('/4370989/CGM-lead-bottom-flex', [320,50], 'div-gpt-ad-1426776676899-0').
defineSizeMapping(mapping2).
addService(googletag.pubads()).
setCollapseEmptyDiv(true);
var mapping = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot1= googletag.defineSlot('/4370989/cgm-lead-flexible-top', [320,50], 'div-gpt-ad-1426776676899-1').
defineSizeMapping(mapping).
addService(googletag.pubads());

googletag.defineSlot('/4370989/Medium_Rectangle_2_internal_ads', [300, 250], 'div-gpt-ad-1426776676899-2').addService(googletag.pubads());
googletag.defineSlot('/4370989/Medium_Rectangle_300x250', [300, 250], 'div-gpt-ad-1426776676899-3').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-182724 single-format-standard mh-boxed-layout mh-right-sb mh-loop-layout2 mh-widget-layout2" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<a class="mh-header-image-link" href="https://www.channelguidemag.com/" title="Channel Guide Magazine" rel="home">
<img class="mh-header-image" src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png" height="139" width="496" alt="Channel Guide Magazine" />
</a>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-99135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99135"><a href="/tv-listings/">TV Listings</a></li>
<li id="menu-item-151619" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-151619"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a>
<ul class="sub-menu">
	<li id="menu-item-99133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99133"><a href="https://www.channelguidemag.com/movies-tv/">Movies on TV</a></li>
	<li id="menu-item-154098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154098"><a href="https://www.channelguidemag.com/tv-news/category/vod/">New to On Demand &#038; DVD</a></li>
</ul>
</li>
<li id="menu-item-151620" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151620"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-99134" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-99134"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports on TV</a>
<ul class="sub-menu">
	<li id="menu-item-152175" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152175"><a href="https://www.channelguidemag.com/sports-on-tv/">This Week&#8217;s Schedule</a></li>
</ul>
</li>
<li id="menu-item-151622" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151622"><a href="/network-contacts/">How to contact a Network</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-customer-service-container"><ul id="menu-customer-service" class="menu"><li id="menu-item-151605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">SUBSCRIBE / More</a>
<ul class="sub-menu">
	<li id="menu-item-151606" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li id="menu-item-151607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li id="menu-item-151608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li id="menu-item-181202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-181202"><a href="https://www.channelguidemag.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-151609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li id="menu-item-156378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-151616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-151617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-151618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>

<div class="mh-wrapper clearfix">
<span class='mh-best-bets-caption'>TV Best Bets</span>	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content"><article id="post-182724" class="post-182724 post type-post status-publish format-standard has-post-thumbnail hentry category-sports category-tv-best-bets tag-nbc tag-nfl">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Sunday, Oct. 3: Tom Brady Faces His Former Team on &#8216;Sunday Night Football&#8217;		</h1>
		<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/10/">October 3, 2021</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.channelguidemag.com/tv-news/author/staff/">Channel Guide Staff</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.channelguidemag.com/tv-news/category/sports/" rel="category tag">Sports</a>, <a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/" rel="category tag">TV Best Bets</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Sunday, Oct. 3: Tom Brady Faces His Former Team on &#8216;Sunday Night Football&#8217;</span></span></span>
</div>
	</header>
		<div class="entry-content clearfix"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-182724" class="share-facebook sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-182724" class="share-pinterest sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-182724" class="share-twitter sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<figure class="entry-thumbnail">
<img src="https://www.channelguidemag.com/wp-content/uploads/2021/01/Buccaneers_Brady_1020_BB-678x381.jpg" alt="" title="Buccaneers_Brady_1020_BB" />
<span class="media-credit">Mike Ehrmann/Getty Images</span></figure>
<h3><strong>ALSO SEE:</strong> <a href="https://www.tvinsider.com/1012553/2021-nfl-regular-season-tv-schedule/" target="_blank" rel="noopener">Complete 2021 NFL TV Schedule</a></h3>
<p><strong>All Times Eastern. <a href="https://www.pbs.org/" target="_blank" rel="noopener">PBS</a> programming varies regionally.</strong></p>
<h2>Sunday, Oct. 3</h2>
<p><strong>NFL Football: Tampa Bay at New England<br />
NBC, 8:20pm Live</strong><br />
Tampa Bay Buccaneers quarterback Tom Brady can achieve the rare feat of beating all 32 NFL teams in his career when he faces the New England Patriots — with whom he won six Super Bowls — on <em>Sunday Night Football</em>.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/gZ7VlWomxE0?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></p>
<p><strong>The Walking Dead<br />
AMC+<br />
Midseason Finale!</strong><br />
Check out the Season 11 midseason finale of <em>The Walking Dead</em> one week ahead of its linear premiere on AMC. In the episode, called “For Blood,” the Reapers defend Meridian from an incoming herd. Meanwhile, Alexandrians scramble to protect themselves when a violent storm leaves them vulnerable to walkers.</p>
<p><strong>The Earthshot Prize: Repairing Our Planet<br />
discovery+<br />
New Series!</strong><br />
This five-part series spotlights Prince William’s Earthshot Prize, which was launched in October 2020 and is the most prestigious global environment prize in history. It aims to discover, celebrate and scale innovative solutions to the greatest environmental challenges facing our planet, and is centered on five Earthshots: Protect and Restore Nature; Clean Our Air; Revive Our Oceans; Build a Waste-Free World; and Fix Our Climate. Featuring Prince William, Sir David Attenborough and additional members of the Earthshot Prize Council, the series showcases these five challenges and highlights the work of 15 prize finalists and their groundbreaking solutions. The series will also air on Discovery Channel on Oct. 16, just ahead of the award ceremony that will stream on Discovery’s Facebook page on Oct. 17.</p>
<p><strong>NASCAR Cup Series: YellaWood 500<br />
NBC, 2pm Live</strong><br />
The NASCAR Cup Series returns to Alabama’s Talladega Superspeedway for the second of three playoff races in the Round of 12.</p>
<p><strong>America’s Funniest Home Videos<br />
ABC, 7pm<br />
Season Premiere!</strong><br />
The venerable and hilarious show returns for yet another season.</p>
<p><strong>The Simpsons: “Bart’s in Jail”<br />
FOX, 8pm</strong><br />
When Grampa (voice of Dan Castellaneta) falls victim to a phone scammer, the Simpsons set out on a mission of vengeance to get his money back. Alan Cumming provides a guest voice in the new episode “Bart’s in Jail.”</p>
<p><strong>Deadly Seduction<br />
Lifetime, 8pm<br />
Original Film!</strong><br />
Maggie and her husband Richard are both college professors and have a daughter, 17-year-old Jenny. Their marriage is falling apart, and when Richard admits to having an affair with a student, they separate. Maggie and best friend Alyssa intend to have a girls’ night out, but at the bar Maggie meets Kyle, and she revels in his attention. After one too many drinks, they share a passionate night. She is later stunned to see Kyle in her class, claiming to be a fan of her bestselling book on serial killer Cordell Colton, from whom she escaped at 15 years old. It is only then that we begin to discover Kyle’s shocking secret as he sets out to destroy Maggie’s life and career by framing her husband for murder and seducing her daughter. Stars Lindsay Hartley, Andrew Rogers and Katie Kelly.</p>
<p><strong>Call the Midwife<br />
PBS, 8pm<br />
Season Premiere!</strong><br />
Season 10 of the acclaimed British drama consists of seven episodes and rejoins the nurses, midwives and nuns of Nonnatus House in London’s East End in the year 1966. While it is a trying time for the midwives, there is excitement, too, as the women’s rights movement intensifies. In the season premiere episode, Sister Julienne (Jenny Agutter) and Dr. Turner (Stephen McGann) clash over whether to provide a private-care service. Meanwhile, a distressing birth raises fears of another thalidomide case.</p>
<p><strong>TCM Classic Horror (With Mario Cantone): “Creature Features”<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Each Sunday evening during this creepy month of October, concluding on Halloween night, comedian/writer Mario Cantone will be on hand to help Turner Classic Movies introduce a horror film double feature centered around a particular theme. Tonight’s initial twin-billing features two notable creature features starting with <em>The Birds</em> (1963), Alfred Hitchcock’s terrifyingly realized nightmare of what might happen should our fine feathered friends decide to turn against us. Tippi Hedren, Rod Taylor and Jessica Tandy lead the cast, and terrific visual and sound effects really enhance the horror that comes from not only the bird attacks, but also from the mere sights of them simply and quietly beginning to gather en masse. Next up tonight is <em>Little Shop of Horrors</em>, the Oscar-nominated 1986 black comedy/musical adaptation of the 1982 off-Broadway production of the same name, which itself was a remake of 1960’s <em>The Little Shop of Horrors</em>. <em>— Jeff Pfeiffer</em></p>
<p><strong>The Great North: “The Great Punkin’ Adventure”<br />
FOX, 8:30pm</strong><br />
A punk band invites Ham (voice of Paul Rust) to audition after hearing him scream in the new episode “The Great Punkin’ Adventure.”</p>
<p><strong>Chapelwaite: “The Offer”<br />
EPIX, 9pm</strong><br />
Charles (Adrien Brody) is overwhelmed with grief and anger after his family is dealt a devastating blow. Later, Stephen (Steven McCarthy) and Uncle Phillip (Julian Richings) come to Charles with a surprising proposition.</p>
<p><strong>Bob’s Burgers: “Crystal Mess”<br />
FOX, 9pm</strong><br />
In order to help with anxiety about an upcoming oral report, Mr. Frond (voice of David Herman) lends Tina (voice of Dan Mintz) a crystal that his new girlfriend alleges has special powers in the new episode “Crystal Mess.”</p>
<p><strong>One Summer<br />
Hallmark Movies &amp; Mysteries, 9pm<br />
Original Film!</strong><br />
Based on the <em>New York Times</em> bestselling book by David Baldacci, the film follows Jack (Sam Page), who takes his son and daughter to his late wife’s (Amanda Schull) beachside hometown hoping to heal and become closer. The summer brings visions of the past that could forge a new path forward.</p>
<p><strong>Grantchester<br />
PBS, 9pm<br />
Season Premiere!</strong><br />
The acclaimed British detective drama is back for an eight-episode sixth season. It’s 1958 in the Cambridgeshire village of Grantchester, and Rev. Will Davenport (Tom Brittney) relishes his role as a firebrand vicar willing to challenge conventions to help people, especially with more crimes to investigate. In the season premiere, a much-needed summer break at a vacation resort takes an unexpected turn for Will and his best friend, Detective Inspector Geordie Keating (Robson Green), when the camp owner is found dead under suspicious circumstances.</p>
<p><strong>Billions<br />
Showtime, 9pm<br />
Season Finale!</strong><br />
Season 5 of the drama series starring Paul Giamatti, Damian Lewis and Maggie Siff comes to a close with the finale episode “No Direction Home.” Showtime has renewed <em>Billions</em> for a sixth season.</p>
<p><strong>Animal Kingdom<br />
TNT, 9pm<br />
Season Finale!</strong><br />
In the season finale, it’s all hands on deck as the Cody family uses all their tools, tricks and vehicles to pull off the job of their lives and settle all scores. A deadly secret from the past is also revealed. The series will return for a sixth and final season in 2022.</p>
<p><strong>Family Guy: “Rock Hard”<br />
FOX, 9:30pm</strong><br />
In the new episode “Rock Hard,” Peter (voice of Seth MacFarlane) and the guys recount tales of rock legends Jim Morrison, Muddy Waters and Elton John.</p>
<p><strong>Outrageous Pumpkins<br />
Food Network, 10pm<br />
Season Premiere!</strong><br />
With four episodes that take the traditional Halloween pastime to the next level, this series showcases seven extraordinarily talented pumpkin carvers who duke it out in an outdoor pumpkin competition that defies imagination. Each week the carvers dive headfirst into the most insane, eerie and outrageous challenges, executing their intricate Halloween designs to impress judges Terri Hardin and Marc Evan. Only one will earn the coveted title of Outrageous Pumpkin Champion and take home a sweet $25,000 Halloween treat!</p>
<p><strong>Storm Rising<br />
Nat Geo, 10pm<br />
New Series!</strong><br />
Storms are becoming stronger and more unpredictable than ever before. In this series, storm chasers Reed Timmer and Mike Theiss are on a mission to understand how tornadoes and hurricanes are evolving in a changing global climate. With decades of storm-chasing experience between them, they track down extreme weather events and put themselves in the path of destruction to collect unprecedented data from inside the heart of the storms.</p>
<p><strong><a href="https://www.foxnews.com/foxnews25" rel="noopener" target="_blank">FOX News Channel: 25 Years</a><br />
FOX News Channel, 10pm</strong><br />
This special kicks off FOX News Channel’s 25th anniversary celebration, featuring interviews, behind-the-scenes footage and flashbacks from FNC’s biggest names. The hourlong special will incorporate the evolution of the channel since its launch on October 7, 1996, through the eyes of its founding on-air team and many of its prominent stars. The special will also be available to stream on FOX Nation.</p>
<p><strong>The Walking Dead: World Beyond<br />
AMC, 10:05pm<br />
Season Premiere!</strong><br />
Season 2 concludes the epic story of Iris (Aliyah Royale), Hope (Alexa Mansour), Elton (Nicolas Cantu) and Silas (Hal Cumpston). As they face off against the mysterious Civic Republic Military, goals shift, bonds form and crumble, and innocence is both lost and found. Hope’s commitment to the future gets put to the test, jeopardizing a potential reunion, while Iris and Felix (Nico Tortorella) meet a new group.</p>
<h3>Monday, Oct. 4</h3>
<p><strong>Midsomer Murders<br />
Acorn TV<br />
New Episodes!</strong><br />
Season 22 of the beloved British mystery drama returns with its final three U.S. premiere episodes becoming available on Acorn TV beginning today and continuing the next two Mondays.</p>
<p><strong>On My Block<br />
Netflix<br />
Season Premiere!</strong><br />
Season 4 of the coming-of-age comedy about a group of bright and street-savvy friends navigating their way through high school in the rough inner city catches up to the group two years later and having gone their separate ways. When a secret is unburied, they quickly learn you can’t run from the past, and they will need to stick together to survive.</p>
<p><strong>Alma’s Way<br />
PBS, 8:30am<br />
New Series!</strong><br />
This new weekday animated series from Fred Rogers Productions was created by Sonia Manzano, beloved by generations for her groundbreaking portrayal of Maria on <em>Sesame Street</em>. <em>Alma’s Way</em> is inspired by Manzano’s own childhood and centers on 6-year-old Alma Rivera, a Puerto Rican girl who lives in the Bronx with her family. Infused with humor and grounded in a social and emotional curriculum, the series will give children ages 4-6 the tools to find their own answers, express themselves and respect others’ perspectives.</p>
<p><strong>Roswell, New Mexico: “2 Became 1”<br />
The CW, 8pm</strong><br />
A desperate Liz (Jeanine Mason) agrees to a deal. Meanwhile, Rosa (Amber Midthunder) helps Isobel (Lily Cowles) make a big discovery and the fight to save Max (Nathan Dean) begins.</p>
<p><strong>9-1-1: “Desperate Measures”<br />
FOX, 8pm</strong><br />
As the citywide blackout continues to cause mayhem in Los Angeles, Athena (Angela Bassett) races to save her family from a tragedy in the new episode “Desperate Measures.”</p>
<p><strong>The Voice: “The Blind Auditions, Part 5”<br />
NBC, 8pm</strong><br />
Ariana Grande, Kelly Clarkson, John Legend and Blake Shelton vie to discover and coach the next singing phenomenon on the fifth night of blind auditions.</p>
<p><strong>Antiques Roadshow: “Extraordinary Finds 2”<br />
PBS, 8pm</strong><br />
Learn what happens to more standout treasures after the <em>Antiques Roadshow</em> cameras stop rolling.</p>
<p><strong>Special Theme: Big Country: “Country Biopics &amp; Country Stars as Actors, Part One”<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Turner Classic Movies goes country on Monday nights this month with lineups of films about country music and country performers, starring country stars or all of the above. Each block of movies features titles grouped by theme, and tonight’s initial lineup features two themes. First is “Country Biopics,” with two of most notable movies ever made about the lives of legendary country stars. First is <em>Coal Miner’s Daughter</em> (1980), the Best Picture Oscar-nominated biopic about the life of country icon Loretta Lynn, portrayed by Best Actress Oscar winner Sissy Spacek. Spacek was personally chosen by Lynn to play her onscreen, and the actress truly does transform into the singer, even performing several of Lynn’s hits for the film and its bestselling soundtrack. Tonight’s second biopic is <em>Your Cheatin’ Heart</em> (1964), with George Hamilton as Hank Williams in the story of his rise to country music immortality. While wanting to sing Williams’ songs himself for realism, Hamilton did agree to be dubbed in his performance scenes by Hank Williams Jr. The second half of tonight’s “Big Country” salute features two films with country music stars in acting roles. First is <em>Songwriter</em>, a 1984 comedy/drama starring Willie Nelson and Kris Kristofferson and loosely based on Nelson’s life, about a country/western composer seeking his artistic freedom. Kristofferson earned an Oscar nomination for Best Music, Original Song Score, and the musician/actor returns in tonight’s second film, the 1976 remake of <em>A Star Is Born</em>. Barbra Streisand stars as a young singer who meets and falls in love with an established music star (Kristofferson), only to find her career ascending while his goes into decline. Streisand and Paul Williams won an Oscar for their memorable original song “Evergreen (Love Theme From <em>A Star Is Born</em>).” <em>— Jeff Pfeiffer</em></p>
<p><strong>Black Ink Crew: Chicago<br />
VH1, 8pm<br />
Season Premiere!</strong><br />
This season follows the cast returning to normalcy after enduring a life-changing year and finding a renewed sense of purpose — growing from their past mistakes to form a stronger future.</p>
<p><strong>The Big Leap: “The White Swan Lives!”<br />
FOX, 9pm</strong><br />
Monica (Mallory Jansen) confronts her past when the contestants head to Chicago to see <em>Swan Lake</em> performed by her former ballet company in the new episode “The White Swan Lives!”</p>
<p><strong>Laetitia<br />
HBO, 9pm<br />
Series Finale!</strong><br />
The limited drama series from France concludes tonight. As disturbing new allegations surface, Béatrice (Alix Poisson) meets with Touchais (Yannick Choirat) to share the full extent of her complicated history with the twins.</p>
<p><strong>The Good Doctor: “Piece of Cake”<br />
ABC, 10pm</strong><br />
Dr. Shaun Murphy and the team race to save a pregnant woman’s baby and find her current situation as a convicted felon complicates it even more than they realize. Meanwhile, the hospital takes on some unexpected changes that the staff are not prepared for.</p>
<p><strong>NCIS: Hawai‘i: “Recruiter”<br />
CBS, 10pm</strong><br />
In the new episode “Recruiter,” Kai (Alex Tarrant) goes undercover inside a surf gang to investigate the murder of a petty officer who’s trying to help wayward kids find a new path in the Marines.</p>
<p><strong>Ordinary Joe: “Happy Birthday Jenny”<br />
NBC, 10pm</strong><br />
Jenny Banks’ (Elizabeth Lail) birthday gives everyone something to celebrate; Music Joe (James Wolk) crashes Jenny’s party while Amy (Natalie Martinez) is in full campaign mode; Nurse Joe (Wolk) and Christopher (John Gluck) try to plan the perfect cake for Jenny; and Cop Joe (Wolk) and Amy take an important step in their relationship.</p>
<p><strong>POV: “Fruits of Labor”<br />
PBS, 10pm</strong><br />
Airing as part of Hispanic Heritage Month, this documentary film follows Ashley, a Mexican American teenager who dreams of graduating high school. But increased ICE raids in her coastal California community threaten the family’s stability since her mother is undocumented.</p>
<p><strong>Good Grief<br />
IFC, 12am (late-night)<br />
New Series!</strong><br />
This is the North American broadcast premiere (it began streaming on Sundance Now last week) of a New Zealand comedy about two millennial sisters in a small town who inherit a funeral home from their grandfather. Unsure what to do with it — or the oddball staff that keeps the place running — the women are thrust into a world of embalming, emceeing and embarrassment. By staring death in the face every day, the sisters begin to confront the realities of their own lives, and what they want to make of them.</p>
<h3>Tuesday, Oct. 5</h3>
<p><strong>The Prison Breaker<br />
discovery+</strong><br />
This four-hour documentary tells the true story of one of the most brilliant escape artists of all time, Richard Lee McNair. Thought to be the only person ever to have broken out of jail, a state penitentiary and a federal penitentiary, McNair is a three-time escape artist who is famous for mailing himself to freedom. Now, with the help of the journalist who spent 13 years building a relationship with McNair, this program uses hundreds of letters, personal photos and videos, and exclusive interviews for a deep dive into the mind of a criminal genius.</p>
<p><strong>Escape the Undertaker<br />
Netflix</strong><br />
In this interactive Halloween special, WWE’s New Day (Big E, Xavier Woods and Kofi Kingston) must survive the wrath of The Undertaker at his mansion, which has been transformed into an extreme haunted house.</p>
<p><strong>FBI: “Trauma”<br />
CBS, 8pm</strong><br />
The team investigates a connection between bombings at government agencies and a New York City private club for veterans in the new episode “Trauma.”</p>
<p><strong>Level Playing Field<br />
HBO, 8pm<br />
Series Finale!</strong><br />
The fourth and final episode of this documentary series, “The Assist,” explores the intersection of sports and politics through an examination of the WNBA’s Atlanta Dream’s landmark role in the election of Senator Raphael Warnock and the ongoing fight against voter suppression in Georgia. The Dream players’ impassionate campaign against then-Georgia senator — and team owner — Kelly Loeffler made an undeniable imprint on one of the most closely watched senate races of all time.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe loading="lazy" class="youtube-player" width="640" height="360" src="https://www.youtube.com/embed/fLOEWS8UA3g?version=3&#038;rel=1&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;fs=1&#038;hl=en-US&#038;autohide=2&#038;wmode=transparent" allowfullscreen="true" style="border:0;" sandbox="allow-scripts allow-same-origin allow-popups allow-presentation"></iframe></span></p>
<p><strong>Generation Gamble<br />
CNBC, 8pm</strong><br />
In this hourlong documentary, CNBC’s Melissa Lee takes viewers on a journey to the intersection of online betting, trading and gaming — all of which surged in popularity and profits during the pandemic. Lee profiles the Gen Z consumers and social media influencers behind the surge, explores the companies capitalizing on the trend and interviews experts trying to raise awareness about the potential pitfalls. The documentary reports on a new era where the boundaries between gambling, gaming and investing are being blurred. As the smartphone generation comes of age, it is overturning traditional concepts of money and risk, and shaking up the markets.</p>
<p><strong>DC’s Stargirl: “Summer School: Chapter Nine”<br />
The CW, 8pm</strong><br />
As Eclipso (Nick E. Tarabay) takes aim at the Whitmore-Dugans, Pat (Luke Wilson) is reminded of painful memories from his past involving the original JSA and their fight to take down Eclipso. Meanwhile, Mike (Trae Romano) is forced to confront the guilt he feels for his role in Icicle’s death, and Barbara (Amy Smart) comes face-to-face with someone from her past. Finally, Courtney (Brec Bassinger) struggles to hold onto hope after Eclipso targets those around her.</p>
<p><strong>MLB Playoffs: AL Wild-Card Game<br />
ESPN, 8pm Live</strong><br />
One AL team’s season will end tonight and another team will advance to the AL Division Series as ESPN airs the wild-card playoff game.</p>
<p><strong>The Resident: “The Long and Winding Road”<br />
FOX, 8pm</strong><br />
The Raptor (Malcolm-Jamal Warner) and Leela (Anuja Joshi) deal with a patient returning with long-term effects of COVID-19 in the new episode “The Long and Winding Road.”</p>
<p><strong>The Voice: “The Blind Auditions, Part 6”<br />
NBC, 8pm</strong><br />
Ariana Grande, Kelly Clarkson, John Legend and Blake Shelton vie to discover and coach the next singing phenomenon on the final night of blind auditions.</p>
<p><strong>TCM Spotlight: New Waves Around the World: “Italian Neo-Realism”<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Each Tuesday this October, Turner Classic Movies will spotlight influential cinematic “new wave” film movements from various countries. Starting on this first Tuesday, TCM will feature films from Italy’s notable neorealism movement. Neorealism in Italian cinema fully came into its own around the time that World War II ended in Europe; with studios destroyed in the air raids and Mussolini no longer in power, the Italian film industry was directionless. The end of the war, and their experiences during the conflict, brought a new outlook to the Italian people, and this was reflected in the neorealism adopted by filmmakers largely in the decade between the early 1940s and early ’50s, with that influence extending into the later ’50s and early ’60s. The films made during this period — filmed on location and frequently using nonprofessional actors — showed not just the rebuilding of Italy and its cities after the war, but also the reconstruction of people’s lives and their relationships with others, particularly among the poor and working class. The films from this era that TCM will be featuring tonight are, in order: the 1945 war drama <em>Rome, Open City</em>, cowritten and directed by prominent neorealist Roberto Rossellini (with future famous filmmaker Federico Fellini also contributing to the script in one of his earlier writing credits) and nominated for an Academy Award, for Best Writing, Screenplay; <em>La Strada</em>, cowriter/director Fellini’s acclaimed 1954 drama that won more than 50 international film awards including the Best Foreign Language Film Oscar; Ermanno Olmi’s 1961 film <em>Il Posto</em>; Michelangelo Antonioni’s 1962 romance <em>L’Elcisse</em>, which was named one of the 100 Greatest Films of All Time by the British Film Institute; the 1965 comedy/drama <em>I Knew Her Well</em>, from cowriter/director Antonio Pietrangeli, which made the list of 100 Italian Films to Be Saved established by the Venice International Film Festival; and the 1962 drama <em>Mamma Roma</em>, written and directed by Pier Paolo Pasolini, and starring renowned Italian actress Anna Magnani in one of her most acclaimed roles. <em>— Evan McLean</em></p>
<p><strong>2021 BET Hip Hop Awards<br />
BET, 9pm</strong><br />
Cardi B, Lil Durk and Megan Thee Stallion lead the nominees of this year’s celebration of hip-hop music with nine nominations each, followed by Drake with eight nods. The ceremony was taped in Atlanta on Friday, Oct. 1.</p>
<p><strong>FBI: International: “Secrets as Weapons”<br />
CBS, 9pm</strong><br />
In the new episode “Secrets as Weapons,” the team investigates the hijacking of millions in cryptocurrency on its way to a vault in Switzerland.</p>
<p><strong>Our Kind of People: “Hot Links &amp; Red Drinks”<br />
FOX, 9pm</strong><br />
In the new episode “Hot Links &amp; Red Drinks,” Angela (Yaya DaCosta) wants to make Nikki (Alana Bright) the face of Eve’s Crown, and secrets are revealed at the Oak Bluffs Juneteenth Rose Ball.</p>
<p><strong>The Nate and Jeremiah Home Project<br />
HGTV, 9pm<br />
New Series!</strong><br />
Married designers and dads of two, Nate Berkus and Jeremiah Brent will be followed docuseries-style as they help families moving into a new place let go of the things they no longer need to get a fresh start. Once the clients have parted with the unnecessary belongings, Nate and Jeremiah will employ their design expertise to renovate the property into a dream home perfect for the next phase of the clients’ lives.</p>
<p><strong>La Brea: “Day Two”<br />
NBC, 9pm</strong><br />
With Josh’s (Jack Martin) life on the line, Eve (Natalie Zea) traverses the dangerous wilderness back to the clearing to save him. Desperate to kick-start a rescue mission, Gavin (Eoin Macken) and Izzy (Zyra Gorecki) work to prove there are survivors alive inside the sinkhole as government agents track their every move.</p>
<p><strong>American Masters: “Rita Moreno: Just a Girl Who Decided to Go for It”<br />
PBS, 9pm</strong><br />
Over a career spanning more than 70 years, Rita Moreno defied both her humble upbringing and the relentless racism she encountered to become a celebrated and award-winning actor. This program explores the legendary star’s rich career using vérité footage of Moreno today, archival footage of her roles and appearances, reenactments of her childhood, animation, and interviews with Moreno, those close to her and performers she influenced. Film interviewees include Gloria Estefan, Morgan Freeman, Mitzi Gaynor, Whoopi Goldberg and Eva Longoria, as well as Norman Lear and Lin-Manuel Miranda, who are also executive producers.</p>
<p><strong>FBI: Most Wanted: “Tough Love”<br />
CBS, 10pm</strong><br />
The team looks into a long list of cases for a suspect in the murder of a judge known for giving harsh sentences to juveniles in the new episode “Tough Love.”</p>
<p><strong>Dinner: Impossible<br />
Food Network, 10pm<br />
Season Premiere!</strong><br />
In each one-hour episode, Robert Irvine and his team of sous chefs must overcome extraordinary obstacles and conditions that push Robert to his physical and mental limits, while preparing and serving delicious meals to groups of hungry and expectant guests through different thematic challenges before his allotted time runs out. Over six episodes, Robert and his team travel to locations in California, Michigan, New Mexico, North Carolina and Ohio.</p>
<p><strong>Impeachment: American Crime Story: “Do You Hear What I Hear?”<br />
FX, 10pm</strong><br />
In the new episode “Do You Hear What I Hear?” Monica (Beanie Feldstein) prepares to leave Washington, D.C., but she grows concerned that someone is sharing news about her affair.</p>
<p><strong>New Amsterdam: “Same As It Ever Was”<br />
NBC, 10pm</strong><br />
Max (Ryan Eggold) and Sharpe (Freema Agyeman) go public with their relationship at the hospital; the team struggles to keep a handle on an overcrowded and understaffed ICU, and everyone must pitch in; and Iggy’s (Tyler Labine) overly critical feedback alienates his residents.</p>
<h3>Wednesday, Oct. 6</h3>
<p><strong>Among the Stars<br />
Disney+<br />
New Series!</strong><br />
This six-part docuseries embeds viewers with NASA astronaut Chris Cassidy as he embarks on one last mission. Through intimate footage, personal video diaries and livestream footage — from cameras both on Earth and in space — viewers are given a first look at the critically important team of engineers, flight controllers and specialists who take on these dangerous and awe-inspiring missions for the greater good. All episodes are available today.</p>
<p><strong>Fauci<br />
Disney+</strong><br />
National Geographic Documentary Films produced this look at Dr. Anthony Fauci, the world-renowned infectious disease specialist who became America’s most unlikely cultural icon during the COVID-19 pandemic. Crafted around unprecedented access to Dr. Fauci, this film is a revealing portrait of one of our most dedicated public servants.</p>
<p><strong>Turner &amp; Hooch<br />
Disney+<br />
Season Finale!</strong><br />
This series based on the 1989 Tom Hanks comedy about a law enforcement officer partnered with a slobbering canine ends its first season. Josh Peck stars.</p>
<p><strong>What If…?<br />
Disney+<br />
Season Finale!</strong><br />
This animated look at what would happen if various notable events in the Marvel Cinematic Universe had turned out differently concludes Season 1.</p>
<p><strong>Wildling<br />
IFC Films Unlimited<br />
Original Film!</strong><br />
A teenage girl’s coming of age comes with a terrifying twist in this spellbinding take on the werewolf legend. Since birth, Anna (Bel Powley) has been raised in isolation by a man she knows only as Daddy (Brad Dourif), who has done everything possible to conceal the truth about the girl’s origins from her. But when the teenage Anna is suddenly thrust into the real world under the protection of no-nonsense police officer Ellen (Liv Tyler), it soon becomes clear that the young woman is far from ordinary.</p>
<p><strong>Baking Impossible<br />
Netflix<br />
New Series!</strong><br />
Top bakers and engineers team up to build edible creations that must taste delicious and survive intense engineering stress tests. Those who are most successful will win $100,000.</p>
<p><strong>There’s Someone Inside Your House<br />
Netflix<br />
Original Film!</strong><br />
In this slasher film, Makani Young (Sydney Park) has moved from Hawaii to quiet, small-town Nebraska to live with her grandmother and finish high school. But as the countdown to graduation begins, her classmates are stalked by a killer intent on exposing their darkest secrets to the entire town, terrorizing victims while wearing a life-like mask of their own face. With a mysterious past of her own, Makani and her friends must discover the killer’s identity before they become victims themselves.</p>
<p><strong>V/H/S/94<br />
Shudder<br />
Original Film!</strong><br />
The infamous <em>V/H/S </em>found-footage horror anthology series returns with this fourth installment, featuring segments directed by franchise alumni Simon Barrett and Timo Tjahjanto, in addition to stories from acclaimed directors Jennifer Reeder, Ryan Prows and Chloe Okuno. In this film, after the discovery of a mysterious VHS tape, a brutish police SWAT team launch a high-intensity raid on a remote warehouse, only to discover a sinister cult compound whose collection of pre-recorded material uncovers a nightmarish conspiracy.</p>
<p><strong>TCM Morning &amp; Afternoon Movies: “Robots”<br />
TCM, beginning at 8:15am<br />
Catch a Classic!</strong><br />
This morning and afternoon’s lineup of films on Turner Classic Movies stars some of the most famous robots (or other types of sentient machines) in cinema history. The day begins with Stanley Kubrick’s legendary 1968 sci-fi classic <em>2001: A Space Odyssey</em>. Among its many iconic elements, the production introduces the HAL 9000 computer (memorably voiced with an almost sinister calmness by Douglas Rain), which runs the functions aboard a spacecraft headed toward Jupiter. Unfortunately, HAL ends up going a bit mad and nearly succeeds in his effort to kill all members of the crew. A somewhat kinder HAL makes a return in today’s next film, <em>2010: The Year We Make Contact</em>, the 1984 sequel to <em>2001 </em>starring Roy Scheider, John Lithgow and Helen Mirren. Next up are two films featuring one of Hollywood’s most famous mechanical men: Robby the Robot. Check him out in his first and second movie appearances, <em>Forbidden Planet </em>(1956) and <em>The Invisible Boy</em> (1957). After those is <em>The Terminal Man</em>, a 1974 adaptation of Michael Crichton’s 1972 novel starring George Segal as an epileptic computer scientist who agrees to an experimental surgical procedure to implant electrodes in his brain and control his seizures with an electrical impulse. Unfortunately, this fusion of man and computer leads to a deepening psychosis. Finally, Wes Craven’s 1986 sci-fi/horror film <em>Deadly Friend</em> is about a similar experiment that goes just as badly as the one in <em>Terminal Man</em>. When a teen computer prodigy (Matthew Laborteaux) implants a robot’s hard drive into the brain of his teenage neighbor (Kristy Swanson), who has been pronounced brain dead, she recovers but soon begins a killing spree in their neighborhood. <em>— Jeff Pfeiffer</em></p>
<p><strong>The Goldbergs: “Riptide Waters”<br />
ABC, 8pm</strong><br />
Recently injured at local waterpark Riptide Waters, Mr. Glascott embarks on a mission to petition the neighborhood to close it down. Determined to foil Mr. Glascott’s plan, Barry starts his own petition to keep the beloved institution, filled with childhood memories, open. Meanwhile, Erica is faced with frustration as Beverly takes over her wedding planning. Geoff tries to intervene by incorporating advice from a “professional” marriage counselor only to realize he should have listened to Murray and let the ladies sort it out themselves.</p>
<p><strong>Riverdale: “Chapter Ninety-Five: RIVERDALE: RIP (?)”<br />
The CW, 8pm<br />
Season Finale!</strong><br />
As the gang pick up the pieces after a rough year back in Riverdale, an incident at Pop’s forces them to make a difficult decision about the future of the town.</p>
<p><strong>The Masked Singer: “House Party”<br />
FOX, 8pm</strong><br />
Group A performers return to the stage and a wild-card singer enters the competition in the new episode “House Party.”</p>
<p><strong>Chicago Med: “Be the Change You Want to See”<br />
NBC, 8pm</strong><br />
Dylan (Adam Poss) and Will (Nick Gehlfuss) deal with a dishonest patient whose lupus is in remission; a wealthy donor makes inappropriate advances toward Stevie (Kristen Hager); and Vanessa (Asjha Cooper), Crockett (Dominic Rains) and Charles (Oliver Platt) try to convince a young woman to have life-saving surgery.</p>
<p><strong>Impossible Builds: “Skinny Skyscraper”<br />
PBS, 8pm</strong><br />
Follow the construction of the skinniest skyscraper in the world.</p>
<p><strong>MLB Playoffs: NL Wild-Card Game<br />
TBS, 8pm Live</strong><br />
The pressure is on the National League’s two wild-card playoff teams in this win-or-go-home showdown for the right to move on to the NL Division Series.</p>
<p><strong>The Wonder Years: “The Club”<br />
ABC, 8:30pm</strong><br />
Dean stumbles upon some “racy literature” and shares it with friends at school. When he is caught by the school principal, Bill and Lillian navigate uncharted territory as parents and Dean learns that manhood isn’t all it’s cracked up to be.</p>
<p><strong>The Conners: “Sober Sex, Plastic Silverware and Losing My Religion”<br />
ABC, 9pm</strong><br />
Part of Becky’s recovery program mandates she make amends with people she has lied to over the years, leading her to meet up again with former high school friend Mikey to apologize for lying to him about her living a successful life. Meanwhile, Darlene visits with Pastor Phil (Jason Alexander), and Louise continues planning her wedding.</p>
<p><strong>American Gangster Presents: Big Fifty: The Delrhonda Hood Story<br />
BET, 9pm; also streaming on BET+</strong><br />
Follow the unbelievable true story of bigger-than-life personality Delrhonda “Big Fifty” Hood (portrayed by Remy Ma), who went from street thug to respected gangster to finding redemption.</p>
<p><strong>Tough as Nails<br />
CBS, 9pm<br />
Season Premiere!</strong><br />
The reality competition series celebrating hardworking Americans who are not afraid to roll up their sleeves and get their hands dirty is back for Season 3 tonight. Phil Keoghan returns as host. CBS has already renewed <em>Tough as Nails</em> for Season 4.</p>
<p><strong>In the Dark: “Expectation Is the Root of All Heartache”<br />
The CW, 9pm<br />
Season Finale!</strong><br />
Murphy (Perry Mattfeld) finally learns the truth about what happened to Jess (Brooke Markham) and it forces her to take a closer look at who she herself has become.</p>
<p><strong>The Bradshaw Bunch<br />
E!, 9pm<br />
Season Premiere!</strong><br />
Legendary quarterback, TV personality and “girl dad” Terry Bradshaw has a new outlook on life after the global pandemic and wants to cherish every minute with his lovable family, which includes his wife Tammy and three daughters Rachel, Erin and Lacey. This season sees the Bradshaws making a return to <em>Celebrity Family Feud</em>, renewing their vows in Hawaii and on a road trip to Terry’s hometown of Shreveport, Louisiana, to walk on the high school football field where it all started.</p>
<p><strong>Alter Ego: “The Final Auditions”<br />
FOX, 9pm</strong><br />
The last five contestants compete to move on to the next round in the new episode “The Final Auditions.”</p>
<p><strong>Chicago Fire: “Counting Your Breaths”<br />
NBC, 9pm</strong><br />
Griffin learns the truth about his father’s death and reveals why he really came to visit Casey (Jesse Spencer). Meanwhile, Gallo (Alberto Rosende), Ritter (Daniel Kyri) and Violet (Hanako Greensmith) take steps to expand their microbrewery business.</p>
<p><strong>NOVA: “Particles Unknown”<br />
PBS, 9pm</strong><br />
Outnumbering atoms a billion to one, neutrinos are the universe’s most common, yet most elusive and baffling, particle. <em>NOVA </em>joins an international team of neutrino hunters whose discoveries may change our understanding of how the universe works.</p>
<p><strong>Home Economics: “Bottle Service, $800 Plus Tip (25% Suggested)”<br />
ABC, 9:30pm</strong><br />
The family is in for a wild night out when they accompany Connor to a club to help him jump-start his dating life. When Tom steps up as Connor’s wingman, things don’t exactly go as planned.</p>
<p><strong>A Million Little Things: “Game Night”<br />
ABC, 10pm</strong><br />
When the girls decide to throw Katherine a celebratory divorce party, the guys get together to watch the hockey game and distract Eddie. Maggie is blindsided by some news, while Sophie is forced to stand her ground. Eddie helps Theo with a romantic gesture for a new crush and stumbles into someone from his past.</p>
<p><strong>CSI: Vegas<br />
CBS, 10pm<br />
New Series!</strong><br />
The iconic series <em>CSI</em> is back for another go-round, this time with even more thrilling cases and the latest forensic techniques. Maxine Roby (Paula Newsome) leads a brilliant new team of investigators, and she enlists the help of old friends Gil Grissom (William Petersen) and Sara Sidle (Jorja Fox) in order to preserve and serve justice in Sin City. In the premiere episode, “Legacy,” an attack on Jim Brass (guest star Paul Guilfoyle) kicks off a twisted conspiracy targeting the Las Vegas crime lab.</p>
<p><strong>Archer<br />
FXX, 10pm<br />
Season Finale!</strong><br />
<em>Archer </em>Season 12 comes to an end with the finale episode “Mission: Difficult,” in which Archer (voice of H. Jon Benjamin) is trapped inside IIA headquarters and Barry (voice of Dave Willis) is trapped inside Other Barry.</p>
<p><strong>Chicago P.D.: “The One Next to Me”<br />
NBC, 10pm</strong><br />
Halstead’s (Jesse Lee Soffer) past resurfaces when a former Army colleague is implicated in a deadly blast. Plus, as the FBI launches an investigation into Roy’s (Michael Maize) disappearance, Upton (Tracy Spiridakos) feels the pressure of the secret she and Voight (Jason Beghe) are sharing.</p>
<h3>Thursday, Oct. 7</h3

<strong>American Gangster: Trap Queens<br />
BET+<br />
New Episodes!</strong><br />
The true-crime series returns with new episodes of its second season, detailing the criminal chronicles of some of America’s most notorious female gangsters. Narrated by hip-hop icon Lil’ Kim, <em>Trap Queens</em> tells the fascinating true stories of fierce and savvy women who hustled hard and solidified their place in the game, however illicit their means may have been. Purported crimes range from grand larceny to bank and wire fraud and drug trafficking. Not only does the series portray captivating and infamous crime tales, but they are also told by those who lived them: the queens themselves, their closest allies, family members, legal team members, reporters and law enforcement.</p>
<p><strong>House Haunters<br />
discovery+<br />
New Series!</strong><br />
During this hidden-camera real estate and home renovation prank series from the producers of <em>Impractical Jokers</em>, Anthony Anderson and his mother, Doris Bowman, will take over properties and devise hilarious gags for unsuspecting house hunters, real estate agents, handymen and even a few HGTV stars. Throughout the show, with dozens of hidden cameras in place and working from a nearby unmarked van, Anthony and Doris will scheme to scare, startle and surprise visitors to the homes — executing humorous high jinks with creepy dolls come to life, mysterious pests on the loose, home decor that has a mind of its own and seemingly haunted spaces.</p>
<p><strong>Baker’s Dozen<br />
Hulu<br />
New Series!</strong><br />
Passionate amateur bakers will go head-to-head with seasoned professionals in each episode of this competition series. Tamera Mowry-Housley and Bill Yosses host the fast-paced show that will determine which of the 13 bakers has what it takes to create the next viral baking sensation, win the golden rolling pin and take home the cash prize.</p>
<p><strong>Create the Escape<br />
Peacock<br />
New Series!</strong><br />
This series allows kids to create, design and build their very own escape rooms. With the help of design professionals, the kids will bring their rooms to life before challenging parents or family members to escape in an allotted time.</p>
<p><strong>One of Us Is Lying<br />
Peacock<br />
New Series!</strong><br />
Based on the bestselling novel by Karen M. McManus, this series follows what happens when five high schoolers walk into detention and only four make it out alive. Everyone is a suspect, and everyone has something to hide. Marianly Tejada, Cooper van Grootel, Annalisa Cochrane, Chibuikem Uche, Barrett Carnahan, Jessica McLeod and Melissa Collazo star.</p>
<p><strong>One Lane Bridge<br />
Sundance Now<br />
Season Premiere!</strong><br />
In Season 2 of this dark crime drama with a supernatural edge from New Zealand, when Detective Ariki Davis (Dominic Ona-Ariki) is trying to harness his Māori gift of matakite to save his boss Stephen Tremaine (Joel Tobeck) from attempting suicide on the infamous One Lane Bridge, he inadvertently triggers a cataclysmic chain of events — unleashing rivalries and uncovering long-buried secrets. Burdened by his second sight, Ariki’s loyalties are tested as he navigates a murder investigation rife with ulterior motives and conflicts of interest, including his own. New episodes air Thursdays.</p>
<p><strong>MLB Playoffs: AL Division Series, Game 1<br />
FS1 &amp; MLB Network, beginning at 4pm Live</strong><br />
FS1 and MLB Network split coverage of both best-of-five-game American League Division Series beginning with Game 1 today. The two series winners advance to the AL Championship Series starting Oct. 15.</p>
<p><strong>Station 19: “Can’t Feel My Face”<br />
ABC, 8pm</strong><br />
Andy and Sullivan’s relationship continues to be tested. Meanwhile, Emmett joins Dean and Vic on a mental health call, and Maya does some soul searching.</p>
<p><strong>Young Sheldon<br />
CBS, 8pm<br />
Season Premiere!</strong><br />
The adventures of young prodigy Sheldon Cooper (Iain Armitage) and his family continue as Season 5 of <em>The Big Bang Theory</em> spinoff premieres tonight.</p>
<p><strong>NFL Football: L.A. Rams at Seattle<br />
FOX &amp; NFL Network, 8pm Live</strong><br />
NFC West foes meet at Seattle’s Lumen Field as Matthew Stafford and the L.A. Rams battle Russell Wilson and the Seahawks on <em>Thursday Night Football</em>.</p>
<p><strong>Star of the Month: Lucille Ball: “Who’s That Girl? (Early Lucy)”<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Although she’s most associated with her classic television comedies, legendary actress Lucille Ball also starred in a number of feature films mostly before, but some during and after, her first TV series, the iconic 1951-57 sitcom <em>I Love Lucy</em>. You can enjoy several of Ball’s movie performances Thursday nights in October when Turner Classic Movies salutes her as its Star of the Month. Each day’s lineup continues well into the following afternoon and features at least 10 films, which are grouped by a theme. Today’s initial theme focuses on Ball’s early big-screen performances, mostly in comedies made during the 1930s, before she met eventual husband and fellow sitcom pioneer Desi Arnaz. This lineup begins with <em>I Dream Too Much</em> (1935), a romantic comedy led by Henry Fonda and Lily Pons, and featuring Ball in one of her earlier performances as a named character. Other early Lucy highlights airing today/tomorrow include Ball’s minor roles in the Katharine Hepburn/Ginger Rogers-led 1937 drama <em>Stage Door</em>, the Marx Brothers comedy <em>Room Service</em> (1938) and the Fred Astaire/Ginger Rogers musical comedy <em>Follow the Fleet</em> (1936); her first starring comedy role, as the title character in <em>The Affairs of Annabel</em> and its sequel, <em>Annabel Takes a Tour</em>, both from 1938; and plenty more. <em>— Jeff Pfeiffer</em></p>
<p><strong>Soccer: CONCACAF Men’s World Cup Qualifiers<br />
Paramount+, beginning at 8:05pm</strong><br />
Paramount+’s live coverage of the final round of the CONCACAF men’s soccer World Cup qualifying matches continues tonight with Honduras vs. Costa Rica, Mexico vs. Canada and El Salvador vs. Panama.</p>
<p><strong>United States of Al<br />
CBS, 8:30pm<br />
Season Premiere!</strong><br />
The comedy about the friendship between Marine combat veteran Riley (Parker Young) and recent immigrant Awalmir (aka Al, played by Adhir Kalyan) returns for Season 2. The premiere episode, &#8220;Promises/Wadaha,&#8221; reflects recent real-world events as Al (Adhir Kalyan) and his friends work together against a ticking clock to get Al&#8217;s sister out of Afghanistan and to safety after Kabul falls.</p>
<p><strong>Grey’s Anatomy: “Some Kind of Tomorrow”<br />
ABC, 9pm</strong><br />
Meredith seeks advice from Amelia. Meanwhile, Richard is reenergized as he takes teaching to a new level at the hospital, and Winston treats a patient suffering from kidney failure. Abigail Spencer and Peter Gallagher guest-star.</p>
<p><strong>Ghosts<br />
CBS, 9pm<br />
New Series!</strong><br />
In this new supernatural comedy, Samantha (Rose McIver) and Jay (Utkarsh Ambudkar) throw both caution and money to the wind when they decide to convert a rundown country estate they inherited into a bed and breakfast — only to find it’s inhabited by the many opinionated spirits of deceased residents who now call it home. The series debuts with two episodes tonight.</p>
<p><strong>The Outpost: “Nothing Lasts Forever”<br />
The CW, 9pm<br />
Series Finale!</strong><br />
Talon (Jessica Green) and her friends battle against the gods. Janzo (Anand Desai-Barochia), Wren (Izuka Hoyle) and Munt (Adam Johnson) fight to save the Kahvi. A ruler is crowned.</p>
<p><strong>Flipping 101 With Tarek El Moussa: “Home Over Improvement”<br />
HGTV, 9pm</strong><br />
After losing $40,000 on their last flip, couple Aryana and Hector desperately need to make a profit on their new renovation, a 2,000-square-foot home with a mother-in-law unit in Buena Park, California. Tarek El Moussa teaches them how to focus on money-savvy decisions that will still attract buyers and bring in big offers.</p>
<p><strong>Law &amp; Order: Special Victims Unit: “One More Tale of Two Victims”<br />
NBC, 9pm</strong><br />
The SVU searches for a serial rapist who preys on mothers with young children. Meanwhile, Benson (Mariska Hargitay) and Fin (Ice-T) struggle under the tightened reins of Chief McGrath (Terry Serpico).</p>
<p><strong>Marriage Boot Camp: Hip Hop Edition<br />
WE tv, 9pm<br />
Season Premiere!</strong><br />
Four hip-hop couples, including rap legend N.O.R.E., face the music at Marriage Boot Camp. Dr. Ish Major and Judge Lynn Toler help them confront lies, tears and denials, but when dark secrets are exposed, will the relationships survive?</p>
<p><strong>Bull<br />
CBS, 10pm<br />
Season Premiere!</strong><br />
Bull (Michael Weatherly) and his team must call upon all their collective experience to locate Bull’s kidnapped daughter in the Season 6 premiere episode “Gone.”</p>
<p><strong>What We Do in the Shadows: “The Siren”<br />
FX, 10pm</strong><br />
Two travelers are shipwrecked and a doll runs away from home in the new episode “The Siren.”</p>
<p><strong>Law &amp; Order: Organized Crime: “For a Few Leke More”<br />
NBC, 10pm</strong><br />
A new episode of this <em>Law &amp; Order: Special Victims Unit</em> spinoff premieres tonight. Christopher Meloni and Danielle Moné Truitt star.</p>
<h3>Friday, Oct. 8</h3>
<p><strong>Justin Bieber: Our World<br />
Amazon Prime Video</strong><br />
This film takes viewers backstage, onstage and into the private world of global superstar Justin Bieber as he prepares for a record-breaking New Year’s Eve 2020 concert. After a three-year hiatus from performing a full concert, Bieber delivers an electrifying performance on the rooftop of the Beverly Hilton Hotel for 240 invited guests — and millions of fans across the globe watching via livestream. The documentary follows Bieber and his team for the month leading up to the show as they rehearse and construct a monumental stage set, and also captures personal self-shot moments between Bieber and his wife, Hailey, through the artist’s own lens.</p>
<p><strong>Welcome to the Blumhouse<br />
Amazon Prime Video<br />
Season Finale!</strong><br />
Season 2 of the horror film anthology series concludes with <em>Madres</em>, in which Diana and Beto, a young Mexican American couple expecting their first child, move to a small town in Northern California where Beto has been offered a job managing a farm. Isolated from the community and plagued by ominous nightmares, Diana explores the rundown company ranch where she and Beto live and finds a grisly talisman and a box containing the belongings of the previous residents. Her discoveries will lead her to a truth much stranger and more terrifying than she could have possibly imagined.</p>
<p><strong>Acapulco<br />
Apple TV+<br />
New Series!</strong><br />
This 10-episode comedy series starring Eugenio Derbez, who also executive produces, tells the story of 20-something Máximo Gallardo (Enrique Arrizon), whose dream comes true when he gets the job of a lifetime as a cabana boy at the hottest resort in Acapulco. He soon realizes the job is far more complicated than he ever imagined, and in order to succeed, he must learn to navigate a demanding clientele, a mercurial mentor and a complicated home life, without losing his way to shortcuts or temptations. The series, which is told in both Spanish and English, takes place in 1984, with Derbez narrating and playing the present-day version of Gallardo.</p>
<p><strong>Get Rolling With Otis<br />
Apple TV+<br />
New Series!</strong><br />
Based on the book series by Loren Long, this animated adventure series welcomes young viewers to Long Hill Dairy Farm, home to Otis the tractor and all his friends. Otis may be little, but he has a big heart. Whenever he sees a friend in need, he hits the brakes, asks how they&#8217;re feeling and rolls into action to help.</p>
<p><strong>Ted Lasso<br />
Apple TV+<br />
Season Finale!</strong><br />
The acclaimed, Emmy-winning comedy led by Jason Sudeikis concludes Season 2.</p>
<p><strong>Eli Roth Presents: A Ghost Ruined My Life<br />
discovery+<br />
New Series!</strong><br />
Horror filmmaker Eli Roth is behind this hourlong series that relates the shocking true stories of hauntings that have left emotional (and sometimes physical) scars on those unlucky enough to have experienced them.</p>
<p><strong>Muppets Haunted Mansion<br />
Disney+</strong><br />
The Muppets’ first ever Halloween special features a star-studded Muppets cast, celebrity cameos, all-new music and spooky fun for families to enjoy together. The special takes place on Halloween night, when Gonzo is challenged to spend one very daring night in the Haunted Mansion.</p>
<p><strong>Leverage: Redemption<br />
IMDb TV<br />
New Episodes!</strong><br />
The final Season 1 episodes of this spinoff of <em>Leverage</em> are available on Amazon Prime Video’s free IMDb TV service. Over these new episodes, the Leverage team must aid a small town librarian, discredit a lifestyle and wellness guru, explore the failing memory of a legendary grifter, and more. Joining the cast in these additional episodes are guest stars LeVar Burton, James Marsters, Andrea Navedo (continuing her role as Maria Shipp), Drew Powell (reprising his role as Jack Hurley from the original <em>Leverage</em> series), Ben Thompson, Joanna Cassidy, Jon Fletcher and Brianna Brown.</p>
<p><strong>Pokémon the Movie: Secrets of the Jungle<br />
Netflix<br />
Original Film!</strong><br />
This Japanese anime film is the 23rd movie in the Pokémon universe and returns to the franchise’s traditional 2D animation style, versus the CGI of the previous entry.</p>
<p><strong>A Tale Dark &amp; Grimm<br />
Netflix<br />
New Series!</strong><br />
In this animated kids series, follow Hansel and Gretel as they walk out of their own story and into a winding and wickedly witty tale full of strange — and scary — surprises.</p>
<p><strong>Madame X<br />
Paramount+</strong><br />
Music icon Madonna is the subject of this documentary film. Shot in Lisbon, it captures one of the star’s recent sold-out world tour performances in support of her latest studio album, <em>Madame X</em>, in which she adopts the fearless title persona — a secret agent fighting for freedom. Madonna’s virtuoso performance features new music alongside previous hits and fan favorites.</p>
<p><strong>MLB Playoffs: NL Division Series, Game 1<br />
TBS, beginning at 4:30pm Live</strong><br />
TBS has exclusive coverage of both best-of-five-game National League Division Series beginning today. The two winners advance to the NL Championship Series beginning Oct. 16.</p>
<p><strong>College Football<br />
ESPN, beginning at 7pm Live</strong><br />
The Temple Owls are at the Cincinnati Bearcats in an American Athletic Conference clash, and the Stanford Cardinal are at the Arizona State Sun Devils in a Pac-12 matchup.</p>
<p><strong>Shark Tank<br />
ABC, 8pm<br />
Season Premiere!</strong><br />
More products are pitched to the team of sharks as another season begins.</p>
<p><strong>Stalked in Paradise<br />
LMN, 8pm<br />
Original Film!</strong><br />
Olivia’s career of putting photos and video of herself on stock photography websites suddenly leads to danger when a man starts stalking her and her husband. When the stalker’s delusions get out of hand, Olivia fights back to protect herself and her husband from the stalker’s outrage. Stars Chelsie Hightower, Channon Voyce and Mason D. Davis.</p>
<p><strong>A Night With Nancy Sinatra<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Nancy Sinatra, the daughter of legendary crooner Frank Sinatra, never fell under her dad’s shadow, quickly becoming a successful and beloved singer in her own right in the 1960s when she was in her 20s. Not only did Nancy’s voice become a familiar staple to music fans with hits like “These Boots Were Made for Walkin’,” but she also became a familiar presence on television and in movies throughout the ’60s with acting roles or appearances as herself. You can enjoy a few of these tonight on Turner Classic Movies. First up is the TCM premiere of <em>Movin’ With Nancy</em>, a 1967 NBC television special featuring the singer in a series of musical vignettes, often with other artists, that were performed outdoors instead of on an indoor stage, making it unique for its time. The show’s guest stars include Nancy’s father and his fellow Rat Packers Dean Martin and Sammy Davis Jr. Also appearing is Lee Hazlewood, who wrote a number of Nancy’s hits and performs memorable duets with her here on songs like “Some Velvet Morning.” The rest of the evening features Nancy in film acting roles, beginning with <em>Marriage on the Rocks</em>, a 1965 comedy led by Frank, with Nancy as his character’s daughter. Deborah Kerr and Martin also star. After that, watch Nancy’s feature-film debut in the 1964 beach party film <em>For Those Who Think Young</em>, followed by the network premiere of the 1966 spy movie spoof <em>The Last of the Secret Agents? — Jeff Pfeiffer</em></p>
<p><strong>Magnum P.I.: “The Harder They Fall”<br />
CBS, 9pm</strong><br />
Magnum (Jay Hernandez) and Higgins (Perdita Weeks) reunite to investigate the death of a construction worker in the new episode “The Harder They Fall.”</p>
<p><strong>Nancy Drew: “The Warning of the Frozen Heart”<br />
The CW, 9pm<br />
Season Premiere!</strong><br />
On the evening of Horseshoe Bay’s annual Harvest Carnival, a whole new mystery unfolds for Nancy (Kennedy McMann) when the body of a mysterious young man is discovered on the Hudson carnival grounds. The Drew Crew (Leah Lewis, Tunji Kasim and Alex Saxon) is drawn into the case by a host of confounding clues surrounding a new menace terrorizing the town — a killer who has an enigmatic connection to none other than Nancy’s newest foil: Temperance Hudson (guest star Bo Martynowska).</p>
<p><strong>Selling the Big Easy<br />
HGTV, 9pm</strong><br />
In the first of back-to-back new episodes, travel enthusiasts Vince and Margeau are officially making the move from Atlanta, Georgia, to New Orleans, Louisiana. Vince is keen on purchasing a home with unique architectural features, while Margeau is focused on generating potential income from the property. In the meantime, Brittany and her team work to give a French Quarter mansion the jaw-dropping first impression it needs to impress buyers. In the second episode, a couple is looking to leave their small starter home in the city and upsize to a larger home in the suburbs. They have different tastes, but a common goal in finding a unique place to call their forever home. Meanwhile, Brittany and her team are challenged with turning a drab condo in the highly sought-after Marigny neighborhood into a fabulous find.</p>
<p><strong>Ancient Aliens: “Top Ten Alien Artifacts”<br />
History, 9pm</strong><br />
An ancient figurine of a modern-day airplane. A primitive statue of a man in a spacesuit. Mysterious crystal skulls whose origins are entirely unknown. For more than a decade, <em>Ancient Aliens</em> has traveled the globe and investigated strange objects found on every continent on Earth. Now, this installment counts down the top 10 alien artifacts — objects that could provide evidence that extraterrestrials once walked among us.</p>
<p><strong>The 34th Hispanic Heritage Awards<br />
PBS, 9pm</strong><br />
Celebrate the recipients of the annual Hispanic Heritage Awards. The evening includes performances and appearances by some of the country’s most celebrated Hispanic artists and visionaries, with honorees including Carlos Santana, Kali Uchis and more.</p>
<p><strong>The Amber Ruffin Show<br />
Peacock, 9pm<br />
Season Premiere!</strong><br />
Amber Ruffin’s Emmy-nominated late-night series is back for Season 2, with new episodes dropping Fridays and showcasing Ruffin’s signature smart and silly take on the week&#8217;s news.</p>
<p><strong>Joe Bob’s Halloween Hoedown<br />
Shudder, 9pm Live</strong><br />
In what has become an annual tradition, iconic horror host and foremost drive-in movie critic Joe Bob Briggs returns with a special <em>The Last Drive-In</em> live double-feature just in time for Halloween. You’ll have to tune in to find out what movies Joe Bob has selected, but you can count on something scary and perfect for the season, with special guests to be announced.</p>
<p><strong>Eli Roth’s History of Horror: “Infections”<br />
AMC, 10pm</strong><br />
Horror has warned us about pandemics for years. Tonight’s episode explores films that mirror reality (<em>Outbreak</em>, <em>Contagion</em>, <em>12 Monkeys</em>), surreal plagues (<em>Shivers</em>, <em>Rabid</em>), zombie outbreaks (<em>REC</em>, <em>Pontypool</em>) and pathogens from space (<em>The Andromeda Strain</em>, <em>Color out of Space</em>).</p>
<p><strong>Blue Bloods: “Times Like These”<br />
CBS, 10pm</strong><br />
Tension escalates between Frank (Tom Selleck) and Mayor Chase (Dylan Walsh) after Frank makes a public arrest that goes viral in the new episode “Times Like These.”</p>
<p><strong>Great Performances at the Met: “Three Divas at Versailles”<br />
PBS, 10pm</strong><br />
Three-time Grammy winner Isabel Leonard joins fellow opera stars Nadine Sierra and Ailyn Pérez to perform timeless selections by Mozart, Offenbach and Bizet, including “Voi che sapete” and “Belle nuit, ô nuit d’amour,” along with beloved songs like “Bésame Mucho” and “Cielito Lindo.” The concert was recorded in May at the Royal Opera of Versailles in France; Met Opera soprano Christine Goerke hosts the broadcast.</p>
<h3>Saturday, Oct. 9</h3>
<p><strong>The Ghost and Molly McGee: “Getting the Band(shell) Back Together/The Greatest Concert Ever”<br />
Disney Channel, 9am</strong><br />
The town of Brighton gets its old band shell rebuilt, but it’s up to Molly (voice of Ashly Burch) to find a band to put on its first concert in the new episode “Getting the Band(shell) Back Together/The Greatest Concert Ever.”</p>
<p><strong>Frankie Drake Mysteries: “Prince in Exile”<br />
Ovation, 7pm</strong><br />
When a playboy prince is kidnapped, the team has to be discreet as they investigate in order to avoid an international incident.</p>
<p><strong>Whose Line Is It Anyway?<br />
The CW, 8pm<br />
Season Premiere!</strong><br />
Hosted by comedian Aisha Tyler, this comedy improv show features cast members Ryan Stiles, Wayne Brady and Colin Mochrie, who helped make the original U.S. version of this series such a hit. Along with a special guest comedian in each episode, the cast members must put their comedic skills to the test through a series of spontaneous improv games.</p>
<p><strong>Outgrown: “Room for the Family”<br />
HGTV, 8pm</strong><br />
After a death in the family, a mother and her three kids downsized to a new home that sadly has no room for a very special handmade dining table. Luke Caldwell and Clint Robertson update their cozy home to allow this family to do what they love most: hang out together.</p>
<p><strong>Dying to Belong<br />
Lifetime, 8pm<br />
Original Film!</strong><br />
A remake of the classic 1997 film, <em>Dying to Belong</em> tells the story of journalism major Olivia (Favour Onwuka) as she meets Riley (Jenika Rose), a shy freshman who suffers from anxiety, and they become fast friends. Riley, whose mother Katherine (Shannen Doherty) was a legacy at Pi Gamma Beta, decides to rush in hopes of following Katherine’s footsteps and is ecstatic when Olivia joins her. Sensing the opportunity to go undercover to write a story about hazing practices, Olivia soon discovers there are deadly secrets involved in being part of the “sisterhood.”</p>
<p><strong>Fantastic Voyage<br />
TCM, 8pm<br />
Catch a Classic!</strong><br />
During a time when there were plenty of sci-fi movies that dealt with adventures in outer space, this wildly imaginative and exciting 1966 classic dared to take viewers on a mission into the <em>inner</em> space of the human body. The film’s premise and voyage are indeed pretty fantastic in all senses of that word. In the world of this story, the science of miniaturization has been unlocked, and the Army has big plans for that technology. When a scientist carrying the secret of the process is injured in a surprise attack, however, a life-threatening blood clot puts him into a coma. A four-person team of medical and military personnel (portrayed by Raquel Welch, in her first significant film role, along with Donald Pleasence, William Redfield and Arthur Kennedy) have to use the technology to shrink themselves and a submarine down to microbic size, travel inside his body and destroy the clot. But with the body’s natural defenses fighting them, and a determined saboteur onboard, can they locate and destroy the problem before the miniaturization wears off? Stephen Boyd also stars in the film that was nominated for five Oscars and won two, for its stunning art direction and its still-impressive special effects. <em>— Jeff Pfeiffer</em></p>
<p><strong>World’s Funniest Animals<br />
The CW, 9pm<br />
Season Premiere!</strong><br />
Hilarious animal antics are back for Season 2.</p>
<p><strong>South Beach Love<br />
Hallmark Channel, 9pm<br />
Original Film!</strong><br />
From <em>New York Times</em> bestselling author Caridad Piñeiro and Hallmark Publishing comes a story about rival quinceañeras, glorious Cuban cooking, friendship, family ties and romance. Stars William Levy and Taylor Cole.</p>
<p><strong>Dr. Oakley<br />
Nat Geo Wild, 9pm<br />
Season Premiere!</strong><br />
Making house calls in the far reaches of the Great North is a daunting task to say the least, considering hundreds of miles may separate the houses. That challenge doesn’t stop Dr. Michelle Oakley from performing her many duties as a veterinarian in one of the most rugged environments on Earth, and juggling them with being a wife and mother. Season 10 of this series will again follow Dr. Oakley in action.</p>
<p><strong>Snapped Notorious: River Valley Killer<br />
Oxygen, 9pm</strong><br />
From 1993 to 2000, the quiet community of Fort Smith, Arkansas, was terrorized by a twisted serial killer, a deranged necrophiliac who targeted elderly and vulnerable women. This two-hour special examines that killer, who became known as the River Valley Killer.</p>
<p><strong>The Waiting Room<br />
BET Her, 10pm</strong><br />
Two dramatic short films follow the lives of two women in a doctor’s waiting room as they wait to hear if they have breast cancer. Each short story, directed by and for Black women, will follow their journey after receiving the life-changing diagnosis. The first film, <em>It Takes Two</em>, is directed by Ta’Rhonda Jones; the second one, <em>The Party</em>, is directed by Yvette Nicole Brown.</p>
<p><strong>Saturday Night Live: “Kim Kardashian West/Halsey”<br />
NBC, 11:30pm Live</strong><br />
TV star Kim Kardashian West makes her first appearance as <em>SNL </em>host, while Grammy-nominated Halsey is musical guest for the fourth time.</p>
	</div>
	<div class="entry-tags clearfix"><i class="fa fa-tag"></i><ul><li><a href="https://www.channelguidemag.com/tv-news/tag/nbc/" rel="tag">NBC</a></li><li><a href="https://www.channelguidemag.com/tv-news/tag/nfl/" rel="tag">NFL</a></li></ul></div>	<div id="text-771362228" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94"><img src="https://www.channelguidemag.com/wp-content/uploads/2020/05/CG-Ad_Save-66_728x90_Perry.jpg" /></a></div>
		</div></article><div id="comments" class="mh-comments-wrap">
</div>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.channelguidemag.com/tv-news/2021/10/02/saturday-oct-2-snl-owen-wilson-kacey-musgraves/" rel="prev"><img width="80" height="60" src="https://www.channelguidemag.com/wp-content/uploads/2020/10/SaturdayNightLiveBB-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" loading="lazy" srcset="https://www.channelguidemag.com/wp-content/uploads/2020/10/SaturdayNightLiveBB-80x60.jpg 80w, https://www.channelguidemag.com/wp-content/uploads/2020/10/SaturdayNightLiveBB-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="179085" data-permalink="https://www.channelguidemag.com/saturdaynightlivebb/" data-orig-file="https://www.channelguidemag.com/wp-content/uploads/2020/10/SaturdayNightLiveBB.jpg" data-orig-size="1030,438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;2019 NBCUniversal Media, LLC.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="SaturdayNightLiveBB" data-image-description="" data-image-caption="" data-medium-file="https://www.channelguidemag.com/wp-content/uploads/2020/10/SaturdayNightLiveBB-300x128.jpg" data-large-file="https://www.channelguidemag.com/wp-content/uploads/2020/10/SaturdayNightLiveBB-1024x435.jpg" /><span>Previous</span><p>Saturday, Oct. 2: &#8216;SNL&#8217; Season 47 Debuts With Host Owen Wilson and Musical Guest Kacey Musgraves</p></a></div>
</nav>
<section class="mh-related-content">
<h3 class="mh-widget-title mh-related-content-title">
<span class="mh-widget-title-inner">Related Articles</span></h3>
<div class="mh-related-wrap mh-row clearfix">
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-28321 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.channelguidemag.com/tv-news/2011/05/31/americas-got-talent-is-more-miss-than-hit/" title="&#8220;America&#8217;s Got Talent&#8221; is more miss than hit"><img class="mh-image-placeholder" src="https://www.channelguidemag.com/wp-content/themes/mh-magazine/images/placeholder-medium.png" alt="No Picture" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Game Shows			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.channelguidemag.com/tv-news/2011/05/31/americas-got-talent-is-more-miss-than-hit/" title="&#8220;America&#8217;s Got Talent&#8221; is more miss than hit" rel="bookmark">
			&#8220;America&#8217;s Got Talent&#8221; is more miss than hit		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2011/05/">May 31, 2011</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.channelguidemag.com/tv-news/author/tom-comi/">Tom Comi</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.channelguidemag.com/tv-news/category/game-shows/" rel="category tag">Game Shows</a>, <a href="https://www.channelguidemag.com/tv-news/category/music/" rel="category tag">Music</a>, <a href="https://www.channelguidemag.com/tv-news/category/reality-tv/" rel="category tag">Reality TV</a>, <a href="https://www.channelguidemag.com/tv-news/category/tv-news-program-updates/" rel="category tag">TV News &#x26; Program Updates</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2011/05/31/americas-got-talent-is-more-miss-than-hit/#comments" class="mh-comment-count-link" >2</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>By Tom Comi Pop quiz: What does Las Vegas headliner Terry Fator have in common with no-names like Bianca Ryan, Neal E. Boyd, Kevin Skinner and Michael Grimm? Answer: All of them won their respective seasons on NBC&#8217;s talent show America&#8217;s Got Talent. The difference is that only Fator (an accomplished ventriloquist) has come close to becoming a household name, and that&#8217;s only for those households who have visited the Mirage hotel and casino in Sin City. And so it goes for the talent show that portends to find the country&#8217;s hidden gems and turn them into stars. As you <a class="mh-excerpt-more" href="https://www.channelguidemag.com/tv-news/2011/05/31/americas-got-talent-is-more-miss-than-hit/" title="&#8220;America&#8217;s Got Talent&#8221; is more miss than hit">[&#8230;]</a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-122429 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.channelguidemag.com/tv-news/2015/02/14/2015-nascar-xfinity-series-tv-schedule/" title="2015 NASCAR XFINITY Series TV schedule"><img width="326" height="233" src="https://www.channelguidemag.com/wp-content/uploads/2015/02/2015NASCARXFINITY.jpg" class="attachment-mh-magazine-medium size-mh-magazine-medium wp-post-image" alt="2015 NASCAR XFINITY Series TV schedule" loading="lazy" srcset="https://www.channelguidemag.com/wp-content/uploads/2015/02/2015NASCARXFINITY.jpg 560w, https://www.channelguidemag.com/wp-content/uploads/2015/02/2015NASCARXFINITY-300x214.jpg 300w" sizes="(max-width: 326px) 100vw, 326px" data-attachment-id="122430" data-permalink="https://www.channelguidemag.com/tv-news/2015/02/14/2015-nascar-xfinity-series-tv-schedule/2015nascarxfinity/" data-orig-file="https://www.channelguidemag.com/wp-content/uploads/2015/02/2015NASCARXFINITY.jpg" data-orig-size="560,400" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Credit: Brian Lawdermilk\/NASCAR via Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="2015NASCARXFINITY" data-image-description="" data-image-caption="" data-medium-file="https://www.channelguidemag.com/wp-content/uploads/2015/02/2015NASCARXFINITY-300x214.jpg" data-large-file="https://www.channelguidemag.com/wp-content/uploads/2015/02/2015NASCARXFINITY.jpg" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Sports			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.channelguidemag.com/tv-news/2015/02/14/2015-nascar-xfinity-series-tv-schedule/" title="2015 NASCAR XFINITY Series TV schedule" rel="bookmark">
			2015 NASCAR XFINITY Series TV schedule		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2015/02/">February 14, 2015</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.channelguidemag.com/tv-news/author/ryan-berenz/">Ryan Berenz</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.channelguidemag.com/tv-news/category/sports/" rel="category tag">Sports</a>, <a href="https://www.channelguidemag.com/tv-news/category/tv-news-program-updates/" rel="category tag">TV News &#x26; Program Updates</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2015/02/14/2015-nascar-xfinity-series-tv-schedule/#comments" class="mh-comment-count-link" >7</a></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>The 2015 NASCAR XFINITY Series (formerly Nationwide Series) season begins Saturday, Feb. 21, with the Alert Today Florida 300 at Daytona International Speedway on FOX Sports 1. Full XFINITY Series schedule below: ALSO SEE: 2015 NASCAR TV schedule on FOX, FOX Sports 1, NBC and NBCSN for the Sprint Cup Series, XFINITY Series (formerly Nationwide Series) and Camping World Truck Series. 2015 NASCAR XFINITY SERIES TV SCHEDULE Schedule subject to change. Date/Race/Track/TV Network/Race Start Time (ET) Feb. 21 Alert Today Florida 300/Daytona International Speedway FS1 3:30pm Feb. 28 Hisense 250/Atlanta Motor Speedway FS1 2pm March 7 Boyd Gaming 300/Las Vegas <a class="mh-excerpt-more" href="https://www.channelguidemag.com/tv-news/2015/02/14/2015-nascar-xfinity-series-tv-schedule/" title="2015 NASCAR XFINITY Series TV schedule">[&#8230;]</a></p>
</div>	</div>
</article></div>
<div class="mh-col-1-3 mh-posts-grid-col clearfix">
<article class="post-103603 format-standard mh-posts-grid-item clearfix">
	<figure class="mh-posts-grid-thumb">
		<a class="mh-thumb-icon mh-thumb-icon-small-mobile" href="https://www.channelguidemag.com/tv-news/2014/02/24/the-voice-season-6-nbc/" title="The Voice Season 6 debuts tonight, with much to prove"><img class="mh-image-placeholder" src="https://www.channelguidemag.com/wp-content/themes/mh-magazine/images/placeholder-medium.png" alt="No Picture" />		</a>
					<div class="mh-image-caption mh-posts-grid-caption">
				Competition			</div>
			</figure>
	<h3 class="entry-title mh-posts-grid-title">
		<a href="https://www.channelguidemag.com/tv-news/2014/02/24/the-voice-season-6-nbc/" title="The Voice Season 6 debuts tonight, with much to prove" rel="bookmark">
			The Voice Season 6 debuts tonight, with much to prove		</a>
	</h3>
	<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2014/02/">February 24, 2014</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.channelguidemag.com/tv-news/author/tom-comi/">Tom Comi</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.channelguidemag.com/tv-news/category/competition/" rel="category tag">Competition</a>, <a href="https://www.channelguidemag.com/tv-news/category/music/" rel="category tag">Music</a>, <a href="https://www.channelguidemag.com/tv-news/category/tv-news-program-updates/" rel="category tag">TV News &#x26; Program Updates</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on The Voice Season 6 debuts tonight, with much to prove</span></span></span>
</div>
	<div class="mh-posts-grid-excerpt clearfix">
		<div class="mh-excerpt"><p>The Voice Season 6 starts Feb. 24 on NBC, and it&#8217;s a pivotal juncture for the popular musical competition. Cee Lo Green announced recently that he is leaving the show, marking the first deviation from the original cast of judges. Sure, we&#8217;ve seen Usher and Shakira fill in for Green and Christina Aguilera for a season — as they will again beginning tonight at 8pm ET — but this is the first scratch in the program&#8217;s armor. The second scratch could be the recent news that Aguilera is pregnant with her second child. Although NBC would obviously do everything to <a class="mh-excerpt-more" href="https://www.channelguidemag.com/tv-news/2014/02/24/the-voice-season-6-nbc/" title="The Voice Season 6 debuts tonight, with much to prove">[&#8230;]</a></p>
</div>	</div>
</article></div>
</div>
</section>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="search-2" class="mh-widget widget_search"><form role="search" method="get" class="search-form" action="https://www.channelguidemag.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="custom_html-7" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><div class='s2nPlayer k-EJmZUnNI' data-type='float'></div><script type='text/javascript' src='//embed.sendtonews.com/player3/embedcode.js?fk=EJmZUnNI&cid=9144&offsetx=0&offsety=0&floatwidth=400&floatposition=bottom-right' data-type='s2nScript'></script></div></div><div id="text-771362214" class="mh-widget widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Today&#8217;s Live Sports</span></h4>			<div class="textwidget"><iframe id="live-sports" src="https://www.channelguidemag.com/sports-on-tv/sports-live-today.php" border="0" frameborder="0" scrolling="yes" allowtransparency="true"></iframe></div>
		</div><div id="text-771362232" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362225" class="mh-widget widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Subscribe</span></h4>			<div class="textwidget"><p>&nbsp;</p>
<figure class="wp-caption aligncenter"  style="max-width: 300px">
			<img loading="lazy" class="wp-image-182358 size-full alignnone" src="https://www.channelguidemag.com/wp-content/uploads/2021/08/cover0921-300-2.jpg" alt="" width="300" height="392" srcset="https://www.channelguidemag.com/wp-content/uploads/2021/08/cover0921-300-2.jpg 300w, https://www.channelguidemag.com/wp-content/uploads/2021/08/cover0921-300-2-230x300.jpg 230w, https://www.channelguidemag.com/wp-content/uploads/2021/08/cover0921-300-2-150x195.jpg 150w" sizes="(max-width: 300px) 100vw, 300px" />		<figcaption class="wp-caption-text" >
			<span class="media-credit"><a href="https://www.channelguidemag.com/tv-news/author/contributor/">Channel Guide Contributor</a></span>		</figcaption>
	</figure>

<p><span style="display: block; font: 100% Montserrat; margin: 0 auto; max-width: 300px;">The most complete TV listings and best recommendations delivered right to your door — every month.</span></p>
</div>
		</div><div id="mh_magazine_custom_posts-10" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">In This Issue</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-182278 post type-post status-publish format-standard has-post-thumbnail category-drama category-horror category-archive tag-14448 tag-amc tag-magazine-archive tag-the-walking-dead">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2021/08/22/josh-mcdermitt-on-walking-dead-final-season-ive-always-wanted-eugene-to-die-of-old-age/" title="Josh McDermitt on &#8216;The Walking Dead&#8217; Final Season: &#8216;I&#8217;ve Always Wanted Eugene to Die of Old Age&#8217;">
										Josh McDermitt on &#8216;The Walking Dead&#8217; Final Season: &#8216;I&#8217;ve Always Wanted Eugene to Die of Old Age&#8217;									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/">August 22, 2021</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/22/josh-mcdermitt-on-walking-dead-final-season-ive-always-wanted-eugene-to-die-of-old-age/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-182208 post type-post status-publish format-standard has-post-thumbnail category-drama category-interview category-archive category-preview tag-14448 tag-starz">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2021/08/15/stephen-amell-alexander-ludwig-heels-starz/" title="Stephen Amell and Alexander Ludwig Tag Team for Hard-Hitting, Heartfelt &#8216;Heels&#8217; on Starz">
										Stephen Amell and Alexander Ludwig Tag Team for Hard-Hitting, Heartfelt &#8216;Heels&#8217; on Starz									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/">August 15, 2021</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/15/stephen-amell-alexander-ludwig-heels-starz/#comments" class="mh-comment-count-link" >1</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-182133 post type-post status-publish format-standard has-post-thumbnail category-documentary category-archive tag-14448 tag-showtime">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2021/08/06/ufo-documentary-showtime/" title="Remove the Foil Hat: UFOs Are Up for Serious Debate in Showtime Documentary Series">
										Remove the Foil Hat: UFOs Are Up for Serious Debate in Showtime Documentary Series									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/">August 6, 2021</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/06/ufo-documentary-showtime/#comments" class="mh-comment-count-link" >1</a></span>
</div>
							</div>
						</li>			</ul></div><div id="text-771362226" class="mh-widget widget_text">			<div class="textwidget"><div style="background-color:  #FF9245; font: 170% Montserrat; font-weight:bold; margin: 10px 0 0; padding: 5px 0; text-align: center;"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94" id="order-button">ORDER NOW!</a></div></div>
		</div><div id="text-771362234" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe title="Find and Remind" src="https://widgets.tvinsider.com/discover/widgets/display.cfm?widgetGUID=e76eae7a-3166-419a-9f01-b1f984cc35a5" style="max-width:300px;width:100%;height:462px;border:0;"></iframe></div></div>
<div id="wpp-6" class="mh-widget popular-posts">
<h4 class="mh-widget-title"><span class="mh-widget-title-inner">Popular Posts</span></h4>            <div class="wpp-widget-placeholder" data-widget-id="wpp-6"></div>
            
</div>
<div id="text-771362236" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362192" class="mh-widget widget_text">			<div class="textwidget"><center><!-- Medium_Rectangle_300x250 -->
<div id='div-gpt-ad-1426776676899-3'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1426776676899-3'); });
</script>
</div></center>

</div>
		</div><div id="text-771362233" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362223" class="mh-widget widget_text">			<div class="textwidget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#e8e8e8; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://channelguidemag.us4.list-manage.com/subscribe/post?u=a2d9de00dacb27b8907ecc15a&amp;id=6990079feb" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2 style="color: #f47d2a;">Email sign up!</h2>
Follow your favorite writers and/or get weekly updates to the best on TV.<br /><br />
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group input-group">
    <ul><li><input type="checkbox" value="1" name="group[2865][1]" id="mce-group[2865]-2865-0"><label for="mce-group[2865]-2865-0">5toWATCH Weekly eNewsletter</label></li>
    <li><input type="checkbox" value="131072" name="group[6821][131072]" id="mce-group[6821]-6821-0"><label for="mce-group[6821]-6821-0">Ryan Berenz posts</label></li>
<li><input type="checkbox" value="262144" name="group[6821][262144]" id="mce-group[6821]-6821-2"><label for="mce-group[6821]-6821-2">Barb Oates posts</label></li>
<li><input type="checkbox" value="524288" name="group[6821][524288]" id="mce-group[6821]-6821-3"><label for="mce-group[6821]-6821-3">Jeff Pfeiffer posts</label></li>
</ul>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_a2d9de00dacb27b8907ecc15a_6990079feb" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[6]='ADDRESS';ftypes[6]='address';fnames[7]='KEYCODE';ftypes[7]='text';fnames[3]='SUBID';ftypes[3]='text';fnames[4]='VERSION';ftypes[4]='text';fnames[5]='EXPISSUE';ftypes[5]='text';fnames[8]='EXPYEAR';ftypes[8]='text';fnames[9]='ACTIVEMO';ftypes[9]='number';fnames[10]='SFGNO';ftypes[10]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
<!--End mc_embed_signup--></div>
		</div>	</aside>	</div>
    </div>
<footer class="mh-footer" id="footer-override">
	<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
					<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-1">
				<div id="text-771362230" class="mh-footer-widget widget_text">			<div class="textwidget"><p><img alt="Channel Guide Logo" src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png" /></p>
</div>
		</div><div id="mh_magazine_social-3" class="mh-footer-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-container"><ul id="menu-social-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>				</nav></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-2">
				<div id="nav_menu-4" class="mh-footer-widget widget_nav_menu"><div class="menu-top-menu-footer-container"><ul id="menu-top-menu-footer" class="menu"><li id="menu-item-151599" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-151599"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a></li>
<li id="menu-item-151600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151600"><a href="/movies-tv/">Movies On TV</a></li>
<li id="menu-item-151601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151601"><a href="/tv-listings/">TV Listings</a></li>
<li id="menu-item-151602" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-151602"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports</a></li>
<li id="menu-item-151603" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151603"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-151604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151604"><a href="https://www.channelguidemag.com/tv-news/category/binge-watching/">Binge Watching</a></li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-3">
				<div id="nav_menu-5" class="mh-footer-widget widget_nav_menu"><div class="menu-customer-service-container"><ul id="menu-customer-service-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">SUBSCRIBE / More</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-181202"><a href="https://www.channelguidemag.com/contact-us/">Contact Us</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-4">
				<div id="text-771362218" class="mh-footer-widget widget_text">			<div class="textwidget"><p><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&amp;publ=CG&amp;key=IZX2Y93"><img src="https://www.channelguidemag.com/wp-content/uploads/2020/05/CG-Ad_Save-66_300x250_Snowpiercer.jpg" alt="Subscribe and Save" /></a></p>
</div>
		</div>			</div>
			</div>
</footer>
	<div class="mh-footer-mobile-nav"></div>
	<nav class="mh-footer-nav">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-publications-container"><ul id="menu-publications" class="menu"><li id="menu-item-151610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-151610"><a href="https://www.channelguidemag.com/">Channel Guide Magazine</a></li>
<li id="menu-item-151611" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151611"><a href="http://www.ondishmag.com">OnDISH Magazine</a></li>
<li id="menu-item-151612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151612"><a href="http://www.iwantmytvmagazine.com/">TV Weekly</a></li>
<li id="menu-item-151613" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151613"><a href="http://www.tvguidemagazine.com/">TV Guide Magazine</a></li>
<li id="menu-item-151614" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151614"><a href="http://www.view-mag.com/">VIEW Magazine</a></li>
<li id="menu-item-151615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151615"><a href="http://www.remindmagazine.com/">REMIND Magazine</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">@ 2020 Channel Guide Magazine</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.channelguidemag.com\/tv-news\/2021\/10\/03\/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc\/":182724};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/tv-news/2021/10/03/sunday-oct-3-tom-brady-buccaneers-vs-patriots-nbc/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.channelguidemag.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
				<div id="jp-carousel-loading-overlay">
			<div id="jp-carousel-loading-wrapper">
				<span id="jp-carousel-library-loading">&nbsp;</span>
			</div>
		</div>
		<div class="jp-carousel-overlay" style="display: none;">

		<div class="jp-carousel-container">
			<!-- The Carousel Swiper -->
			<div
				class="jp-carousel-wrap swiper-container jp-carousel-swiper-container jp-carousel-transitions"
				itemscope
				itemtype="https://schema.org/ImageGallery">
				<div class="jp-carousel swiper-wrapper"></div>
				<div class="jp-swiper-button-prev swiper-button-prev">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskPrev" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="9" height="12">
							<path d="M16.2072 16.59L11.6496 12L16.2072 7.41L14.8041 6L8.8335 12L14.8041 18L16.2072 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskPrev)">
							<rect x="0.579102" width="23.8823" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
				<div class="jp-swiper-button-next swiper-button-next">
					<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
						<mask id="maskNext" mask-type="alpha" maskUnits="userSpaceOnUse" x="8" y="6" width="8" height="12">
							<path d="M8.59814 16.59L13.1557 12L8.59814 7.41L10.0012 6L15.9718 12L10.0012 18L8.59814 16.59Z" fill="white"/>
						</mask>
						<g mask="url(#maskNext)">
							<rect x="0.34375" width="23.8822" height="24" fill="#FFFFFF"/>
						</g>
					</svg>
				</div>
			</div>
			<!-- The main close buton -->
			<div class="jp-carousel-close-hint">
				<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
					<mask id="maskClose" mask-type="alpha" maskUnits="userSpaceOnUse" x="5" y="5" width="15" height="14">
						<path d="M19.3166 6.41L17.9135 5L12.3509 10.59L6.78834 5L5.38525 6.41L10.9478 12L5.38525 17.59L6.78834 19L12.3509 13.41L17.9135 19L19.3166 17.59L13.754 12L19.3166 6.41Z" fill="white"/>
					</mask>
					<g mask="url(#maskClose)">
						<rect x="0.409668" width="23.8823" height="24" fill="#FFFFFF"/>
					</g>
				</svg>
			</div>
			<!-- Image info, comments and meta -->
			<div class="jp-carousel-info">
				<div class="jp-carousel-info-footer">
					<div class="jp-carousel-pagination-container">
						<div class="jp-swiper-pagination swiper-pagination"></div>
						<div class="jp-carousel-pagination"></div>
					</div>
					<div class="jp-carousel-photo-title-container">
						<h2 class="jp-carousel-photo-caption"></h2>
					</div>
					<div class="jp-carousel-photo-icons-container">
						<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-info" aria-label="Toggle photo metadata visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskInfo" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M12.7537 2C7.26076 2 2.80273 6.48 2.80273 12C2.80273 17.52 7.26076 22 12.7537 22C18.2466 22 22.7046 17.52 22.7046 12C22.7046 6.48 18.2466 2 12.7537 2ZM11.7586 7V9H13.7488V7H11.7586ZM11.7586 11V17H13.7488V11H11.7586ZM4.79292 12C4.79292 16.41 8.36531 20 12.7537 20C17.142 20 20.7144 16.41 20.7144 12C20.7144 7.59 17.142 4 12.7537 4C8.36531 4 4.79292 7.59 4.79292 12Z" fill="white"/>
									</mask>
									<g mask="url(#maskInfo)">
										<rect x="0.8125" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
							</span>
						</a>
												<a href="#" class="jp-carousel-icon-btn jp-carousel-icon-comments" aria-label="Toggle photo comments visibility">
							<span class="jp-carousel-icon">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="maskComments" mask-type="alpha" maskUnits="userSpaceOnUse" x="2" y="2" width="21" height="20">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M4.3271 2H20.2486C21.3432 2 22.2388 2.9 22.2388 4V16C22.2388 17.1 21.3432 18 20.2486 18H6.31729L2.33691 22V4C2.33691 2.9 3.2325 2 4.3271 2ZM6.31729 16H20.2486V4H4.3271V18L6.31729 16Z" fill="white"/>
									</mask>
									<g mask="url(#maskComments)">
										<rect x="0.34668" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>

								<span class="jp-carousel-has-comments-indicator" aria-label="This image has comments."></span>
							</span>
						</a>
											</div>
				</div>
				<div class="jp-carousel-info-extra">
					<div class="jp-carousel-info-content-wrapper">
						<div class="jp-carousel-photo-title-container">
							<h2 class="jp-carousel-photo-title"></h2>
						</div>
						<div class="jp-carousel-comments-wrapper">
															<div id="jp-carousel-comments-loading">
									<span>Loading Comments...</span>
								</div>
								<div class="jp-carousel-comments"></div>
								<div id="jp-carousel-comment-form-container">
									<span id="jp-carousel-comment-form-spinner">&nbsp;</span>
									<div id="jp-carousel-comment-post-results"></div>
																														<form id="jp-carousel-comment-form">
												<label for="jp-carousel-comment-form-comment-field" class="screen-reader-text">Write a Comment...</label>
												<textarea
													name="comment"
													class="jp-carousel-comment-form-field jp-carousel-comment-form-textarea"
													id="jp-carousel-comment-form-comment-field"
													placeholder="Write a Comment..."
												></textarea>
												<div id="jp-carousel-comment-form-submit-and-info-wrapper">
													<div id="jp-carousel-comment-form-commenting-as">
																													<fieldset>
																<label for="jp-carousel-comment-form-email-field">Email (Required)</label>
																<input type="text" name="email" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-email-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-author-field">Name (Required)</label>
																<input type="text" name="author" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-author-field" />
															</fieldset>
															<fieldset>
																<label for="jp-carousel-comment-form-url-field">Website</label>
																<input type="text" name="url" class="jp-carousel-comment-form-field jp-carousel-comment-form-text-field" id="jp-carousel-comment-form-url-field" />
															</fieldset>
																											</div>
													<input
														type="submit"
														name="submit"
														class="jp-carousel-comment-form-button"
														id="jp-carousel-comment-form-button-submit"
														value="Post Comment" />
												</div>
											</form>
																											</div>
													</div>
						<div class="jp-carousel-image-meta">
							<div class="jp-carousel-title-and-caption">
								<div class="jp-carousel-photo-info">
									<h3 class="jp-carousel-caption" itemprop="caption description"></h3>
								</div>

								<div class="jp-carousel-photo-description"></div>
							</div>
							<ul class="jp-carousel-image-exif" style="display: none;"></ul>
							<a class="jp-carousel-image-download" target="_blank" style="display: none;">
								<svg width="25" height="24" viewBox="0 0 25 24" fill="none" xmlns="http://www.w3.org/2000/svg">
									<mask id="mask0" mask-type="alpha" maskUnits="userSpaceOnUse" x="3" y="3" width="19" height="18">
										<path fill-rule="evenodd" clip-rule="evenodd" d="M5.84615 5V19H19.7775V12H21.7677V19C21.7677 20.1 20.8721 21 19.7775 21H5.84615C4.74159 21 3.85596 20.1 3.85596 19V5C3.85596 3.9 4.74159 3 5.84615 3H12.8118V5H5.84615ZM14.802 5V3H21.7677V10H19.7775V6.41L9.99569 16.24L8.59261 14.83L18.3744 5H14.802Z" fill="white"/>
									</mask>
									<g mask="url(#mask0)">
										<rect x="0.870605" width="23.8823" height="24" fill="#FFFFFF"/>
									</g>
								</svg>
								<span class="jp-carousel-download-text"></span>
							</a>
							<div class="jp-carousel-image-map" style="display: none;"></div>
						</div>
					</div>
				</div>
			</div>
		</div>

		</div>
		<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/wp-embed.min.js?ver=c7b5b4d1a6be1ddfc8885d67d1e1244b' id='wp-embed-js'></script>
<script type='text/javascript' id='jetpack-carousel-js-extra'>
/* <![CDATA[ */
var jetpackSwiperLibraryPath = {"url":"https:\/\/www.channelguidemag.com\/wp-content\/plugins\/jetpack\/_inc\/build\/carousel\/swiper-bundle.min.js"};
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/www.channelguidemag.com\/wp-admin\/admin-ajax.php","nonce":"cb45f82fcb","display_exif":"1","display_comments":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/www.channelguidemag.com\/6m5q187EwM\/?redirect_to=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2011%2F05%2F31%2Famericas-got-talent-is-more-miss-than-hit%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/build/carousel/jetpack-carousel.min.js?ver=10.1' id='jetpack-carousel-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.1' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202139.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.1',blog:'113259570',post:'182724',tz:'-5',srv:'www.channelguidemag.com'} ]);
	_stq.push([ 'clickTrackerInit', '113259570', '182724' ]);
</script>
</body>
</html>