<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

	<!-- This site is optimized with the Yoast SEO plugin v17.0 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Wednesday, Sept. 8: &#039;Too Soon: Comedy After 9/11&#039; Looks at Humor in a Horrific Time</title>
	<meta name="description" content="This documentary explores the sudden halt and triumphant rebirth of comedy following the cataclysmic events of Sept. 11, 2001, and the entertainers who struggled to establish humor&#039;s place." />
	<link rel="canonical" href="https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Wednesday, Sept. 8: &#039;Too Soon: Comedy After 9/11&#039; Looks at Humor in a Horrific Time" />
	<meta property="og:description" content="This documentary explores the sudden halt and triumphant rebirth of comedy following the cataclysmic events of Sept. 11, 2001, and the entertainers who struggled to establish humor&#039;s place." />
	<meta property="og:url" content="https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/" />
	<meta property="og:site_name" content="Channel Guide Magazine" />
	<meta property="article:publisher" content="https://www.facebook.com/ChannelGuideMagazine" />
	<meta property="article:published_time" content="2021-09-08T11:00:35+00:00" />
	<meta property="article:modified_time" content="2021-09-03T18:25:12+00:00" />
	<meta property="og:image" content="https://www.channelguidemag.com/wp-content/uploads/2021/09/TooSoonViceTVBB.jpg" />
	<meta property="og:image:width" content="1030" />
	<meta property="og:image:height" content="438" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Channel Guide Staff" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="27 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.channelguidemag.com/#website","url":"https://www.channelguidemag.com/","name":"Channel Guide Magazine","description":"Our writers comment on the state of TV","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.channelguidemag.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/#primaryimage","inLanguage":"en-US","url":"https://www.channelguidemag.com/wp-content/uploads/2021/09/TooSoonViceTVBB.jpg","contentUrl":"https://www.channelguidemag.com/wp-content/uploads/2021/09/TooSoonViceTVBB.jpg","width":1030,"height":438,"caption":"Too Soon: Comedy After 9/11"},{"@type":"WebPage","@id":"https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/#webpage","url":"https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/","name":"Wednesday, Sept. 8: 'Too Soon: Comedy After 9/11' Looks at Humor in a Horrific Time","isPartOf":{"@id":"https://www.channelguidemag.com/#website"},"primaryImageOfPage":{"@id":"https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/#primaryimage"},"datePublished":"2021-09-08T11:00:35+00:00","dateModified":"2021-09-03T18:25:12+00:00","author":{"@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f"},"description":"This documentary explores the sudden halt and triumphant rebirth of comedy following the cataclysmic events of Sept. 11, 2001, and the entertainers who struggled to establish humor's place.","breadcrumb":{"@id":"https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/"]}]},{"@type":"BreadcrumbList","@id":"https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.channelguidemag.com/"},{"@type":"ListItem","position":2,"name":"TV News","item":"https://www.channelguidemag.com/tv-news/"},{"@type":"ListItem","position":3,"name":"Wednesday, Sept. 8: &#8216;Too Soon: Comedy After 9/11&#8217; Looks at Humor in a Horrific Time"}]},{"@type":"Person","@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f","name":"Channel Guide Staff","image":{"@type":"ImageObject","@id":"https://www.channelguidemag.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/68b6c70392ac45a38a16ac89e1b612bb?s=96&d=blank&r=g","contentUrl":"https://secure.gravatar.com/avatar/68b6c70392ac45a38a16ac89e1b612bb?s=96&d=blank&r=g","caption":"Channel Guide Staff"},"url":"https://www.channelguidemag.com/tv-news/author/staff/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Feed" href="https://www.channelguidemag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Comments Feed" href="https://www.channelguidemag.com/comments/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v7.18.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-435360-2"  type="text/javascript" data-cfasync="false" async></script>
			<script type="text/javascript" data-cfasync="false">
				var mi_version = '7.18.0';
				var mi_track_user = true;
				var mi_no_track_reason = '';
				
								var disableStr = 'ga-disable-UA-435360-2';

				/* Function to detect opted out users */
				function __gtagTrackerIsOptedOut() {
					return document.cookie.indexOf( disableStr + '=true' ) > - 1;
				}

				/* Disable tracking if the opt-out cookie exists. */
				if ( __gtagTrackerIsOptedOut() ) {
					window[disableStr] = true;
				}

				/* Opt-out function */
				function __gtagTrackerOptout() {
					document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
					window[disableStr] = true;
				}

				if ( 'undefined' === typeof gaOptout ) {
					function gaOptout() {
						__gtagTrackerOptout();
					}
				}
								window.dataLayer = window.dataLayer || [];
				if ( mi_track_user ) {
					function __gtagTracker() {dataLayer.push( arguments );}
					__gtagTracker( 'js', new Date() );
					__gtagTracker( 'set', {
						'developer_id.dZGIzZG' : true,
						                    });
					__gtagTracker( 'config', 'UA-435360-2', {
						forceSSL:true,					} );
										window.gtag = __gtagTracker;										(
						function () {
							/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
							/* ga and __gaTracker compatibility shim. */
							var noopfn = function () {
								return null;
							};
							var newtracker = function () {
								return new Tracker();
							};
							var Tracker = function () {
								return null;
							};
							var p = Tracker.prototype;
							p.get = noopfn;
							p.set = noopfn;
							p.send = function (){
								var args = Array.prototype.slice.call(arguments);
								args.unshift( 'send' );
								__gaTracker.apply(null, args);
							};
							var __gaTracker = function () {
								var len = arguments.length;
								if ( len === 0 ) {
									return;
								}
								var f = arguments[len - 1];
								if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
									if ( 'send' === arguments[0] ) {
										var hitConverted, hitObject = false, action;
										if ( 'event' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[3] ) {
												hitObject = {
													'eventAction': arguments[3],
													'eventCategory': arguments[2],
													'eventLabel': arguments[4],
													'value': arguments[5] ? arguments[5] : 1,
												}
											}
										}
										if ( 'pageview' === arguments[1] ) {
											if ( 'undefined' !== typeof arguments[2] ) {
												hitObject = {
													'eventAction': 'page_view',
													'page_path' : arguments[2],
												}
											}
										}
										if ( typeof arguments[2] === 'object' ) {
											hitObject = arguments[2];
										}
										if ( typeof arguments[5] === 'object' ) {
											Object.assign( hitObject, arguments[5] );
										}
										if ( 'undefined' !== typeof arguments[1].hitType ) {
											hitObject = arguments[1];
											if ( 'pageview' === hitObject.hitType ) {
												hitObject.eventAction = 'page_view';
											}
										}
										if ( hitObject ) {
											action = 'timing' === arguments[1].hitType ? 'timing_complete' : hitObject.eventAction;
											hitConverted = mapArgs( hitObject );
											__gtagTracker( 'event', action, hitConverted );
										}
									}
									return;
								}

								function mapArgs( args ) {
									var arg, hit = {};
									var gaMap = {
										'eventCategory': 'event_category',
										'eventAction': 'event_action',
										'eventLabel': 'event_label',
										'eventValue': 'event_value',
										'nonInteraction': 'non_interaction',
										'timingCategory': 'event_category',
										'timingVar': 'name',
										'timingValue': 'value',
										'timingLabel': 'event_label',
										'page' : 'page_path',
										'location' : 'page_location',
										'title' : 'page_title',
									};
									for ( arg in args ) {
										if ( args.hasOwnProperty(arg) && gaMap.hasOwnProperty(arg) ) {
											hit[gaMap[arg]] = args[arg];
										} else {
											hit[arg] = args[arg];
										}
									}
									return hit;
								}

								try {
									f.hitCallback();
								} catch ( ex ) {
								}
							};
							__gaTracker.create = newtracker;
							__gaTracker.getByName = newtracker;
							__gaTracker.getAll = function () {
								return [];
							};
							__gaTracker.remove = noopfn;
							__gaTracker.loaded = true;
							window['__gaTracker'] = __gaTracker;
						}
					)();
									} else {
										console.log( "" );
					( function () {
							function __gtagTracker() {
								return null;
							}
							window['__gtagTracker'] = __gtagTracker;
							window['gtag'] = __gtagTracker;
					} )();
									}
			</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.channelguidemag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=7d701376d6f2bb258bc61e61c3f12ef5"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.channelguidemag.com/wp-includes/css/dist/block-library/style.min.css?ver=7d701376d6f2bb258bc61e61c3f12ef5' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://www.channelguidemag.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.16' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://www.channelguidemag.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=7d701376d6f2bb258bc61e61c3f12ef5' type='text/css' media='all' />
<link rel='stylesheet' id='media-credit-css'  href='https://www.channelguidemag.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.4.1' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/style.css?ver=7d701376d6f2bb258bc61e61c3f12ef5' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine-child/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans:300,400,400italic,600,700,700italic%7cMontserrat:300,400,400italic,600,700,700italic' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=10.0' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/css/jetpack.css?ver=10.0' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.channelguidemag.com","hash_tracking":"false","ua":"UA-435360-2"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=7.18.0' id='monsterinsights-frontend-script-js'></script>
<script type='application/json' id='wpp-json'>
{"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/www.channelguidemag.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/www.channelguidemag.com\/wp-json\/wordpress-popular-posts","ID":182428,"token":"52179cf19d","lang":0,"debug":0}
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp.min.js?ver=5.4.1' id='wpp-js-js'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3' id='mh-scripts-js'></script>
<link rel="https://api.w.org/" href="https://www.channelguidemag.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.channelguidemag.com/wp-json/wp/v2/posts/182428" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.channelguidemag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.channelguidemag.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p7FdZg-Lso' />
<link rel="alternate" type="application/json+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2021%2F09%2F08%2Fwednesday-sept-8-too-soon-comedy-after-911-vice-tv%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2021%2F09%2F08%2Fwednesday-sept-8-too-soon-comedy-after-911-vice-tv%2F&#038;format=xml" />
        <style>
            @-webkit-keyframes bgslide {
                from {
                    background-position-x: 0;
                }
                to {
                    background-position-x: -200%;
                }
            }

            @keyframes bgslide {
                    from {
                        background-position-x: 0;
                    }
                    to {
                        background-position-x: -200%;
                    }
            }

            .wpp-widget-placeholder {
                margin: 0 auto;
                width: 60px;
                height: 3px;
                background: #dd3737;
                background: -webkit-gradient(linear, left top, right top, from(#dd3737), color-stop(10%, #571313), to(#dd3737));
                background: linear-gradient(90deg, #dd3737 0%, #571313 10%, #dd3737 100%);
                background-size: 200% auto;
                border-radius: 3px;
                -webkit-animation: bgslide 1s infinite linear;
                animation: bgslide 1s infinite linear;
            }
        </style>
        <style type="text/css">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</style>
<style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Montserrat", sans-serif; }
body { font-family: "Droid Sans", sans-serif; }
</style>
<link rel="amphtml" href="https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/amp/"><link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-270x270.png" />


<script src="https://cmp.osano.com/16BcscRpZUDCE2Y0Z/0b6a2128-f6bd-4fa8-b909-5ed16896e933/osano.js"></script>



<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
var mapping2 = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot2= googletag.defineSlot('/4370989/CGM-lead-bottom-flex', [320,50], 'div-gpt-ad-1426776676899-0').
defineSizeMapping(mapping2).
addService(googletag.pubads()).
setCollapseEmptyDiv(true);
var mapping = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot1= googletag.defineSlot('/4370989/cgm-lead-flexible-top', [320,50], 'div-gpt-ad-1426776676899-1').
defineSizeMapping(mapping).
addService(googletag.pubads());

googletag.defineSlot('/4370989/Medium_Rectangle_2_internal_ads', [300, 250], 'div-gpt-ad-1426776676899-2').addService(googletag.pubads());
googletag.defineSlot('/4370989/Medium_Rectangle_300x250', [300, 250], 'div-gpt-ad-1426776676899-3').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-182428 single-format-standard mh-boxed-layout mh-right-sb mh-loop-layout2 mh-widget-layout2" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<a class="mh-header-image-link" href="https://www.channelguidemag.com/" title="Channel Guide Magazine" rel="home">
<img class="mh-header-image" src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png" height="139" width="496" alt="Channel Guide Magazine" />
</a>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-99135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99135"><a href="/tv-listings/">TV Listings</a></li>
<li id="menu-item-151619" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-151619"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a>
<ul class="sub-menu">
	<li id="menu-item-99133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99133"><a href="https://www.channelguidemag.com/movies-tv/">Movies on TV</a></li>
	<li id="menu-item-154098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154098"><a href="https://www.channelguidemag.com/tv-news/category/vod/">New to On Demand &#038; DVD</a></li>
</ul>
</li>
<li id="menu-item-151620" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151620"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-99134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-99134"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports on TV</a>
<ul class="sub-menu">
	<li id="menu-item-152175" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152175"><a href="https://www.channelguidemag.com/sports-on-tv/">This Week&#8217;s Schedule</a></li>
</ul>
</li>
<li id="menu-item-151622" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151622"><a href="/network-contacts/">How to contact a Network</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-customer-service-container"><ul id="menu-customer-service" class="menu"><li id="menu-item-151605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">SUBSCRIBE / More</a>
<ul class="sub-menu">
	<li id="menu-item-151606" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li id="menu-item-151607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li id="menu-item-151608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li id="menu-item-181202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-181202"><a href="https://www.channelguidemag.com/contact-us/">Contact Us</a></li>
	<li id="menu-item-151609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li id="menu-item-156378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-151616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-151617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-151618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>

<div class="mh-wrapper clearfix">
<span class='mh-best-bets-caption'>TV Best Bets</span>	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content"><article id="post-182428" class="post-182428 post type-post status-publish format-standard has-post-thumbnail hentry category-tv-best-bets">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Wednesday, Sept. 8: &#8216;Too Soon: Comedy After 9/11&#8217; Looks at Humor in a Horrific Time		</h1>
		<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/09/">September 8, 2021</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.channelguidemag.com/tv-news/author/staff/">Channel Guide Staff</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/" rel="category tag">TV Best Bets</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Wednesday, Sept. 8: &#8216;Too Soon: Comedy After 9/11&#8217; Looks at Humor in a Horrific Time</span></span></span>
</div>
	</header>
		<div class="entry-content clearfix"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-182428" class="share-facebook sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-182428" class="share-pinterest sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-182428" class="share-twitter sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<figure class="entry-thumbnail">
<img src="https://www.channelguidemag.com/wp-content/uploads/2021/09/TooSoonViceTVBB-678x381.jpg" alt="Too Soon: Comedy After 9/11" title="TooSoonViceTVBB" />
<span class="media-credit">Vice TV/Pulse Films</span></figure>
<p><strong>All Times Eastern. <a href="https://www.pbs.org/" target="_blank" rel="noopener">PBS</a> programming varies regionally.</strong></p>
<h2><strong>Wednesday, Sept. 8</strong></h2>
<p><strong><a href="https://toosoondoc.com/" rel="noopener" target="_blank">Too Soon: Comedy After 9/11</a><br />
Vice, 9pm</strong><br />
This documentary explores the sudden halt and triumphant rebirth of comedy following the cataclysmic events of Sept. 11, 2001. The entertainers who struggled to establish humor’s place in a post-9/11 world narrate the special, which features interviews with David Cross, Janeane Garofalo, Marc Maron, Matthew Broderick, Aasif Mandvi, Rob Riggle, Nathan Lane, Gilbert Gottfried, Cedric the Entertainer, Chris Kattan, Lewis Black, Doug Stanhope, Jimmy Carr, Russell Peters and many more.</p>
<blockquote class="twitter-tweet" data-width="500" data-dnt="true">
<p lang="en" dir="ltr">I can&#39;t wait for y&#39;all to see this five year labor of love on the small screen via <a href="https://twitter.com/VICETV?ref_src=twsrc%5Etfw">@VICETV</a> or the big screen at <a href="https://twitter.com/danceswithfilms?ref_src=twsrc%5Etfw">@danceswithfilms</a>. <a href="https://twitter.com/hashtag/TooSoonDoc?src=hash&amp;ref_src=twsrc%5Etfw">#TooSoonDoc</a> <a href="https://twitter.com/hashtag/IndieFilmmaker?src=hash&amp;ref_src=twsrc%5Etfw">#IndieFilmmaker</a><a href="https://t.co/KKVlgjXuxp">https://t.co/KKVlgjXuxp</a></p>
<p>&mdash; Nick Fituri Scown (@nicoliorama) <a href="https://twitter.com/nicoliorama/status/1427696465380405248?ref_src=twsrc%5Etfw">August 17, 2021</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p><strong>Doogie Kamealoha, M.D.<br />
Disney+<br />
New Series!</strong><br />
For 16-year-old prodigy Dr. Lahela “Doogie” Kamealoha (Peyton Elizabeth Lee), surfing with her chill dad (Jason Scott Lee), trying to ace her driver’s test and jolting a man’s dislocated hip back into place is just another day. This spirited update of the Neil Patrick Harris coming-of-age drama <em>Doogie Howser, M.D.</em> — shot on location in Hawaii — takes place in a world where that 1989–93 series once aired. In fact, that’s how Lahela got her nickname at the hospital where her mom (Kathleen Rose Perkins) is also her boss. Doogie is “a bit like a superhero, but her power is her big brain,” says exec producer Kourtney Kang. “She’s not afraid to be the smartest person in the room.” Other nods to the original <em>Doogie</em> include the same theme song (now played on the ukulele!) and Lahela keeping a video journal. Will Harris make an appearance? Kang, who worked with the actor on <em>How I Met Your Mother</em>, is hopeful. “He said, ‘Season 2!’”</p>
<p><strong>Wu-Tang: An American Saga<br />
Hulu<br />
Season Premiere!</strong><br />
In Season 2 of this fictionalized version of the formation of hip-hop group Wu-Tang Clan, the Clan is disillusioned with life in the projects, and Bobby (Ashton Sanders) knows that success in the music industry could be their ticket to better lives. But getting the Clan members to drop everything for music isn’t easy. The resentment between Dennis (Siddiq Saunderson), Sha (Shameik Moore), Power (Marcus Callender) and Divine (Julian Elijah Martinez) still runs deep, while the other Clan members struggle dealing with inner city life. This time around, Bobby is dedicated to authenticity, and though he knows he can lead his crew through the challenges of the music business, the Clan’s fractures may prove too much to overcome. The first three episodes drop today; subsequent new episodes will be available Wednesdays.</p>
<p><strong>The Circle<br />
Netflix<br />
Season Premiere!</strong><br />
In Season 3, a fresh crew of flirts, fibbers and honest allies join the Circle — and navigate new twists and turns — in hopes of winning this season’s cash prize. New episodes are available weekly.</p>
<p><strong>Soccer: CONCACAF Men’s World Cup Qualifiers<br />
Paramount+, beginning at 7:30pm Live</strong><br />
Paramount+’s live coverage of the final round of the CONCACAF men’s soccer World Cup qualifying matches continues. Tonight’s matches are Canada vs. El Salvador, Costa Rica vs. Jamaica, Panama vs. Mexico and Honduras vs. United States. The action is bookended by pre- and post-match shows.</p>
<p><strong>Riverdale: “Chapter Ninety-One: The Return of the Pussycats”<br />
The CW, 8pm</strong><br />
After going MIA during the middle of her world tour, megastar Josie McCoy (guest star Ashleigh Murray) returns to Riverdale unexpectedly. But it’s not until she reunites with her former bandmates Valerie (guest star Hayley Law) and Melody (guest star Asha Bromfield) that she opens up about the real reason why she’s back. Elsewhere, Veronica (Camila Mendes) gets creative after a surprise visit from her old friend Alexandra Cabot (guest star Camille Hyde).</p>
<p><strong>Curb Appeal Xtreme<br />
HGTV, 8pm<br />
New Series!</strong><br />
HGTV’s popular outdoor renovation show <em>Curb Appeal</em> will get a fresh spin in <em>Curb Appeal Xtreme</em>. The new series will combine the architectural and design savvy of John Gidding, the horticulture and landscape design genius of Jamie Durie, and the custom carpentry and furniture wizardry of Rachel Taylor as they dramatically overhaul the front and backyards of homes in Nashville, Tennessee.</p>
<p><strong>America’s Got Talent: “Semifinals Results 2”<br />
NBC, 8pm Live</strong><br />
Five acts from among last night’s performances will move on to the finals. Viewers can send their favorite performer to the next round by using the <em>America’s Got Talent</em> official app or going to nbc.com to vote.</p>
<p><strong>Directed by Mike Nichols<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Mike Nichols, who went from success directing stage plays to fame that was at least as equal as a film director, is the focus of tonight’s Turner Classic Movies lineup. It begins with one of Nichols’ most famous films, the 1967 Best Picture Oscar-nominated comedy/drama <em>The Graduate</em>, which won him a Best Director Oscar in what was just the second movie he directed. Following that is a 2016 installment of PBS’ <em>American Masters</em> biographical documentary series about Nichols. The films then pick up again with Nichols’ directorial debut, <em>Who’s Afraid of Virginia Woolf?</em> (1966), the Best Picture Oscar-nominated, Elizabeth Taylor/Richard Burton-led adaptation of Edward Albee’s play that earned Nichols his first Best Director Oscar nomination. The evening winds up with <em>Gilda Live</em> (1980), Nichols’ documentary film that captured comedian/actress Gilda Radner’s one-woman show performance of <em>Gilda Radner Live on Broadway</em>.</p>
<p><strong>Family Game Fight!: “The Collins Family vs. the Bailey Family”<br />
NBC, 9pm</strong><br />
A new episode of Kristen Bell and Dax Shepard’s game show premieres tonight.</p>
<p><strong>Good Trouble: “Closing Arguments”<br />
Freeform, 9:30pm<br />
Season Finale!</strong><br />
In this 90-minute season finale, Callie (Maia Mitchell) questions her choices, Mariana (Cierra Ramirez) interviews for a new job, Malika (Zuri Adele) considers an offer away from DPN, Gael (Tommy Martinez) is forced to put his priorities into perspective, and Alice (Sherry Cola) must make a tough decision.</p>
<p><strong>Memory Box: Echoes of 9/11<br />
MSNBC, 10pm; also streams on Peacock</strong><br />
In the months following America’s worst terror attack, a simple video booth recorded the thoughts, feelings, fears and eyewitness testimonies of more than 500 Americans. Now, 20 years later, these same voices return to reflect on the past two decades in this special, which brings to the screen their collective, untold and hugely relevant story.</p>
<p><strong>Future of Work: “Futureproof”<br />
PBS, 10pm</strong><br />
How can we predict job growth, training needs and the role of education to prepare for the work of the future? What are the challenges and consequences of the pandemic and America’s racial and economic disparities?</p>
<p><strong>Crowning New York<br />
Smithsonian Channel, 10pm</strong><br />
After the devastating attacks of 9/11, New York City needed to rebuild itself emotionally, spiritually and physically. The site where the Twin Towers once stood was now a gaping pit, and the entire world watched to see what, if anything, could fill the void. Witness the story of One World Trade Center, one of the most significant, and dangerous, construction jobs ever launched. From brazen designs and heated debates to dangerous tasks at dizzying heights, we detail every step of this towering, poignant achievement.</p>
<p><strong>My Feet Are Killing Me<br />
TLC, 10pm</strong><br />
When a man who urinates on his feet, a patient with twisted toes and a woman who says she walks like a clodhopper visit the doctors, they are faced with shock — and wet socks.</p>
<h3><strong>Thursday, Sept. 9</strong></h3>
<p><strong>Kin<br />
AMC+<br />
New Series!</strong><br />
This eight-episode family-driven Irish crime drama charts the lives of a fictional Dublin family — the Kinsellas, a small but tight-knit crime family who are increasingly at odds with the powerful drug cartel led by Eamon Cunningham (Ciarán Hinds). When the hotheaded son of Kinsella patriarch Frank (Aidan Gillen) gets into a violent confrontation with one of Eamon’s men, the Cunninghams retaliate, resulting in a full-blown war. Amanda (Clare Dunne) enlists her brother-in-law, Michael (Charlie Cox) — recently returned from prison — to help her take down Eamon. Michael simply wishes to stay on the straight and narrow so he can reconnect with his estranged daughter, Anna. But family loyalty always wins, and Michael is soon thrust back into the brutal crime world. New episodes are available Thursdays.</p>
<p><strong>All the Queen’s Men<br />
BET+<br />
New Series!</strong><br />
One of the first shows from Tyler Perry Studios’ scripted development arm, this drama is based on the book <em>Ladies Night</em> by actor Christian Keyes (who also wrote the series and portrays a hitman known as “The Concierge”) and is set in the world of male exotic dancing in Atlanta. It centers around the life of Marilyn “Madam” DeVille (Eva Marcille). Madam is a fierce businesswoman who is at the top of her game in the nightclub industry and is surrounded by a band of trusted employees who are down to make sure that she is successful. But Madam, a self-proclaimed boss, soon discovers that more money and more power mean more problems. Will Madam retain reign as she navigates this dangerous and sexy society? Will the sensuous world of exotic dancing cost Madam her queendom and potentially her life? All 10 hourlong episodes are available today.</p>
<p><strong>No Responders Left Behind<br />
discovery+</strong><br />
Shot over five years, this documentary follows former <em>Daily Show</em> host Jon Stewart, first responder and 9/11 social activist John Feal, and FDNY hero Ray Pfeifer as they take on the U.S. government to get healthcare and benefits for the thousands of first responders who are suffering with life-threatening and financially devastating illnesses from toxins released at Ground Zero after 9/11.</p>
<p><strong>Blood Brothers: Malcolm X &amp; Muhammad Ali<br />
Netflix</strong><br />
This film is billed as the definitive documentary about icons Malcolm X and Muhammad Ali, and features never-before-seen archival footage. The feature is inspired by the book <em>Blood Brothers: The Fatal Friendship Between Muhammad Ali and Malcolm X</em> by Randy Roberts and Johnny Smith.</p>
<p><strong>Behind the Music<br />
Paramount+<br />
Season Finale!</strong><br />
The reimagined music docuseries ends its first season with a profile of rapper Joseph Antonio Cartagena, better known by his stage name Fat Joe.</p>
<p><strong>American Ninja Warrior Junior<br />
Peacock<br />
Season Premiere!</strong><br />
In Season 3, the competition series is taking the nation’s top junior athletes and putting them on the world’s most iconic course to compete on some of the most challenging obstacles yet. They’ll put their mental and physical strength to the test as they go head-to-head in extra-competitive, extra-inspiring and extra-fun races. All of these junior athletes will bring their best ninja skills, indomitable spirits and fearless attitudes to the course, but only three of them will become the next <em>American Ninja Warrior Junior</em> champions. The first two episodes drop today; subsequent new episodes will be available Thursdays.</p>
<p><strong>Frogger<br />
Peacock<br />
New Series!</strong><br />
Cohosted by Damon Wayans Jr. and Kyle Brandt, this physical competition series is based on the classic 1981 video game Frogger, in which a player maneuvers a frog across a busy highway and a rushing river, avoiding all kinds of obstacles to get it safely home. This show brings Frogger to life and supersizes it on an epic course. Audiences and contestants alike will be transported into a wild and whimsical world filled with all the simple but challenging elements found in the game. The first three episodes drop today; subsequent new episodes will be available Thursdays.</p>
<p><strong>Top Chef Family Style<br />
Peacock<br />
New Series!</strong><br />
This family culinary competition features the most talented young chefs from across the country who will battle it out to prove that their skills are aged to perfection. The kitchen prodigies will each pair up with an adult family member who will serve as their sous chef. Together, the chef duos will compete in a series of exciting Quickfire and Elimination Challenges. Grammy-winning artist Meghan Trainor hosts, with acclaimed chef Marcus Samuelsson serving as head judge. The first two episodes drop today; subsequent new episodes will be available Thursdays.</p>
<p><strong>Dead Places<br />
Sundance Now &amp; ALLBLK<br />
U.S. Premiere Series!</strong><br />
This South African thriller follows author Will Stone (Anthony Oseyemi), who has devoted his career to solving paranormal cases but now returns home to South Africa to investigate the biggest mystery of his life: his sister’s death in a water canal 20 years earlier.</p>
<p><strong>TCM Spotlight: The Greatest Stories Ever Rolled<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Airing films about roller skating or featuring famous roller-skating scenes will be how Turner Classic Movies rolls starting tonight and continuing the next two Thursday evenings. Incredibly, <em>Xanadu</em> somehow does not appear on any of the nights, but there are still some great titles. One of those is tonight’s leadoff film, filmmaker/star Charlie Chaplin’s comedy classic <em>Modern Times</em>, which, despite being produced in 1936, is a silent film. One scene famously finds Chaplin’s Little Tramp character roller skating on the fourth floor of a department store while blindfolded, unaware that he is consistently and dangerously close to the edge of a long drop (clever visual effects ensured Chaplin was actually in no danger, but still makes it hilariously harrowing for the audience to watch). Chaplin and his roller-skating skills return in the following film, a silent production that was actually made during the silent era — <em>The Rink</em> (1916). Here, a skating party at the title location turns into chaos. Finally, in <em>Shall We Dance</em> (1937), Fred Astaire and Ginger Rogers, not content to make most of us envious of the dancing skills they display when they are just in their shoes, really show off with a famous comic tap dance number performed while they are wearing roller skates at a Central Park rink, to the tune of George and Ira Gershwin’s “Let’s Call the Whole Thing Off.” <em>— Jeff Pfeiffer</em></p>
<p><strong>Heartland<br />
UPtv, 8pm<br />
Season Finale!</strong><br />
In “Staying the Course,” the Season 14 finale of the long-running Canadian dramedy, while Amy (Amber Marshall) works with a challenging horse to help a friend of Clint’s (Greg Lawson), she also revives a dream to rebuild the jumping course that she and Spartan practiced on so many years ago. Meanwhile, Lou (Michelle Morgan) learns that Peter (Gabriel Hogan) won’t attend her upcoming wedding and, surprised by her emotional reaction, she is forced to face a realization about their relationship. This “supersized” episode will include exclusive bonus content following its conclusion.</p>
<p><strong>NFL Football: Dallas at Tampa Bay<br />
NBC, 8:20pm Live</strong><br />
The NFL regular season kicks off tonight on NBC at Raymond James Stadium in Tampa, Florida, as Dak Prescott and the Dallas Cowboys visit Tom Brady and the Super Bowl LV champion Tampa Bay Buccaneers.</p>
<p><strong>Christina on the Coast: “Reno Before Wedding”<br />
HGTV, 9pm</strong><br />
Christina Haack takes on a kitchen redesign for a pair of elementary school sweethearts on an expedited schedule. She must race to finish this major renovation before the couple’s imminent wedding!</p>
<p><strong>Paranormal Caught on Camera<br />
Travel Channel, 9pm<br />
New Episodes!</strong><br />
In tonight’s episode, a shop owner in Mexico loses customers to a haunted piñata; a man in Russia is driven out of an abandoned house by an angry poltergeist; and could a woman in California be an actual UFO magnet?</p>
<p><strong>The Hustler: “A Real Imposter at Work”<br />
ABC, 10pm</strong><br />
Five new competitors join host Craig Ferguson in this mind-bending and enigmatic game show where motorcycles and moon cycles are clues to discovering The Hustler.</p>
<p><strong>What We Do in the Shadows: “Gail”<br />
FX, 10pm</strong><br />
An old flame returns and an ancient vehicle is resurrected in the new episode “Gail.”</p>
<p><strong>First Ladies Revealed: “In Times of War”<br />
Smithsonian Channel, 10pm</strong><br />
Every first lady has their own tale to tell, and this series examines some of the women who left their indelible mark on the White House and in history. Celebrate three first ladies who helped the country through the Civil War, World War II, and 9/11.</p>
<p><strong>True Crime Story: It Couldn’t Happen Here<br />
SundanceTV, 10pm; also streams on AMC+<br />
New Series!</strong><br />
The first series to premiere as part of SundanceTV’s new <em>True Crime Story</em> franchise, the six-part <em>It Couldn’t Happen Here</em> follows actress Hilarie Burton Morgan (<em>One Tree Hill</em>), a small-town native and advocate, as she visits different small towns in an effort to shine a much-needed light on the unique ways in which crime impacts rural communities and their judicial systems. In each episode, Morgan hears the facts of a murder case from family members and local insiders in an attempt to understand the challenges the community faced investigating the crime, learn the lasting impact the crime has had on the fabric of the town and ultimately call attention to where justice currently stands.</p>
<p><strong>Long Island Medium: In Memory of 9/11<br />
TLC, 10pm</strong><br />
Medium Theresa Caputo will use her gift to bring peace to those most personally impacted by the 9/11 attacks by meeting with them in the shadow of the World Trade Center, steps from the Pentagon and at the Flight 93 National Memorial near Shanksville, Pennsylvania. Theresa delivers messages of healing and heroism from the spirits of their loved ones.</p>
<h3><strong>Friday, Sept. 10</strong></h3>
<p><strong>LuLaRich<br />
Amazon Prime Video<br />
New Miniseries!</strong><br />
This four-part docuseries offers a deep dive into the ups and downs of the notorious multilevel-marketing company LuLaRoe, known for its over-the-top leggings.</p>
<p><strong>The Voyeurs<br />
Amazon Prime Video<br />
Original Film!</strong><br />
In this erotic thriller, when Pippa (Sydney Sweeney) and Thomas (Justice Smith) move into their dream apartment, they notice that their windows look directly into the apartment opposite — inviting them to witness the volatile relationship of the attractive couple across the street. But when they attempt to anonymously intercede in their lives, they unwittingly set in motion a chain of events that will lead to disaster.</p>
<p><strong>Come From Away<br />
Apple TV+</strong><br />
This is a filmed version of the Tony-winning musical set in the immediate aftermath of the events of Sept. 11, 2001.</p>
<p><strong>Shock Docs: “The Curse of Lizzie Borden”<br />
discovery+</strong><br />
In this new <em>Shock Docs</em> special, Dave Schrader and a team of other paranormal experts investigate whether a dark family curse led to the most infamous axe murders of all time. With new evidence that Lizzie Borden’s ghost resides in the house where the murders took place, the team conducts a séance to unearth the truth.</p>
<p><strong>SparkShorts: “Twenty Something”<br />
Disney+<br />
Original Film!</strong><br />
This short film from Pixar Animation Studios’ SparkShorts program is about the insecurities of “adulting” and how we all just fake it till we make it.</p>
<p><strong>Malignant<br />
HBO Max<br />
Feature Film Exclusive!</strong><br />
Director James Wan, architect of the <em>Conjuring</em> universe, returns to his horror roots with this film about a woman (Annabelle Wallis) who is paralyzed by shocking visions of grisly murders. Her torment worsens as she discovers that these waking dreams are, in fact, terrifying realities. The film also debuts in theaters today, and streams on HBO Max for 31 days from today.</p>
<p><strong>Pretty Hard Cases<br />
IMDb TV<br />
New Series!</strong><br />
This fun and irreverent buddy-cop drama from Canada follows two radically different 40-something female detectives (Meredith MacNeill and Adrienne C. Moore) who team up to take down a drug-dealing Toronto street gang.</p>
<p><strong>Making Modern<br />
Magnolia Network on discovery+<br />
New Series!</strong><br />
Married duo Brooke and Brice Gilliam flip the script on traditional home renovation roles, and as more clients seek out their work, they take a leap of faith to launch a home remodeling business.</p>
<p><strong>Kate<br />
Netflix<br />
Original Film!</strong><br />
After she is poisoned, a ruthless assassin (Mary Elizabeth Winstead) has less than 24 hours to exact revenge on her enemies and in the process forms an unexpected bond with the daughter of one of her past victims. Woody Harrelson also stars.</p>
<p><strong>Lucifer<br />
Netflix<br />
Season Premiere!</strong><br />
In the sixth and final season of the popular drama, the devil himself, Lucifer (Tom Ellis), has become God … almost. Why is he hesitating? And as the world starts to unravel without a God, what will he do in response? Netflix advises fans to “bring tissues” for this bittersweet goodbye to Lucifer, Chloe (Lauren German), Amenadiel (D.B. Woodside), Maze (Lesley-Ann Brandt), Ella (Aimee Garcia), Linda (Rachael Harris) and Dan (Kevin Alejandro).</p>
<p><strong>Metal Shop Masters<br />
Netflix<br />
New Series!</strong><br />
Sparks fly and tensions flare in this fierce and fiery six-episode competition between seven of America’s top welding legends, hosted by Jo Koy. These iron men and women race against the clock in challenging builds ranging from epic, one-of-a-kind grills to futuristic vehicles, all judged on both form and function.</p>
<p><strong>Days of Our Lives: Beyond Salem<br />
Peacock<br />
Miniseries Finale!</strong><br />
The first original <em>Days of Our Lives</em> special limited event series concludes as its fifth and final episode drops today.</p>
<p><strong>9/11: The Legacy<br />
History, 7pm</strong><br />
More than 72 million children woke up the morning of Sept. 11, 2001, to what seemed like an ordinary Tuesday; by the end, eight had lost their lives and more than 3,000 had lost their parents. This poignant hourlong documentary shares extraordinary stories of resilience and healing from the children impacted on 9/11 — their lives and legacy 20 years later. It encapsulates the tragic event through these now young adults, who describe what they thought it meant then versus now, and how the experience altered their lives forever.</p>
<p><strong>The Smurfs<br />
Nickelodeon, 7:30pm<br />
New Series!</strong><br />
This original series marks the return of the globally renowned characters to television for the first time since the original series ended in 1989 and follows Papa Smurf, Smurfette, Brainy, Hefty, Clumsy and the other inhabitants of Smurf Village on all-new adventures, packed with humor, heart and high-stakes action. In the premiere episode, “Smurf-Fu,” when Smurfette rescues Brainy from a giant snake, the other Smurfs ask her to teach them “Smurf-Fu.”</p>
<p><strong>Rise and Fall: The World Trade Center<br />
History, 8pm</strong><br />
Through a unique architectural and engineering lens, this two-hour documentary takes a chronological look at the conception, construction and destruction of the World Trade Center towers. Witness the evolution of this innovative sky-high complex from early designs to overcoming technical challenges to its heart-wrenching collapse. The film covers the first terrorist attack on the WTC during the 1993 bombing and unpacks, in vivid detail, a timeline of how and why the building fell after terrorists flew commercial airliners into them on 9/11.</p>
<p><strong>Bury the Past<br />
LMN, 8pm<br />
Original Film!</strong><br />
Alice was married to a deranged, abusive man — a police officer who was regarded as a pillar of the community but was secretly a monster. After Alice killed him in self-defense, and fearing her story would never be believed, she fled and went into hiding. But now an old police buddy of her dead husband is on her porch. He has tracked her down and wants money to keep silent. Stars Sarah Allen, Damon Runyan and Matt Wells.</p>
<p><strong>Return of the Taliban: A Vice Special Report<br />
Showtime, 8pm</strong><br />
This hourlong special looks at the current Taliban takeover in Afghanistan. Correspondents Hind Hassan, Ben Solomon, Seb Walker and Isobel Yeung report from the ground in Afghanistan and surrounding areas — including exclusive footage and interviews captured before and after the takeover — and provide a deeper look at the militant group that seized control of the country in 11 days, following the U.S. military withdrawal.</p>
<p><strong>Movie Cults<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
It’s a night of literal cult classics on TCM as the network airs four horror movies with stories involving groups of fanatical devotees to various sinister causes. First is <em>The Seventh Victim</em> (1943), one of the terrific supernatural-themed suspense films that Val Lewton produced in the 1940s and ’50s. Kim Hunter, in her film debut, plays a young woman who stumbles upon a secret cult of devil worshippers in Greenwich Village while searching for her missing sister. As with most of Lewton’s horror productions, this one very effectively relies largely on quieter, unseen psychological horror and a moody, shadowy ambiance versus outright shocking scenes, evidenced best in a creepy shower scene that anticipated <em>Psycho</em> by nearly 20 years. One director who mastered that sort of understated horror while working on some Lewton-produced classics was Jacques Tourneur, and he directed tonight’s next film, the superb <em>Curse of the Demon</em> (1957). Dana Andrews stars as an American psychologist who travels to England to investigate a satanic cult suspected in some deaths. The doctor’s skepticism about the existence of supernatural evil is put to the test when he finds himself targeted by a curse put upon him by the cult’s leader (a terrific Niall MacGinnis). Although a special effects-created demon was forcibly inserted into a few shots against Tourneur’s wishes, it doesn’t detract too much from the intensifying horror that viewers feel, along with the hero, as he races to stop the curse before its deadline arrives. The evening ends with two TCM premiere movies. In <em>Cult of the Cobra</em> (1955), servicemen returning home to the States after running afoul of an Asian snake cult that worships a cobra goddess begin experiencing mysterious “accidents.” Finally, Christopher Lee, Barbara Steele and Boris Karloff, in one of his final roles, lead <em>The Crimson Cult</em> (1968, aka <em>Curse of the Crimson Altar</em>), about an old witchcraft cult that is found to still be active.</p>
<p><strong>Selling the Big Easy<br />
HGTV, 9pm<br />
Season Premiere!</strong><br />
New Orleans native and resident real estate expert Brittany Picolo-Ramos helps families find the house of their dreams by showing them high-end homes with the right amount of history and charm. She also helps clients stage and sell their homes for top dollar in the city’s vibrant real estate market.</p>
<p><strong>Detainee 001<br />
Showtime, 9pm</strong><br />
This documentary unpacks the mysteries surrounding the young American man, John Walker Lindh, found on the battlefield in Afghanistan alongside the people who were supposed to be his enemy. The story reveals how society views the “enemy from within” and the shifting allegiances during the war on terror. Drawing on unique access to the world of intelligence and special operations, the film pieces together the defining yet barely remembered origin story of post-9/11 America. From the battlefield to the courtroom, it confronts the unresolved issues at the heart of Lindh’s case, including his role in the uprising that led to the first American casualty of the war in Afghanistan, CIA officer Johnny Micheal Spann.</p>
<p><strong>The Hunt for Bin Laden<br />
Smithsonian Channel, 9pm</strong><br />
In 2011, Osama bin Laden, the mastermind behind the 9/11 bombings, was killed by American special forces, marking an end to the longest, most expensive manhunt in American history. Witness the 20-year search for the most wanted man on Earth, as counter-terrorism experts in the White House, the CIA and the FBI divulge their firsthand accounts. This inside story reveals the presidential frustrations, missed opportunities and vicious turf wars that tainted the operation right up until the night Navy SEALs ended Bin Laden’s reign of terror.</p>
<p><strong>These Woods Are Haunted<br />
Travel Channel, 9pm<br />
Season Premiere!</strong><br />
Enjoy more spooky episodes of the series that looks at paranormal incidents that reportedly took place in the woods or other wilderness locations.</p>
<p><strong>SurrealEstate: “White Wedding”<br />
Syfy, 10pm</strong><br />
Susan (Sarah Levy) works to keep a dream wedding from becoming a nightmare. Meanwhile, the Donovan House strikes back.</p>
<p><strong>The Alaska Triangle<br />
Travel Channel, 10pm<br />
Season Premiere!</strong><br />
In tonight’s episode, “The Dark Pyramid and Violent Nature,” a top-secret government facility beneath the Alaskan wilderness may be hiding an extraterrestrial pyramid, and strange forces within the Alaska Triangle are making wildlife more aggressive toward humans.</p>
<h3><strong>Saturday, Sept. 11</strong></h3>
<p><strong>Last Night of the Proms 2021<br />
BritBox<br />
North American Exclusive Premiere!</strong><br />
This annual British music festival returns with audiences finally invited back to the Royal Albert Hall for a night of music and merriment. This year’s grand classic musical event will be conducted by Sakari Oramo, chief conductor of the BBC Symphony Orchestra, who is scheduled to perform, in Last Night tradition.</p>
<p><strong>College Football<br />
ABC, CBS, ESPN, ESPN2, FOX, FS1 &amp; NBC, beginning at 12pm Live</strong><br />
Highlights of Saturday’s college gridiron action include Pittsburgh at Tennessee (ESPN), Oregon at Ohio State (FOX), Tulsa at Oklahoma State (FS1), Florida at South Florida (ABC), Toledo at Notre Dame (NBC), UAB at Georgia (ESPN2), Texas A&amp;M vs. Colorado in Denver (FOX), Air Force at Navy (CBS), Iowa at Iowa State (ABC), Texas at Arkansas (ESPN), Washington at Michigan (ABC), Utah at BYU (ESPN) and Stanford at USC (FOX).</p>
<p><strong>Sweet Smell of Success<br />
TCM, 1:45pm<br />
Catch a Classic!</strong><br />
Many films have taken hard looks at human greed, corruption and cruelty, but rarely have they been so viscerally presented as in this 1957 film noir masterpiece, director Alexander Mackendrick’s brutal and cynical look at Broadway’s underbelly. BAFTA Award nominee Tony Curtis stars as opportunistic and unprincipled press agent Sidney Falco, who enters into a power struggle with J.J. Hunsecker, an all-powerful, totally corrupt newspaper gossip columnist portrayed by Burt Lancaster. The two clash menacingly in the midst of a stylish Manhattan nightclub, as reputations are bought and sold and Falco’s whole life hangs in the balance. Along with the intense performances, the film’s masterfully structured script by Clifford Odets, Ernest Lehman and an uncredited Mackendrick (based on Lehman’s novella <em>Tell Me About It Tomorrow!</em>); its stunning neon cityscapes captured by cinematographer James Wong Howe; and a jazzy musical score by Elmer Bernstein and Chico Hamilton really bring audiences into the darker side of 1950s Manhattan.</p>
<p><strong>2020 Tokyo Paralympics Games<br />
NBC &amp; Peacock, 3pm</strong><br />
Take a look back at great moments from the recently concluded 2020 Tokyo Paralympic Games with this two-hour highlights show.</p>
<p><strong>Tennis: US Open: Women’s Singles Final<br />
ESPN, 4pm Live</strong><br />
The US Open’s two remaining women’s singles players compete for the title at the USTA Billie Jean King National Tennis Center in Queens, New York.</p>
<p><strong>Major League Baseball: N.Y. Yankees at N.Y. Mets<br />
FOX, 7:30pm Live</strong><br />
Aaron Judge and the N.Y. Yankees are at Citi Field for Game 2 of a three-game Subway Series against Pete Alonso and the N.Y. Mets.</p>
<p><strong>NASCAR Cup Series: Federated Auto Parts 400 Salute to First Responders<br />
NBCSN, 7:30pm Live</strong><br />
The .75-mile, D-shaped oval at Virginia’s Richmond Raceway is the site of this primetime race, the second of three races in the NASCAR Cup Series playoffs Round of 16.</p>
<p><strong>9/11: Four Flights<br />
History, 8pm</strong><br />
Four flights — American 11, United 175, American 77 and United 93 — took off the morning of Sept. 11, 2001, unaware of the life-changing events to follow and the fate that would forever intertwine them. Through the powerful and personal narratives from family and friends, this two-hour documentary tells the riveting and emotional human stories of those aboard each doomed jetliner. Looking at all four flights for the first time in one program, the film unveils a saga of surprising connections, strange coincidences and detrimental decisions.</p>
<p><strong>Great Performances: “Verdi’s Requiem: The Met Remembers 9/11”<br />
PBS, 8pm Live</strong><br />
The Metropolitan Opera commemorates the 20th anniversary of the Sept. 11, 2001, terror attacks with this special live performance of Giuseppe Verdi’s “Requiem,” the first concert at the Metropolitan Opera House since is closure in March 2020 due to the COVID-19 pandemic. Hosted by world-renowned ballerina Misty Copeland from the nearby site of the 9/11 Memorial &amp; Museum, the special also includes footage from the archives of the museum as well as New York City’s Tribute in Light, a commemorative public art installation featuring two beams of light that reach up to 4 miles into the sky, echoing the shape and orientation of the Twin Towers, every year from dusk to dawn on the night of Sept. 11.</p>
<p><strong>Say Yes to the Dress<br />
TLC, 8pm</strong><br />
LaQuesha wants two dresses fit for her royal highness, while Jessica is convinced she is too picky to even say yes to a dress at all. Plus, will Isabella’s final look come together just days before her wedding?</p>
<p><strong>Roadhouse Romance<br />
Hallmark Channel, 9pm<br />
Original Film!</strong><br />
Country music fan Callie (Lauren Alaina) is determined to continue her late grandfather’s legacy. While TV director Luke (Tyler Hynes) is in town, he teaches her that sometimes it’s best to look forward instead of back.</p>
<p><strong>Destination Fear: “Villisca Axe Murder House and Malvern Manor”<br />
Travel Channel, 9pm<br />
Season Finale!</strong><br />
In an unprecedented move, Dakota takes the team to not one, but two locations — at the same time. Combined, it will make for an exploration of one of the most gruesome events in American history. A family was brutally murdered in the now-infamous Villisca Axe Murder House, and many believe that a dark and nefarious entity haunts the home. But it’s the seemingly paranormal connection to a hotel 40 miles away that has intrigued Dakota, and he and the team are the first to explore it.</p>
<p><strong>9/11: I Was There<br />
History, 10pm</strong><br />
This is an intimate portrayal of the events of Sept. 11, 2001, captured by ordinary people who chose to pick up their video cameras on that day. Over two hours, previously unseen video and unheard audio — offered without interview or commentary — tells a unique story of their journey from confusion to comprehension, terror and relief.</p>
	</div>
		<div id="text-771362228" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94"><img src="https://www.channelguidemag.com/wp-content/uploads/2020/05/CG-Ad_Save-66_728x90_Perry.jpg" /></a></div>
		</div></article><div id="comments" class="mh-comments-wrap">
</div>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.channelguidemag.com/tv-news/2021/09/07/tuesday-sept-7-impeachment-american-crime-story-fx/" rel="prev"><img width="80" height="60" src="https://www.channelguidemag.com/wp-content/uploads/2021/09/ACSImpeachmentBB-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="Impeachment American Crime Story FX" loading="lazy" srcset="https://www.channelguidemag.com/wp-content/uploads/2021/09/ACSImpeachmentBB-80x60.jpg 80w, https://www.channelguidemag.com/wp-content/uploads/2021/09/ACSImpeachmentBB-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="182425" data-permalink="https://www.channelguidemag.com/acsimpeachmentbb/" data-orig-file="https://www.channelguidemag.com/wp-content/uploads/2021/09/ACSImpeachmentBB.jpg" data-orig-size="1030,438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ACSImpeachmentBB" data-image-description="" data-image-caption="" data-medium-file="https://www.channelguidemag.com/wp-content/uploads/2021/09/ACSImpeachmentBB-300x128.jpg" data-large-file="https://www.channelguidemag.com/wp-content/uploads/2021/09/ACSImpeachmentBB-1024x435.jpg" /><span>Previous</span><p>Tuesday, Sept. 7: The Clinton White House Scandal Revisited in &#8216;Impeachment: American Crime Story&#8217;</p></a></div>
</nav>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="search-2" class="mh-widget widget_search"><form role="search" method="get" class="search-form" action="https://www.channelguidemag.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="text-771362232" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362225" class="mh-widget widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Subscribe</span></h4>			<div class="textwidget"><p>&nbsp;</p>
<figure class="wp-caption aligncenter"  style="max-width: 300px">
			<img loading="lazy" class="wp-image-182358 size-full alignnone" src="https://www.channelguidemag.com/wp-content/uploads/2021/08/cover0921-300-2.jpg" alt="" width="300" height="392" srcset="https://www.channelguidemag.com/wp-content/uploads/2021/08/cover0921-300-2.jpg 300w, https://www.channelguidemag.com/wp-content/uploads/2021/08/cover0921-300-2-230x300.jpg 230w, https://www.channelguidemag.com/wp-content/uploads/2021/08/cover0921-300-2-150x195.jpg 150w" sizes="(max-width: 300px) 100vw, 300px" />		<figcaption class="wp-caption-text" >
			<span class="media-credit"><a href="https://www.channelguidemag.com/tv-news/author/contributor/">Channel Guide Contributor</a></span>		</figcaption>
	</figure>

<p><span style="display: block; font: 100% Montserrat; margin: 0 auto; max-width: 300px;">The most complete TV listings and best recommendations delivered right to your door — every month.</span></p>
</div>
		</div><div id="mh_magazine_custom_posts-10" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">In This Issue</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-182278 post type-post status-publish format-standard has-post-thumbnail category-drama category-horror category-archive tag-14448 tag-amc tag-magazine-archive tag-the-walking-dead">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2021/08/22/josh-mcdermitt-on-walking-dead-final-season-ive-always-wanted-eugene-to-die-of-old-age/" title="Josh McDermitt on &#8216;The Walking Dead&#8217; Final Season: &#8216;I&#8217;ve Always Wanted Eugene to Die of Old Age&#8217;">
										Josh McDermitt on &#8216;The Walking Dead&#8217; Final Season: &#8216;I&#8217;ve Always Wanted Eugene to Die of Old Age&#8217;									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/">August 22, 2021</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/22/josh-mcdermitt-on-walking-dead-final-season-ive-always-wanted-eugene-to-die-of-old-age/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-182208 post type-post status-publish format-standard has-post-thumbnail category-drama category-interview category-archive category-preview tag-14448 tag-starz">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2021/08/15/stephen-amell-alexander-ludwig-heels-starz/" title="Stephen Amell and Alexander Ludwig Tag Team for Hard-Hitting, Heartfelt &#8216;Heels&#8217; on Starz">
										Stephen Amell and Alexander Ludwig Tag Team for Hard-Hitting, Heartfelt &#8216;Heels&#8217; on Starz									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/">August 15, 2021</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/15/stephen-amell-alexander-ludwig-heels-starz/#comments" class="mh-comment-count-link" >1</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-182133 post type-post status-publish format-standard has-post-thumbnail category-documentary category-archive tag-14448 tag-showtime">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2021/08/06/ufo-documentary-showtime/" title="Remove the Foil Hat: UFOs Are Up for Serious Debate in Showtime Documentary Series">
										Remove the Foil Hat: UFOs Are Up for Serious Debate in Showtime Documentary Series									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/">August 6, 2021</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2021/08/06/ufo-documentary-showtime/#comments" class="mh-comment-count-link" >1</a></span>
</div>
							</div>
						</li>			</ul></div><div id="text-771362226" class="mh-widget widget_text">			<div class="textwidget"><div style="background-color:  #FF9245; font: 170% Montserrat; font-weight:bold; margin: 10px 0 0; padding: 5px 0; text-align: center;"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94" id="order-button">ORDER NOW!</a></div></div>
		</div><div id="text-771362234" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe title="Find and Remind" src="https://widgets.tvinsider.com/discover/widgets/display.cfm?widgetGUID=e76eae7a-3166-419a-9f01-b1f984cc35a5" style="max-width:300px;width:100%;height:462px;border:0;"></iframe></div></div>
<div id="wpp-6" class="mh-widget popular-posts">
<h4 class="mh-widget-title"><span class="mh-widget-title-inner">Popular Posts</span></h4>            <div class="wpp-widget-placeholder" data-widget-id="wpp-6"></div>
            
</div>
<div id="text-771362236" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362192" class="mh-widget widget_text">			<div class="textwidget"><center><!-- Medium_Rectangle_300x250 -->
<div id='div-gpt-ad-1426776676899-3'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1426776676899-3'); });
</script>
</div></center>

</div>
		</div><div id="text-771362233" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362223" class="mh-widget widget_text">			<div class="textwidget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#e8e8e8; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://channelguidemag.us4.list-manage.com/subscribe/post?u=a2d9de00dacb27b8907ecc15a&amp;id=6990079feb" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2 style="color: #f47d2a;">Email sign up!</h2>
Follow your favorite writers and/or get weekly updates to the best on TV.<br /><br />
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group input-group">
    <ul><li><input type="checkbox" value="1" name="group[2865][1]" id="mce-group[2865]-2865-0"><label for="mce-group[2865]-2865-0">5toWATCH Weekly eNewsletter</label></li>
    <li><input type="checkbox" value="131072" name="group[6821][131072]" id="mce-group[6821]-6821-0"><label for="mce-group[6821]-6821-0">Ryan Berenz posts</label></li>
<li><input type="checkbox" value="262144" name="group[6821][262144]" id="mce-group[6821]-6821-2"><label for="mce-group[6821]-6821-2">Barb Oates posts</label></li>
<li><input type="checkbox" value="524288" name="group[6821][524288]" id="mce-group[6821]-6821-3"><label for="mce-group[6821]-6821-3">Jeff Pfeiffer posts</label></li>
</ul>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_a2d9de00dacb27b8907ecc15a_6990079feb" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[6]='ADDRESS';ftypes[6]='address';fnames[7]='KEYCODE';ftypes[7]='text';fnames[3]='SUBID';ftypes[3]='text';fnames[4]='VERSION';ftypes[4]='text';fnames[5]='EXPISSUE';ftypes[5]='text';fnames[8]='EXPYEAR';ftypes[8]='text';fnames[9]='ACTIVEMO';ftypes[9]='number';fnames[10]='SFGNO';ftypes[10]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
<!--End mc_embed_signup--></div>
		</div>	</aside>	</div>
    </div>
<footer class="mh-footer" id="footer-override">
	<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
					<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-1">
				<div id="text-771362230" class="mh-footer-widget widget_text">			<div class="textwidget"><p><img alt="Channel Guide Logo" src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png" /></p>
</div>
		</div><div id="mh_magazine_social-3" class="mh-footer-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-container"><ul id="menu-social-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>				</nav></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-2">
				<div id="nav_menu-4" class="mh-footer-widget widget_nav_menu"><div class="menu-top-menu-footer-container"><ul id="menu-top-menu-footer" class="menu"><li id="menu-item-151599" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-151599"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a></li>
<li id="menu-item-151600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151600"><a href="/movies-tv/">Movies On TV</a></li>
<li id="menu-item-151601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151601"><a href="/tv-listings/">TV Listings</a></li>
<li id="menu-item-151602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151602"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports</a></li>
<li id="menu-item-151603" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151603"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-151604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151604"><a href="https://www.channelguidemag.com/tv-news/category/binge-watching/">Binge Watching</a></li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-3">
				<div id="nav_menu-5" class="mh-footer-widget widget_nav_menu"><div class="menu-customer-service-container"><ul id="menu-customer-service-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">SUBSCRIBE / More</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-181202"><a href="https://www.channelguidemag.com/contact-us/">Contact Us</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-4">
				<div id="text-771362218" class="mh-footer-widget widget_text">			<div class="textwidget"><p><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&amp;publ=CG&amp;key=IZX2Y93"><img src="https://www.channelguidemag.com/wp-content/uploads/2020/05/CG-Ad_Save-66_300x250_Snowpiercer.jpg" alt="Subscribe and Save" /></a></p>
</div>
		</div>			</div>
			</div>
</footer>
	<div class="mh-footer-mobile-nav"></div>
	<nav class="mh-footer-nav">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-publications-container"><ul id="menu-publications" class="menu"><li id="menu-item-151610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-151610"><a href="https://www.channelguidemag.com/">Channel Guide Magazine</a></li>
<li id="menu-item-151611" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151611"><a href="http://www.ondishmag.com">OnDISH Magazine</a></li>
<li id="menu-item-151612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151612"><a href="http://www.iwantmytvmagazine.com/">TV Weekly</a></li>
<li id="menu-item-151613" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151613"><a href="http://www.tvguidemagazine.com/">TV Guide Magazine</a></li>
<li id="menu-item-151614" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151614"><a href="http://www.view-mag.com/">VIEW Magazine</a></li>
<li id="menu-item-151615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151615"><a href="http://www.remindmagazine.com/">REMIND Magazine</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">@ 2020 Channel Guide Magazine</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.channelguidemag.com\/tv-news\/2021\/09\/08\/wednesday-sept-8-too-soon-comedy-after-911-vice-tv\/":182428};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/tv-news/2021/09/08/wednesday-sept-8-too-soon-comedy-after-911-vice-tv/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.channelguidemag.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/wp-embed.min.js?ver=7d701376d6f2bb258bc61e61c3f12ef5' id='wp-embed-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=10.0' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-facebook' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-facebook' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
						return false;
					}
				} );
			} )();
var windowOpen;
			( function () {
				function matches( el, sel ) {
					return !! (
						el.matches && el.matches( sel ) ||
						el.msMatchesSelector && el.msMatchesSelector( sel )
					);
				}

				document.body.addEventListener( 'click', function ( event ) {
					if ( ! event.target ) {
						return;
					}

					var el;
					if ( matches( event.target, 'a.share-twitter' ) ) {
						el = event.target;
					} else if ( event.target.parentNode && matches( event.target.parentNode, 'a.share-twitter' ) ) {
						el = event.target.parentNode;
					}

					if ( el ) {
						event.preventDefault();

						// If there's another sharing window open, close it.
						if ( typeof windowOpen !== 'undefined' ) {
							windowOpen.close();
						}
						windowOpen = window.open( el.getAttribute( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
						return false;
					}
				} );
			} )();
</script>
<script src='https://stats.wp.com/e-202136.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:10.0',blog:'113259570',post:'182428',tz:'-5',srv:'www.channelguidemag.com'} ]);
	_stq.push([ 'clickTrackerInit', '113259570', '182428' ]);
</script>
</body>
</html>