<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>Monday, April 20: Things Get Dire for Jimmy and Kim in &#039;Better Call Saul&#039; Season Finale - Channel Guide Magazine</title>

<!-- This site is optimized with the Yoast SEO plugin v13.5 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="In the Season 5 finale, Jimmy (Bob Odenkirk) and Kim (Rhea Seehorn) make a sideways move that takes a serious turn."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Monday, April 20: Things Get Dire for Jimmy and Kim in &#039;Better Call Saul&#039; Season Finale - Channel Guide Magazine" />
<meta property="og:description" content="In the Season 5 finale, Jimmy (Bob Odenkirk) and Kim (Rhea Seehorn) make a sideways move that takes a serious turn." />
<meta property="og:url" content="https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/" />
<meta property="og:site_name" content="Channel Guide Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/ChannelGuideMagazine" />
<meta property="article:section" content="TV Best Bets" />
<meta property="article:published_time" content="2020-04-20T11:39:20+00:00" />
<meta property="article:modified_time" content="2020-04-16T18:46:36+00:00" />
<meta property="og:updated_time" content="2020-04-16T18:46:36+00:00" />
<meta property="og:image" content="https://www.channelguidemag.com/wp-content/uploads/2020/02/BetterCallSaulSn5BB.jpg" />
<meta property="og:image:secure_url" content="https://www.channelguidemag.com/wp-content/uploads/2020/02/BetterCallSaulSn5BB.jpg" />
<meta property="og:image:width" content="1030" />
<meta property="og:image:height" content="438" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.channelguidemag.com/#website","url":"https://www.channelguidemag.com/","name":"Channel Guide Magazine","inLanguage":"en-US","description":"Our writers comment on the state of TV","potentialAction":[{"@type":"SearchAction","target":"https://www.channelguidemag.com/?s={search_term_string}","query-input":"required name=search_term_string"}]},{"@type":"ImageObject","@id":"https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/#primaryimage","inLanguage":"en-US","url":"https://www.channelguidemag.com/wp-content/uploads/2020/02/BetterCallSaulSn5BB.jpg","width":1030,"height":438},{"@type":"WebPage","@id":"https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/#webpage","url":"https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/","name":"Monday, April 20: Things Get Dire for Jimmy and Kim in &#039;Better Call Saul&#039; Season Finale - Channel Guide Magazine","isPartOf":{"@id":"https://www.channelguidemag.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/#primaryimage"},"datePublished":"2020-04-20T11:39:20+00:00","dateModified":"2020-04-16T18:46:36+00:00","author":{"@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f"},"description":"In the Season 5 finale, Jimmy (Bob Odenkirk) and Kim (Rhea Seehorn) make a sideways move that takes a serious turn.","potentialAction":[{"@type":"ReadAction","target":["https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/"]}]},{"@type":["Person"],"@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f","name":"Channel Guide Staff","image":{"@type":"ImageObject","@id":"https://www.channelguidemag.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/68b6c70392ac45a38a16ac89e1b612bb?s=96&d=blank&r=g","caption":"Channel Guide Staff"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Feed" href="https://www.channelguidemag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Comments Feed" href="https://www.channelguidemag.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-435360-2';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-435360-2', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.channelguidemag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=12ad2e24ebd5082ea4904983bf327010"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.channelguidemag.com/wp-includes/css/dist/block-library/style.min.css?ver=12ad2e24ebd5082ea4904983bf327010' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='media-credit-css'  href='https://www.channelguidemag.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=4.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/style.css?ver=12ad2e24ebd5082ea4904983bf327010' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine-child/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans:300,400,400italic,600,700,700italic%7cMontserrat:300,400,400italic,600,700,700italic' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.4.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.channelguidemag.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.channelguidemag.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"177515","token":"92176ecb3b","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.1.0'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://www.channelguidemag.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.channelguidemag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.channelguidemag.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p7FdZg-Kb9' />
<link rel="alternate" type="application/json+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2020%2F04%2F20%2Fmonday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2020%2F04%2F20%2Fmonday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type="text/css">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</style>
<style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Montserrat", sans-serif; }
body { font-family: "Droid Sans", sans-serif; }
</style>
<link rel="amphtml" href="https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/amp/"><link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-270x270.png" />
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
var mapping2 = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot2= googletag.defineSlot('/4370989/CGM-lead-bottom-flex', [320,50], 'div-gpt-ad-1426776676899-0').
defineSizeMapping(mapping2).
addService(googletag.pubads()).
setCollapseEmptyDiv(true);
var mapping = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot1= googletag.defineSlot('/4370989/cgm-lead-flexible-top', [320,50], 'div-gpt-ad-1426776676899-1').
defineSizeMapping(mapping).
addService(googletag.pubads());

googletag.defineSlot('/4370989/Medium_Rectangle_2_internal_ads', [300, 250], 'div-gpt-ad-1426776676899-2').addService(googletag.pubads());
googletag.defineSlot('/4370989/Medium_Rectangle_300x250', [300, 250], 'div-gpt-ad-1426776676899-3').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-177515 single-format-standard mh-boxed-layout mh-right-sb mh-loop-layout2 mh-widget-layout2" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<a class="mh-header-image-link" href="https://www.channelguidemag.com/" title="Channel Guide Magazine" rel="home">
<img class="mh-header-image" src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png" height="139" width="496" alt="Channel Guide Magazine" />
</a>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-99135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99135"><a href="/tv-listings/">TV Listings</a></li>
<li id="menu-item-151619" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-151619"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a>
<ul class="sub-menu">
	<li id="menu-item-99133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99133"><a href="https://www.channelguidemag.com/movies-tv/">Movies on TV</a></li>
	<li id="menu-item-154098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154098"><a href="https://www.channelguidemag.com/tv-news/category/vod/">New to On Demand &#038; DVD</a></li>
</ul>
</li>
<li id="menu-item-151620" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151620"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-99134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-99134"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports on TV</a>
<ul class="sub-menu">
	<li id="menu-item-152175" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152175"><a href="https://www.channelguidemag.com/sports-on-tv/">This Week&#8217;s Schedule</a></li>
</ul>
</li>
<li id="menu-item-151622" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151622"><a href="/network-contacts/">How to contact a Network</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-customer-service-container"><ul id="menu-customer-service" class="menu"><li id="menu-item-151605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-151606" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li id="menu-item-151607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li id="menu-item-151608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li id="menu-item-151609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li id="menu-item-156378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-151616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-151617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-151618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>

<div class="mh-wrapper clearfix">
<span class='mh-best-bets-caption'>TV Best Bets</span>	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content"><article id="post-177515" class="post-177515 post type-post status-publish format-standard has-post-thumbnail hentry category-tv-best-bets">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Monday, April 20: Things Get Dire for Jimmy and Kim in &#8216;Better Call Saul&#8217; Season Finale		</h1>
		<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/04/">April 20, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.channelguidemag.com/tv-news/author/staff/">Channel Guide Staff</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/" rel="category tag">TV Best Bets</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Monday, April 20: Things Get Dire for Jimmy and Kim in &#8216;Better Call Saul&#8217; Season Finale</span></span></span>
</div>
	</header>
		<div class="entry-content clearfix"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-177515" class="share-facebook sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-177515" class="share-pinterest sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-177515" class="share-twitter sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<figure class="entry-thumbnail">
<img src="https://www.channelguidemag.com/wp-content/uploads/2020/02/BetterCallSaulSn5BB-678x381.jpg" alt="" title="BetterCallSaulSn5BB" />
<span class="media-credit">Greg Lewis/AMC/Sony Pictures Television</span></figure>
<p><strong>All Times Eastern.</strong></p>
<h2><strong>Monday, April 20</strong></h2>
<p><strong>Better Call Saul: “Something Unforgivable”<br />
AMC, 9pm<br />
Season Finale!</strong><br />
In the Season 5 finale, Jimmy (Bob Odenkirk) and Kim (Rhea Seehorn) make a sideways move that takes a serious turn. Nacho (Michael Mando) gets closer to the cartel than he’d like. We’ve got one more season left of Vince Gilligan and Peter Gould’s riveting storytelling before it comes to an official end.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='640' height='360' src='https://www.youtube.com/embed/MAqc3ioD22k?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p><strong>9-1-1 : “Eddie Begins”<br />
FOX, 8pm</strong><br />
The rescue of a boy stuck in a well fuels a flashback-heavy hour that reveals how Eddie’s (Ryan Guzman) time as a medic in Afghanistan led him to join the LAFD <em>and </em>gives glimpses into his backstory with son Christopher (Gavin McHugh) and late wife Shannon (Devin Kelley).</p>
<p><strong>The Voice: “The Knockouts Part 2”<br />
NBC, 8pm</strong><br />
The Knockouts rounds conclude tonight, with each artist paired against a teammate to perform individually, while their direct competitor watches and waits. Famed singer/songwriter James Taylor will serve as the Mega Mentor and be on hand to work with all of the coaches and their artists as they prepare for this challenge. The coaches alone will choose the winner from each Knockout to advance. Each coach will have one steal in the Knockouts, and in a new twist, the four artists who were saved during the Battle Rounds will compete in a four-way Knockout.</p>
<p><strong>Star of the Month: Jane Russell<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
It’s time for another Monday evening visit with Jane Russell in several of her films on Turner Classic Movies. The night begins with Russell costarring with fellow bombshell Marilyn Monroe in 1953’s <em>Gentlemen Prefer Blondes</em>, followed by the actress returning sans Monroe, and as a different character, in a follow-up of sorts, 1955’s <em>Gentlemen Marry Brunettes</em>. The rest of the lineup includes <em>The French Line</em> (1954), <em>The Revolt of Mamie Stover</em> (1956) and <em>The Fuzzy Pink Nightgown</em> (1957).</p>
<p><strong>Roswell, New Mexico: “Sex and Candy”<br />
The CW, 9pm</strong><br />
Maria’s (Heather Hemmens) investigation into her mother’s disappearance leads her and Alex (Tyler Blackburn) to the home of a mysterious bootmaker named Travis (guest star David Anders). Meanwhile, on her journey of self-discovery, Isobel’s (Lily Cowles) night out leads her into the arms of someone unexpected. Finally, after making some major scientific strides, Liz (Jeanine Mason) is dealt a devastating blow.</p>
<p><strong>Prodigal Son: “The Professionals”<br />
FOX, 9pm</strong><br />
In the new episode “The Professionals,” a catastrophic turn of events has Malcolm (Tom Payne) and Ainsley (Halston Sage) convinced there’s more to Nicholas Endicott (guest star Dermot Mulroney) than meets the eye.</p>
<p><strong>Cosmos: Possible Worlds<br />
National Geographic, 9pm<br />
Season Finale!</strong><br />
In the season finale episode “Seven Wonders of the New World,” travel to the future and the dazzling pavilions of the 2039 New York World’s Fair, where problems currently considered intractable may have been solved through public commitment and scientific imagination.</p>
<p><strong>Vanity Fair Confidential: “Nightmare on Elwood Avenue”<br />
OWN, 9pm</strong><br />
OWN borrows this 2015-18 true-crime series from sister channel Investigation Discovery, which borrowed <em>its</em> cases from the glossy magazine. Tonight, Wall Street whiz Maria Cruz vanishes in 2003 — as does the last man to see her alive.</p>
<p><strong>Generation Columbine<br />
Starz, 9pm</strong><br />
More than two decades after the mass shooting at Columbine High School, an entire generation has grown up knowing the threat of school violence. This documentary explores the epidemic of school shootings and the lasting impact on survivors.</p>
<p><strong>The Baker and the Beauty: “Ruin My Life”<br />
ABC, 10pm</strong><br />
Noa (Nathalie Kelley) and Daniel’s (Victor Rasuk) relationship begins to flourish, and after an unwanted birthday party for Noa, Daniel discovers more about her past while a heartbroken Vanessa (Michelle Veintimilla) is not giving up so easily. Meanwhile, with the bakery booming, a food critic extraordinaire puts in an outrageous food order the Garcias cannot refuse to take.</p>
<p><strong>Torn From the Headlines: New York Post Reports: “CSI Slay”<br />
Investigation Discovery, 10pm<br />
Season Finale!</strong><br />
When a young CSI tech is found brutally murdered in her bedroom, her colleagues at the NYPD crime lab are left to solve her murder. But the deeper they dig, the stranger the case becomes. The <em>New York Post</em> follows the case as all the gruesome details unfold, including a shocking discovery that leads investigators to an unexpected killer.</p>
<p><strong>Songland: “Luis Fonsi”<br />
NBC, 10pm</strong><br />
Multi-platinum, Grammy-nominated Latin pop sensation Luis Fonsi comes to the show to hear unknown songwriters pitch their original material. Three of the most successful and sought-after writer/producers in music — Ryan Tedder, Ester Dean and Shane McAnally — produce the songwriters to creatively adapt their songs so they perfectly fit the superstar artist. One song is chosen to be recorded by Fonsi and released for a global audience.</p>
<p><strong>Independent Lens: “The Hottest August”<br />
PBS, 10pm</strong><br />
Listen as ordinary New Yorkers attempt to answer the question “What were you doing while the planet burned?” During one sweltering month in 2017, they discuss the biggest issues they face, from climate change to skyrocketing rents to mass shootings.</p>
<p><strong>Marianne &amp; Leonard: Words of Love<br />
EPIX, 10:45pm</strong><br />
This documentary examines the relationship between the late musician Leonard Cohen and his Norwegian muse and longtime love Marianne Ihlen.</p>
<h3><strong>Tuesday, April 21</strong></h3>
<p><strong>Quantum Leap<br />
Comet, 6pm</strong><br />
Back-to-back episodes of the time-hopping drama now air weekdays on Comet! In today’s first, from 1990, physicist Sam Beckett (Scott Bakula) jumps into the body of a 1962 high school football player to help a teammate in need.</p>
<p><strong>The Flash: “So Long and Goodnight”<br />
The CW, 8pm</strong><br />
After Black Hole hires Rag Doll (guest star Troy James) to kill Joe (Jesse L. Martin), Singh (guest star Patrick Sabongui) suggests he go into Witness Protection, but Joe refuses to stop investigating Carver (guest star Eric Nenninger). While investigating Carver with Cisco (Carlos Valdes), Ralph (Hartley Sawyer) runs into Sue (guest star Natalie Dreyfuss). Iris (Candice Patton) becomes suspicious of Eva (guest star Efrat Dor).</p>
<p><strong>American Experience: “The Man Who Tried to Feed the World”<br />
PBS, 8pm</strong><br />
This installment of the acclaimed docuseries explores the life of 1970 Nobel Peace Prize winner Norman Borlaug, who tried to solve world hunger. Borlaug rescued India from a severe famine and led the “Green Revolution,” which has been estimated to have saved 1 billion lives, though his work later faced criticism.</p>
<p><strong>Female Ensemble Casts<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Women acting ensembles headline the casts of the five classic films airing tonight. The evening begins with <em>The Group</em> (1966), whose cast is led by Candice Bergen and follows eight female college graduates in the 1930s. Next up is 1939’s <em>The Women</em>, a comedy/drama featuring powerhouse names like Norma Shearer, Joan Crawford, Rosalind Russell, Paulette Goddard and Joan Fontaine. Also on the schedule are <em>Cry Havoc</em> (1943), <em>Stage Door</em> (1937) and <em>Little Women</em> (1949).</p>
<p><strong>Let’s Go Crazy: The Grammy Salute to Prince<br />
CBS, 9pm</strong><br />
A lineup of all-star artists pay tribute to Prince and his musical influence in this concert special recorded at the Los Angeles Convention Center. Beck, Common, Foo Fighters, Alicia Keys, John Legend, Mavis Staples, St. Vincent, Usher and Susanna Hoffs are among the performers and presenters. Also appearing are Prince’s band, the Revolution, and frequent collaborators Sheila E. and Morris Day and the Time.</p>
<p><strong>Chopped: Beat the Judge: “Tiffani”<br />
Food Network, 9pm<br />
</strong>Three determined chefs return to the <em>Chopped </em>kitchen eager to take on judge Tiffani Faison, but first they have to battle each other! An unusual snack food is part of the puzzle in the appetizer round, and in the entree round, the champs try not to let a mashup ingredient get them down. The chef who moves on to the Beat Tiffani round faces some high-brow and low-brow ingredients and stiff competition from a judge who loves to win.</p>
<p><strong>Empire<br />
FOX, 9pm<br />
Series Finale!</strong><br />
<em>Empire </em>wasn’t quite supposed to go out like this, but the COVID-19 crisis forced production to shut down before the intended series finale could be shot. Producers cobbled together Episodes 18 and 19 to create something resembling finality in the episode “Home Is on the Way,” in which the Lyons face their biggest threat yet. Lucious (Terrence Howard) prepares for the battle of his life and realizes that family is what matters the most.</p>
<p><strong>Accused: Guilty or Innocent?<br />
A&amp;E, 10pm<br />
New Series!</strong><br />
Imagine being accused of a crime, knowing you may spend years in prison. This compelling new documentary series follows the dramatic inside stories — as they unfold — of people facing trial for serious crimes they are alleged to have committed.</p>
<h3><strong>Wednesday, April 22</strong></h3>
<p><strong>The Story of Plastic<br />
Discovery Channel, 2pm</strong><br />
Grammy-nominated artist and environmental activist Jackson Browne is an executive producer of this film airing in honor of Earth Day. Using original animation, archival industry footage and first-person accounts, it looks at the man-made crisis of plastic pollution and the effect it has on the health of our planet and the living things that inhabit its ecosystems and communities.</p>
<p><strong>The Real Housewives of Beverly Hills: “To Live and Text in Beverly Hills”<br />
Bravo, 8pm</strong><br />
While Kyle tries to attract buyers for her new fashion line in New York City, Erika gets big news that has her moving there. Dorit’s move into a new house is marred by negative press about her finances. As Denise faces emergency surgery, Lisa Rinna worries about Amelia adjusting to college life. Meanwhile, Teddi’s confusing invitation causes conflict in the group.</p>
<p><strong>People Presents Harry &amp; Meghan: A Royal Rebellion<br />
The CW, 8pm</strong><br />
This two-hour special breaks down the story of Prince Harry and Meghan Markle — from their captivating love story to their shocking exit from royal life — not just what happened, but why, how and what it all really means. A team of full-time, royals-focused <em>People</em> reporters in New York and London break down the ins and outs of all things royal, offering new updates and insights into the couple who has thrown out the royal playbook.</p>
<p><strong>Josh Gates Tonight<br />
Discovery Channel, 8pm</strong><br />
In this Earth Day special, adventurer Josh Gates (<em>Expedition Unknown</em>) interviews a variety of celebrity guests and environmental experts about their commitment to preserving our planet.</p>
<p><strong>The Masked Singer: “The Mother of All Final Face Offs, Part 2”<br />
FOX, 8pm</strong><br />
Special guest Sharon Osbourne joins the panel as the singers compete in another round of smackdowns. One singer will be unmasked at the end of the new episode “The Mother of All Final Face Offs, Part 2.”</p>
<p><strong>Born Wild: Earth Day Live<br />
National Geographic &amp; Nat Geo Wild, 8pm Live</strong><br />
Produced with ABC News and hosted by <em>Good Morning America</em>’s Robin Roberts, this hourlong live global telecast (interspersed with prerecorded, “cinematically sweeping” segments) follows correspondents around the world as they witness and celebrate the diversity of adorable baby animals and their families, along with their habitats, which face insurmountable environmental changes.</p>
<p><strong>Climate Change — The Facts<br />
PBS, 8pm</strong><br />
Iconic natural historian Sir David Attenborough hosts this hourlong Earth Day special that presents scientific evidence of the impact of global warming. The program also examines possible solutions to the crisis, including the latest innovations, technology and actions individuals can take to prevent further damage.</p>
<p><strong>Earth Day 50th Anniversary Film Marathon<br />
TCM, beginning at 8pm<br />
Catch a Classic!</strong><br />
Turner Classic Movies celebrates Earth Day with a night of environmental-themed films. The evening begins with the Oscar-winning climate-change documentary <em>An Inconvenient Truth</em> (2006), with other highlights including the 1982 experimental film <em>Koyaanisqatsi</em>; two documentary shorts from the Dust Bowl era, <em>The Plow That Broke the Plains</em> (1936) and <em>The River</em> (1938); and the Oscar-winning doc <em>The Sea Around Us</em> (1953).</p>
<p><strong>Ghost Nation<br />
Travel Channel, 8pm<br />
Season Premiere!</strong><br />
In the new season, paranormal investigators Jason Hawes, Steve Gonsalves and Dave Tango call in their old friend, investigator Shari DeBenedetti, to help explore potential hauntings. In the two-hour season premiere, the team answers a distressed Pennsylvania couple’s call for help. The newlyweds report seeing apparitions and hearing unexplained noises in their 18th-century farmhouse and believe a cursed “witching tree” in the yard is at the heart of the disturbances.</p>
<p><strong>She Walks With Apes<br />
BBC America, 9pm</strong><br />
Sandra Oh (<em>Killing Eve</em>) narrates this documentary film airing as part of BBC America’s Earth Day 50th anniversary lineup. Father-daughter team Mark and Caitlin Starowicz filmed the feature over the course of a year, trudging through jungles to tell the story of three women — Jane Goodall, Dian Fossey and Biruté Galdikas — who embarked on lifelong journeys to live with, study and change our understanding of humanity’s closest living relatives, the great apes.</p>
<p><strong>SEAL Team: “Edge of Nowhere”<br />
CBS, 9pm</strong><br />
In the new episode “Edge of Nowhere,” Bravo Team searches for a new terrorist group leader who is orchestrating violent resistance to peace negotiations in Afghanistan.</p>
<p><strong>The Great Global Clean Up<br />
Discovery Channel, 9pm</strong><br />
Actor Zac Efron and special host filmmaker/social media personality Zach King are joined by celebrities like Lil Dicky, Liza Koshy and Cody Simpson, as well as others from the worlds of entertainment and sports, to spotlight the efforts of the next generation of individuals and organizations that have made it their mission to help clean up our planet. Through interviews with environmental pioneers, including Earth Day founder Denis Hayes, this special travels to places around the globe and features individuals cleaning up their hometowns with groups of volunteers, including Efron’s beach cleanup in his California hometown.</p>
<p><strong>The Masked Singer: After the Mask<br />
FOX, 9pm<br />
New Series!</strong><br />
<em>The Masked Singer</em> fans will want to stick around for this new aftershow hosted by Nick Cannon on a virtual stage. Celebrity guests will remotely discuss the best moments of that night’s show. Plus, expect stunts, games and impromptu musical performances.</p>
<p><strong>Jane Goodall: The Hope<br />
National Geographic &amp; Nat Geo Wild, 9pm</strong><br />
Picking up where Nat Geo’s award-winning 2017 documentary <em>Jane</em> left off, this two-hour special highlights pioneering primatologist Dr. Jane Goodall’s four-decade legacy of advocacy and leadership on behalf of chimpanzees and humanity. It chronicles how she has transformed environmentalism, nonhuman animal welfare and conservation through her innovative approaches.</p>
<p><strong>Celebrity Ghost Stories: “Paula Abdul”<br />
A&amp;E, 10pm</strong><br />
Music icon Paula Abdul brings psychic medium Kim Russo back to her former California home where she was troubled by incessant spirits. During their probe, Paula discovers the reason for her past haunting was much more than she originally expected.</p>
<p><strong>S.W.A.T.: “Vice”<br />
CBS, 10pm</strong><br />
In the new episode “Vice,” the SWAT team searches for an escaped convict who plans to kill Tan (David Lim) and every member of law enforcement who helped put him in prison.</p>
<p><strong>Impossible Croc Rescue<br />
Discovery Channel, 10pm</strong><br />
In this Earth Day special, animal expert Forrest Galante travels to Indonesia, and with the help of some local guides takes on the ultimate challenge of saving the life of a giant saltwater crocodile that is stuck with a motorcycle tire around its neck as the result of humans polluting its environment.</p>
<p><strong>Deadly Recall: “Truck Stop”<br />
Investigation Discovery, 10pm<br />
</strong>In the middle of the night, Pat is called to the scene of a homicide at the North First Street Truck Stop. Police found the body of the victim just past what the truckers call “Party Row,” and quickly identify her by the bracelet with her name on it: Sara Hulbert. Pat and his team comb through surveillance footage, searching for any evidence of the crime. That’s when Pat recognizes an unlikely pattern, leading to a race against the clock to apprehend an active killer before he murders again.</p>
<p><strong>NOVA: “Killer Floods”<br />
PBS, 10pm</strong><br />
Uncover geologic fingerprints of colossal floods that violently reshaped the ancient world. Follow geologists around the globe as they reconstruct catastrophic Ice Age floods more powerful than all the world’s top 10 rivers combined.</p>
<p><strong>True Terror With Robert Englund: “Bad Omens”<br />
Travel Channel, 10pm<br />
Season Finale!</strong><br />
A man uncovers an unholy secret in Kansas; a factory worker confronts the witch he believes cursed him; and a Philadelphia secretary is tormented by nightmares foretelling her death.</p>
	</div>
		<div id="text-771362228" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94"><img src="https://www.channelguidemag.com/wp-content/uploads/2017/08/CG-Ad_Save-66_728x90_Dolly.jpg" /></a></div>
		</div></article><div id="comments" class="mh-comments-wrap">
</div>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.channelguidemag.com/tv-news/2020/04/19/sunday-april-19-the-last-dance-revisits-the-1990s-chicago-bulls-dynasty/" rel="prev"><img width="80" height="60" src="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheLastDanceJordanBB-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheLastDanceJordanBB-80x60.jpg 80w, https://www.channelguidemag.com/wp-content/uploads/2020/04/TheLastDanceJordanBB-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="177506" data-permalink="https://www.channelguidemag.com/thelastdancejordanbb/" data-orig-file="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheLastDanceJordanBB.jpg" data-orig-size="1030,438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;1990 Getty Images&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="TheLastDanceJordanBB" data-image-description="" data-medium-file="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheLastDanceJordanBB-300x128.jpg" data-large-file="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheLastDanceJordanBB-1024x435.jpg" /><span>Previous</span><p>Sunday, April 19: &#8216;The Last Dance&#8217; Revisits the 1990s Chicago Bulls Dynasty</p></a></div>
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-next">
<a href="https://www.channelguidemag.com/tv-news/2020/04/20/on-demand-dvd-new-releases-april-20-26-2/" rel="next"><img width="80" height="60" src="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheGentlemen_web-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheGentlemen_web-80x60.jpg 80w, https://www.channelguidemag.com/wp-content/uploads/2020/04/TheGentlemen_web-678x509.jpg 678w, https://www.channelguidemag.com/wp-content/uploads/2020/04/TheGentlemen_web-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="177528" data-permalink="https://www.channelguidemag.com/tv-news/2020/04/20/on-demand-dvd-new-releases-april-20-26-2/thegentlemen_web/" data-orig-file="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheGentlemen_web.jpg" data-orig-size="1038,692" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="The Gentlemen" data-image-description="" data-medium-file="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheGentlemen_web-300x200.jpg" data-large-file="https://www.channelguidemag.com/wp-content/uploads/2020/04/TheGentlemen_web-1024x683.jpg" /><span>Next</span><p>On Demand DVD New Releases: April 20-26</p></a></div>
</nav>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="search-2" class="mh-widget widget_search"><form role="search" method="get" class="search-form" action="https://www.channelguidemag.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="text-771362232" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362225" class="mh-widget widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Subscribe</span></h4>			<div class="textwidget"><p><center><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&amp;publ=CG&amp;key=IZX2Y94"><img src="https://www.channelguidemag.com/wp-content/uploads/2017/07/save-66.gif" /><br />
<img style="max-width: 250px;" src="https://f1a66fb47ceb2043c6d5-23982838d2415744fc67238fdcf4584f.ssl.cf2.rackcdn.com/cover0420-400.jpg" /></a></center><br />
<span style="display: block; font: 100% Montserrat; margin: 0 auto; max-width: 250px;">The most complete TV listings and best recommendations delivered right to your door — every month.</span></p>
</div>
		</div><div id="mh_magazine_custom_posts-10" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">In This Issue</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-177484 post type-post status-publish format-standard has-post-thumbnail category-comedy category-interview category-archive category-preview category-tv-news-program-updates tag-14395 tag-fx">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2020/04/14/what-we-do-in-the-shadows-season-2-fx/" title="Close the Shades! &#8216;What We Do in the Shadows&#8217; Season 2 Rises on FX">
										Close the Shades! &#8216;What We Do in the Shadows&#8217; Season 2 Rises on FX									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/04/">April 14, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/04/14/what-we-do-in-the-shadows-season-2-fx/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-177422 post type-post status-publish format-standard has-post-thumbnail category-family category-archive category-movies tag-14395 tag-lifetime">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2020/04/09/the-clark-sisters-first-ladies-of-gospel-a-trailblazing-biopic-of-five-amazing-women-and-their-inspiring-songs/" title="&#8216;The Clark Sisters: First Ladies of Gospel&#8217; a Trailblazing Biopic of Five Amazing Women and Their Inspiring Songs">
										&#8216;The Clark Sisters: First Ladies of Gospel&#8217; a Trailblazing Biopic of Five Amazing Women and Their Inspiring Songs									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/04/">April 9, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/04/09/the-clark-sisters-first-ladies-of-gospel-a-trailblazing-biopic-of-five-amazing-women-and-their-inspiring-songs/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-177417 post type-post status-publish format-standard has-post-thumbnail category-comedy category-archive category-preview tag-14395 tag-abc">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2020/04/06/modern-family-finale-abc/" title="&#8216;Modern Family&#8217; Finale: Say Farewell to the Family That Changed TV Families Forever">
										&#8216;Modern Family&#8217; Finale: Say Farewell to the Family That Changed TV Families Forever									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/04/">April 6, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/04/06/modern-family-finale-abc/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>			</ul></div><div id="text-771362226" class="mh-widget widget_text">			<div class="textwidget"><div style="background-color:  #FF9245; font: 170% Montserrat; font-weight:bold; margin: 10px 0 0; padding: 5px 0; text-align: center;"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94" id="order-button">ORDER NOW!</a></div></div>
		</div><div id="text-771362326" class="mh-widget widget_text">			<div class="textwidget"><figure class="wp-caption aligncenter"  style="max-width: 500px">
			<img class="size-full wp-image-177481" src="https://www.channelguidemag.com/wp-content/uploads/2020/04/comfort-tv-logo.gif" alt="" width="500" height="332" />		<figcaption class="wp-caption-text" >
			<span class="media-credit"><a href="https://www.channelguidemag.com/tv-news/author/contributor/">Channel Guide Contributor</a></span>		</figcaption>
	</figure>

<p>The <em>TV Guide Magazine</em> staff talks about their Comfort TV picks, from <em>Cheers</em> to <em>Zoey’s Extraordinary Playlist</em>, on the TV Insider Podcast. Head to <a href="https://www.tvinsider.com/930125/tv-insider-podcast-comfort-tv-staff-picks-nailed-it-what-we-do-in-the-shadows/">tvinsider.com/podcast</a> to listen now!</p>
</div>
		</div><div id="text-771362234" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe src="https://widgets.tvinsider.com/discover/widgets/display.cfm?widgetGUID=e76eae7a-3166-419a-9f01-b1f984cc35a5" style="max-width:300px;width:100%;height:462px;border:0;"></iframe></div></div>
<div id="wpp-6" class="mh-widget popular-posts">
<h4 class="mh-widget-title"><span class="mh-widget-title-inner">Popular Posts</span></h4>            <script type="text/javascript">
                document.addEventListener('DOMContentLoaded', function() {
                    var wpp_widget_container = document.getElementById('wpp-6');

                    if ( 'undefined' != typeof WordPressPopularPosts ) {
                        WordPressPopularPosts.get(
                            wpp_params.ajax_url + '/widget/6',
                            'is_single=177515',
                            function(response){
                                wpp_widget_container.innerHTML += JSON.parse(response).widget;

                                let sr = wpp_widget_container.querySelector('.popular-posts-sr');

                                if ( sr ) {
                                    WordPressPopularPosts.theme(sr);
                                }

                                var event = null;

                                if ( 'function' === typeof(Event) ) {
                                    event = new Event("wpp-onload", {"bubbles": true, "cancelable": false});
                                } /* Fallback for older browsers */
                                else {
                                    if ( document.createEvent ) {
                                        event = document.createEvent('Event');
                                        event.initEvent("wpp-onload", true, false);
                                    }
                                }

                                if ( event ) {
                                    wpp_widget_container.dispatchEvent(event);
                                }
                            }
                        );
                    }
                });
            </script>
            
</div>
<div id="text-771362236" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362192" class="mh-widget widget_text">			<div class="textwidget"><center><!-- Medium_Rectangle_300x250 -->
<div id='div-gpt-ad-1426776676899-3'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1426776676899-3'); });
</script>
</div></center>

</div>
		</div><div id="text-771362233" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362223" class="mh-widget widget_text">			<div class="textwidget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#e8e8e8; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://channelguidemag.us4.list-manage.com/subscribe/post?u=a2d9de00dacb27b8907ecc15a&amp;id=6990079feb" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2 style="color: #f47d2a;">Email sign up!</h2>
Follow your favorite writers and/or get weekly updates to the best on TV.<br /><br />
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group input-group">
    <ul><li><input type="checkbox" value="1" name="group[2865][1]" id="mce-group[2865]-2865-0"><label for="mce-group[2865]-2865-0">5toWATCH Weekly eNewsletter</label></li>
    <li><input type="checkbox" value="131072" name="group[6821][131072]" id="mce-group[6821]-6821-0"><label for="mce-group[6821]-6821-0">Ryan Berenz posts</label></li>
<li><input type="checkbox" value="8388608" name="group[6821][8388608]" id="mce-group[6821]-6821-1"><label for="mce-group[6821]-6821-1">Kellie Freeze posts</label></li>
<li><input type="checkbox" value="262144" name="group[6821][262144]" id="mce-group[6821]-6821-2"><label for="mce-group[6821]-6821-2">Barb Oates posts</label></li>
<li><input type="checkbox" value="524288" name="group[6821][524288]" id="mce-group[6821]-6821-3"><label for="mce-group[6821]-6821-3">Jeff Pfeiffer posts</label></li>
</ul>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_a2d9de00dacb27b8907ecc15a_6990079feb" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[6]='ADDRESS';ftypes[6]='address';fnames[7]='KEYCODE';ftypes[7]='text';fnames[3]='SUBID';ftypes[3]='text';fnames[4]='VERSION';ftypes[4]='text';fnames[5]='EXPISSUE';ftypes[5]='text';fnames[8]='EXPYEAR';ftypes[8]='text';fnames[9]='ACTIVEMO';ftypes[9]='number';fnames[10]='SFGNO';ftypes[10]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
<!--End mc_embed_signup--></div>
		</div>	</aside>	</div>
    </div>
<footer class="mh-footer" id="footer-override">
	<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
					<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-1">
				<div id="text-771362230" class="mh-footer-widget widget_text">			<div class="textwidget"><img src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png"></div>
		</div><div id="mh_magazine_social-3" class="mh-footer-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-container"><ul id="menu-social-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>				</nav></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-2">
				<div id="nav_menu-4" class="mh-footer-widget widget_nav_menu"><div class="menu-top-menu-footer-container"><ul id="menu-top-menu-footer" class="menu"><li id="menu-item-151599" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-151599"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a></li>
<li id="menu-item-151600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151600"><a href="/movies-tv/">Movies On TV</a></li>
<li id="menu-item-151601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151601"><a href="/tv-listings/">TV Listings</a></li>
<li id="menu-item-151602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151602"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports</a></li>
<li id="menu-item-151603" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151603"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-151604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151604"><a href="https://www.channelguidemag.com/tv-news/category/binge-watching/">Binge Watching</a></li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-3">
				<div id="nav_menu-5" class="mh-footer-widget widget_nav_menu"><div class="menu-customer-service-container"><ul id="menu-customer-service-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">Subscribe</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-4">
				<div id="text-771362218" class="mh-footer-widget widget_text">			<div class="textwidget"><p><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&amp;publ=CG&amp;key=IZX2Y93"><img src="https://www.channelguidemag.com/wp-content/uploads/2017/07/CG-Ad_Save-66_300x250_Dolly.jpg" /></a></p>
</div>
		</div>			</div>
			</div>
</footer>
	<div class="mh-footer-mobile-nav"></div>
	<nav class="mh-footer-nav">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-publications-container"><ul id="menu-publications" class="menu"><li id="menu-item-151610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-151610"><a href="https://www.channelguidemag.com/">Channel Guide Magazine</a></li>
<li id="menu-item-151611" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151611"><a href="http://www.ondishmag.com">OnDISH Magazine</a></li>
<li id="menu-item-151612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151612"><a href="http://www.iwantmytvmagazine.com/">TV Weekly</a></li>
<li id="menu-item-151613" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151613"><a href="http://www.tvguidemagazine.com/">TV Guide</a></li>
<li id="menu-item-151614" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151614"><a href="http://www.view-mag.com/">VIEW Magazine</a></li>
<li id="menu-item-151615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151615"><a href="http://www.remindmagazine.com/">REMIND Magazine</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">@ 2020 Channel Guide Magazine</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
        <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
                <script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
        
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.channelguidemag.com\/tv-news\/2020\/04\/20\/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale\/":177515};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/tv-news/2020/04/20/monday-april-20-things-get-dire-for-jimmy-and-kim-in-better-call-saul-season-finale/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.channelguidemag.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/wp-embed.min.js?ver=12ad2e24ebd5082ea4904983bf327010'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.4.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202017.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.4.2',blog:'113259570',post:'177515',tz:'-5',srv:'www.channelguidemag.com'} ]);
	_stq.push([ 'clickTrackerInit', '113259570', '177515' ]);
</script>
</body>
</html>