<!DOCTYPE html>
<html class="no-js mh-one-sb" lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="profile" href="http://gmpg.org/xfn/11" />
<title>Friday, Feb. 21: &#039;Fresh Off the Boat&#039; Two-Part Series Finale on ABC - Channel Guide Magazine</title>

<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="In “Family Van,” the first episode of the two-part finale, Jaleel White guest-stars, and when the trusty Huang van takes a turn for the worst, Jessica and Louis each process the loss in their own way."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Friday, Feb. 21: &#039;Fresh Off the Boat&#039; Two-Part Series Finale on ABC - Channel Guide Magazine" />
<meta property="og:description" content="In “Family Van,” the first episode of the two-part finale, Jaleel White guest-stars, and when the trusty Huang van takes a turn for the worst, Jessica and Louis each process the loss in their own way." />
<meta property="og:url" content="https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/" />
<meta property="og:site_name" content="Channel Guide Magazine" />
<meta property="article:publisher" content="https://www.facebook.com/ChannelGuideMagazine" />
<meta property="article:section" content="TV Best Bets" />
<meta property="article:published_time" content="2020-02-21T12:12:57+00:00" />
<meta property="article:modified_time" content="2020-02-20T21:38:19+00:00" />
<meta property="og:updated_time" content="2020-02-20T21:38:19+00:00" />
<meta property="og:image" content="https://www.channelguidemag.com/wp-content/uploads/2020/02/FreshOffTheBoatFinaleBB.jpg" />
<meta property="og:image:secure_url" content="https://www.channelguidemag.com/wp-content/uploads/2020/02/FreshOffTheBoatFinaleBB.jpg" />
<meta property="og:image:width" content="1030" />
<meta property="og:image:height" content="438" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.channelguidemag.com/#website","url":"https://www.channelguidemag.com/","name":"Channel Guide Magazine","inLanguage":"en-US","description":"Our writers comment on the state of TV","potentialAction":{"@type":"SearchAction","target":"https://www.channelguidemag.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/#primaryimage","inLanguage":"en-US","url":"https://www.channelguidemag.com/wp-content/uploads/2020/02/FreshOffTheBoatFinaleBB.jpg","width":1030,"height":438},{"@type":"WebPage","@id":"https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/#webpage","url":"https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/","name":"Friday, Feb. 21: &#039;Fresh Off the Boat&#039; Two-Part Series Finale on ABC - Channel Guide Magazine","isPartOf":{"@id":"https://www.channelguidemag.com/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/#primaryimage"},"datePublished":"2020-02-21T12:12:57+00:00","dateModified":"2020-02-20T21:38:19+00:00","author":{"@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f"},"description":"In \u201cFamily Van,\u201d the first episode of the two-part finale, Jaleel White guest-stars, and when the trusty Huang van takes a turn for the worst, Jessica and Louis each process the loss in their own way."},{"@type":["Person"],"@id":"https://www.channelguidemag.com/#/schema/person/6fdbf81be098622882a3461cbb3e8e1f","name":"Channel Guide Staff","image":{"@type":"ImageObject","@id":"https://www.channelguidemag.com/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/68b6c70392ac45a38a16ac89e1b612bb?s=96&d=blank&r=g","caption":"Channel Guide Staff"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Feed" href="https://www.channelguidemag.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Channel Guide Magazine &raquo; Comments Feed" href="https://www.channelguidemag.com/comments/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-435360-2';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-435360-2', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.channelguidemag.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=992155a48e1b80f830c1d3baf8c7b15c"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.channelguidemag.com/wp-includes/css/dist/block-library/style.min.css?ver=992155a48e1b80f830c1d3baf8c7b15c' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='media-credit-css'  href='https://www.channelguidemag.com/wp-content/plugins/media-credit/public/css/media-credit.min.css?ver=4.0.4' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='parent-style-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/style.css?ver=992155a48e1b80f830c1d3baf8c7b15c' type='text/css' media='all' />
<link rel='stylesheet' id='mh-magazine-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine-child/style.css?ver=3.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='mh-font-awesome-css'  href='https://www.channelguidemag.com/wp-content/themes/mh-magazine/includes/font-awesome.min.css' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mh-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Droid+Sans:300,400,400italic,600,700,700italic%7cMontserrat:300,400,400italic,600,700,700italic' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://www.channelguidemag.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.2.2' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/www.channelguidemag.com","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/www.channelguidemag.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"176934","token":"82fe8fb8d9","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/scripts.js?ver=3.8.3'></script>
<link rel='https://api.w.org/' href='https://www.channelguidemag.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.channelguidemag.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.channelguidemag.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://wp.me/p7FdZg-K1M' />
<link rel="alternate" type="application/json+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2020%2F02%2F21%2Ffriday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.channelguidemag.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.channelguidemag.com%2Ftv-news%2F2020%2F02%2F21%2Ffriday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type="text/css">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</style>
<style type="text/css">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</style>
<!--[if lt IE 9]>
<script src="https://www.channelguidemag.com/wp-content/themes/mh-magazine/js/css3-mediaqueries.js"></script>
<![endif]-->
<style type="text/css">
h1, h2, h3, h4, h5, h6, .mh-custom-posts-small-title { font-family: "Montserrat", sans-serif; }
body { font-family: "Droid Sans", sans-serif; }
</style>
<link rel="amphtml" href="https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/amp/"><link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-32x32.png" sizes="32x32" />
<link rel="icon" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-180x180.png" />
<meta name="msapplication-TileImage" content="https://www.channelguidemag.com/wp-content/uploads/2016/05/cropped-CG-Web-Icon-512-270x270.png" />
<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>
<script type='text/javascript'>
googletag.cmd.push(function() {
var mapping2 = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot2= googletag.defineSlot('/4370989/CGM-lead-bottom-flex', [320,50], 'div-gpt-ad-1426776676899-0').
defineSizeMapping(mapping2).
addService(googletag.pubads()).
setCollapseEmptyDiv(true);
var mapping = googletag.sizeMapping().
        addSize([480, 200], [320, 50]).
        addSize([768, 200], [728, 90]).
        build();
window.slot1= googletag.defineSlot('/4370989/cgm-lead-flexible-top', [320,50], 'div-gpt-ad-1426776676899-1').
defineSizeMapping(mapping).
addService(googletag.pubads());

googletag.defineSlot('/4370989/Medium_Rectangle_2_internal_ads', [300, 250], 'div-gpt-ad-1426776676899-2').addService(googletag.pubads());
googletag.defineSlot('/4370989/Medium_Rectangle_300x250', [300, 250], 'div-gpt-ad-1426776676899-3').addService(googletag.pubads());

googletag.pubads().enableSingleRequest();
googletag.enableServices();
});
</script>
</head>
<body id="mh-mobile" class="post-template-default single single-post postid-176934 single-format-standard mh-boxed-layout mh-right-sb mh-loop-layout2 mh-widget-layout2" itemscope="itemscope" itemtype="http://schema.org/WebPage">
<div class="mh-container mh-container-outer">
<div class="mh-header-nav-mobile clearfix"></div>
<header class="mh-header" itemscope="itemscope" itemtype="http://schema.org/WPHeader">
	<div class="mh-container mh-container-inner clearfix">
		<div class="mh-custom-header clearfix">
<a class="mh-header-image-link" href="https://www.channelguidemag.com/" title="Channel Guide Magazine" rel="home">
<img class="mh-header-image" src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png" height="139" width="496" alt="Channel Guide Magazine" />
</a>
</div>
	</div>
	<div class="mh-main-nav-wrap">
		<nav class="mh-navigation mh-main-nav mh-container mh-container-inner clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<div class="menu-top-menu-container"><ul id="menu-top-menu" class="menu"><li id="menu-item-151619" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-151619"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a>
<ul class="sub-menu">
	<li id="menu-item-99133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99133"><a href="https://www.channelguidemag.com/movies-tv/">Movies on TV</a></li>
	<li id="menu-item-99135" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-99135"><a href="/tv-listings/">TV Listings</a></li>
	<li id="menu-item-154098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-154098"><a href="https://www.channelguidemag.com/tv-news/category/vod/">New to On Demand &#038; DVD</a></li>
</ul>
</li>
<li id="menu-item-151620" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151620"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-99134" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-99134"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports on TV</a>
<ul class="sub-menu">
	<li id="menu-item-152175" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-152175"><a href="https://www.channelguidemag.com/sports-on-tv/">This Week&#8217;s Schedule</a></li>
</ul>
</li>
<li id="menu-item-151622" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151622"><a href="/network-contacts/">How to contact a Network</a></li>
</ul></div>		</nav>
	</div>
	</header>
	<div class="mh-subheader">
		<div class="mh-container mh-container-inner mh-row clearfix">
							<div class="mh-header-bar-content mh-header-bar-bottom-left mh-col-2-3 clearfix">
											<nav class="mh-navigation mh-header-nav mh-header-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-customer-service-container"><ul id="menu-customer-service" class="menu"><li id="menu-item-151605" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">Subscribe</a>
<ul class="sub-menu">
	<li id="menu-item-151606" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li id="menu-item-151607" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li id="menu-item-151608" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li id="menu-item-151609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li id="menu-item-156378" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div>						</nav>
									</div>
										<div class="mh-header-bar-content mh-header-bar-bottom-right mh-col-1-3 clearfix">
											<nav class="mh-social-icons mh-social-nav mh-social-nav-bottom clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
							<div class="menu-social-container"><ul id="menu-social" class="menu"><li id="menu-item-151616" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li id="menu-item-151617" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li id="menu-item-151618" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>						</nav>
									</div>
					</div>
	</div>

<div class="mh-wrapper clearfix">
<span class='mh-best-bets-caption'>TV Best Bets</span>	<div class="mh-main clearfix">
		<div id="main-content" class="mh-content"><article id="post-176934" class="post-176934 post type-post status-publish format-standard has-post-thumbnail hentry category-tv-best-bets">
	<header class="entry-header clearfix">
		<h1 class="entry-title">
			Friday, Feb. 21: &#8216;Fresh Off the Boat&#8217; Two-Part Series Finale on ABC		</h1>
		<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/02/">February 21, 2020</a></span>
<span class="entry-meta-author author vcard"><i class="fa fa-user"></i><a class="fn" href="https://www.channelguidemag.com/tv-news/author/staff/">Channel Guide Staff</a></span>
<span class="entry-meta-categories"><i class="fa fa-folder-open-o"></i><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/" rel="category tag">TV Best Bets</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><span class="mh-comment-count-link">Comments Off<span class="screen-reader-text"> on Friday, Feb. 21: &#8216;Fresh Off the Boat&#8217; Two-Part Series Finale on ABC</span></span></span>
</div>
	</header>
		<div class="entry-content clearfix"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-email"><a rel="nofollow noopener noreferrer" data-shared="" class="share-email sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/?share=email" target="_blank" title="Click to email this to a friend"><span></span><span class="sharing-screen-reader-text">Click to email this to a friend (Opens in new window)</span></a></li><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-176934" class="share-facebook sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-pinterest"><a rel="nofollow noopener noreferrer" data-shared="sharing-pinterest-176934" class="share-pinterest sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/?share=pinterest" target="_blank" title="Click to share on Pinterest"><span></span><span class="sharing-screen-reader-text">Click to share on Pinterest (Opens in new window)</span></a></li><li class="share-reddit"><a rel="nofollow noopener noreferrer" data-shared="" class="share-reddit sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/?share=reddit" target="_blank" title="Click to share on Reddit"><span></span><span class="sharing-screen-reader-text">Click to share on Reddit (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-176934" class="share-twitter sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://www.channelguidemag.com/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>
<figure class="entry-thumbnail">
<img src="https://www.channelguidemag.com/wp-content/uploads/2020/02/FreshOffTheBoatFinaleBB-678x381.jpg" alt="" title="FreshOffTheBoatFinaleBB" />
<span class="media-credit">Andrew Eccles/ABC</span></figure>
<p><strong>All Times Eastern.</strong></p>
<h2><strong>Friday, Feb. 21</strong></h2>
<p><strong>Fresh Off the Boat<br />
ABC, 8pm<br />
Series Finale!</strong><br />
In “Family Van,” the first episode of the two-part finale, Jaleel White guest-stars, and when the trusty Huang van takes a turn for the worst, Jessica (Constance Wu) and Louis (Randall Park) each process the loss in their own way. In the second episode, “Commencement,” Jessica grapples with her vision of the future as the boys are each realizing what their own goals are. Andy Richter guest-stars.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='640' height='360' src='https://www.youtube.com/embed/Uq4WMjffMVg?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p><strong>The Last Thing He Wanted<br />
Netflix<br />
Original Film!</strong><br />
Anne Hathaway, Ben Affleck, Rosie Perez, Willem Dafoe and Mel Rodriguez lead the cast of this political thriller set against the nebulous backdrop of the 1980s Iran-Contra scandal and based on the Joan Didion novel of the same name.</p>
<p><strong>The Waltons: “The Bequest”<br />
MeTV, 12pm</strong><br />
The promise of inherited money results in both happy moments and unusual conflicts for the Walton family.</p>
<p><strong>MacGyver: “Kid + Plane + Cable + Truck”<br />
CBS, 8pm</strong><br />
In the new episode “Kid + Plane + Cable + Truck,” Mac (Lucas Till) and his team have to board an in-flight airplane after the pilot suffers a heart attack.</p>
<p><strong>NBA Basketball<br />
ESPN, beginning at 8pm Live</strong><br />
ESPN’s Friday night NBA doubleheader has a pair of Western Conference clashes with the Denver Nuggets at the Oklahoma City Thunder and the New Orleans Pelicans at the Portland Trail Blazers.</p>
<p><strong>Lincoln Rhyme: Hunt for the Bone Collector: “’Til Death Do Us Part”<br />
NBC, 8pm</strong><br />
Lincoln (Russell Hornsby) and the team hunt a serial killer who stages perfect murders by brilliantly framing suspects in what appear to be open and shut cases. The hunt hits home when one of Lincoln’s closest friends is accused.</p>
<p><strong>Gold Rush: Dave Turin’s Lost Mine<br />
Discovery Channel, 9pm<br />
Season Premiere!</strong><br />
This season, Dave is expanding his hunt for an even bigger payday in the historic lost mines of Montana. With more than 3,500 abandoned mines in the Treasure State, Dave believes one of them could be a jackpot in gold. But finding it will require him to uncover the history and decode the land like never before.</p>
<p><strong>Haunting in the Heartland: “The Watchman”<br />
Travel Channel, 10pm<br />
New Series!</strong><br />
Steve Shippy is called to Merrill, Mich., to investigate an evil entity tormenting a young girl. With the help of a local historian, he discovers the town’s long-forgotten traumatic past and its connection to the girl’s home.</p>
<p><strong>The Hours<br />
TCM, 10:30pm</strong><br />
Continuing its 31 Days of Oscar celebration, Turner Classic Movies presents the network premiere of this acclaimed, Oscar-winning 2002 psychological drama based on the novel by Michael Cunningham. Nicole Kidman won a Best Actress Oscar for her performance here, and she is joined by a stellar cast including Miranda Richardson, Julianne Moore, John C. Reilly, Meryl Streep, Ed Harris and many more.</p>
<p><strong>This Week at the Comedy Cellar<br />
Comedy Central, 11pm<br />
Season Premiere!</strong><br />
Comedians of all stripes, from rising stars to established legends, pop into New York’s legendary Comedy Cellar every week for a topical set.</p>
<h3><strong>Saturday, Feb. 22</strong></h3>
<p><strong>51st NAACP Image Awards<br />
BET, 8pm Live</strong><br />
The annual ceremony again honors the accomplishments of people of color in the fields of television, music, literature and film, and also recognizes individuals or groups who promote social justice through creative endeavors. Netflix leads this year’s television nominees with 30 nominations, and has 12 more movie nominations, for titles like <em>Dear White People</em>, <em>When They See Us </em>and <em>American Son</em>. This marks the first year that the Image Awards, previously televised by TV One, are being broadcast by BET, which celebrates its 40th anniversary this year.</p>
<p><strong>Almost Family<br />
FOX, 8pm<br />
Season Finale!</strong><br />
Season 1 of <em>Almost Family</em> concludes with the episodes “Permanent AF” and “Expectant AF.” The trial against Dr. Bechley (Timothy Hutton) begins, and Julia (Brittany Snow) gains the confidence to approach Donovan (Michael Stahl-David) again about her desire for a family.</p>
<p><strong>Seven Worlds, One Planet: “Antarctica”<br />
BBC America, 9pm</strong><br />
Filming crews spent 236 days capturing Antarctica: our coldest, windiest, most hostile continent. Footage of the largest great whale aggregation ever filmed nearly didn’t make it into this episode. After seven weeks searching for the sequence, on the one day it all came together, the crew’s helicopter broke and the drone malfunctioned. Thankfully, the drone operator managed to save the memory card at the last minute. In addition to the whales, viewers will witness Weddell seals that grind back the ice with their teeth, colorful starfish carpeting the seabed beneath the ice, huge colonies of king penguins crowding any ice-free land, and four-ton elephant seals fighting for territory on the beach.</p>
<p><strong>Love in Store<br />
Hallmark Channel, 9pm<br />
Original Film!</strong><br />
Shopping network hosts Terrie (Alexandra Breckenridge) and David (Robert Buckley) have different styles and personalities that clash. Each wants a promotion, but first they’ll have to get along as cohosts.</p>
<p><strong>Whitmer Thomas: The Golden One<br />
HBO, 10pm</strong><br />
Comedian and actor Whitmer Thomas features his deeply personal, provocative and unconventional standup and original songs in his first hourlong special from the legendary Flora-Bama Lounge, located along the state line between Florida and Alabama.</p>
<h3><strong>Sunday, Feb. 23</strong></h3>
<p><strong>College Basketball<br />
CBS &amp; FS1, beginning at 2pm Live</strong><br />
Highlights of Sunday’s college basketball action include St. John’s at Seton Hall (CBS), Butler at Creighton (FS1) and Maryland at Ohio State (CBS).</p>
<p><strong>The Walking Dead<br />
AMC, 9pm<br />
New Episodes!</strong><br />
Back from its Season 10 hiatus, there’s a lot to worry about now that the survivors know Alpha was behind the Whisperer spy Dante. The season ended with Gabriel stabbing Dante for killing Siddiq, but how many other double agents might be mixed in with their community? And what’s going to happen to Carol, Daryl and the rest of the survivors who fell onto a cave-like plateau with a herd of zombies below them?</p>
<p><strong>Sanditon<br />
PBS, 9pm<br />
Season Finale!<br />
</strong>On the night of the Midsummer Ball, romance, jealousy and betrayal fill the air. Events conspire to leave Charlotte and the Parker family facing difficult choices.</p>
<p><strong>Better Call Saul<br />
AMC, 10pm<br />
Season Premiere!</strong><br />
In the 10-episode fifth season, Jimmy’s (Bob Odenkirk) decision to practice law as “Saul Goodman” creates unexpected and profound waves of change for those in his orbit. Tomorrow the series continues in its regular time slot. Rhea Seehorn, Jonathan Banks, Giancarlo Esposito, Patrick Fabian and Michael Mando all return.</p>
<p><strong>Unknown Valor: A Story of Family, Courage &amp; Sacrifice<br />
FOX News Channel, 10pm</strong><br />
<a href="https://www.channelguidemag.com/tv-news/2020/02/11/martha-maccallum-fox-news-channel-5-questions/" target="_blank" rel="noopener noreferrer">Martha MacCallum</a>, anchor of FOX News Channel&#8217;s <em>The Story</em>, hosts this one-hour special based on her book <em><a href="https://www.amazon.com/Valor-Family-Courage-Sacrifice-Harbor-ebook/dp/B07S9S3DB1" target="_blank" rel="noopener noreferrer">Unknown Valor: A Story of Family, Courage, and Sacrifice From Pearl Harbor to Iwo Jima</a></em>, available Feb. 25. The special takes viewers behind her journey to find answers about the death of her uncle, Private Harry Gray, on Iwo Jima more than 70 years ago. An extended director’s cut version containing additional footage will be available on streaming service FOX Nation immediately after airing on FOX News Channel.</p>
<p><strong>Forensic Files II<br />
HLN, 10pm<br />
New Series!</strong><br />
<em>Forensic Files</em>, one of TV’s earliest true-crime docuseries, ceased production in 2011, but has continued airing in repeats that remain popular. Now, 16 new episodes of the series will begin airing starting this month. Original series narrator Peter Thomas passed away in 2016, and at presstime a new narrator had not been announced.</p>
<p><strong>Vienna Blood<br />
PBS, 10pm<br />
Season Finale!</strong><br />
Suspicion at the military school falls on an elite group of cadets with a penchant for sadism and dangerous games. Solving the case will have a devastating impact on both Oskar and Max’s professional lives.</p>
<h3><strong>Monday, Feb. 24</strong></h3>
<p><strong>College Basketball<br />
ESPN, beginning at 7pm Live</strong><br />
Monday night college basketball on ESPN has the Louisville Cardinals at the Florida State Seminoles, followed by the Oklahoma State Cowboys at the Kansas Jayhawks.</p>
<p><strong>9-1-1: Lone Star: “Bum Steer”<br />
FOX, 8pm</strong><br />
Owen (Rob Lowe) and his team are called to deal with a runaway bull in a used-car lot in the new episode “Bum Steer.”</p>
<p><strong>The Voice<br />
NBC, 8pm<br />
Season Premiere!</strong><br />
The hit singing competition returns for Season 18, with musician/actor Nick Jonas joining the coaching lineup alongside Kelly Clarkson, John Legend and Blake Shelton.</p>
<p><strong>Black in Space: Breaking the Color Barrier<br />
Smithsonian Channel, 8pm</strong><br />
In the early 1960s, the Kennedy administration pushed to have fighter pilot Ed Dwight become the first black astronaut in space, but it would not be until 1983 that Guion Bluford broke NASA’s astronaut color barrier and flew into orbit. Black astronauts and their families share their stories in this documentary special.</p>
<p><strong>Better Call Saul<br />
AMC, 9pm</strong><br />
Season 5 of Saul Goodman’s (Bob Odenkirk) journey continues tonight. The series will remain in this Monday time slot.</p>
<p><strong>The Good Doctor: “Autopsy”<br />
ABC, 10pm</strong><br />
When Dr. Murphy (Freddie Highmore) makes an emotional confession, the result may not be as desired. Meanwhile, he becomes obsessed with performing an autopsy on a Jane Doe, which challenges his relationships at the hospital. Dr. Browne (Antonia Thomas), Dr. Reznick (Fiona Gubelmann) and Dr. Andrews (Hill Harper) treat a male college student with a mysterious split personality disorder.</p>
<h3><strong>Tuesday, Feb. 25</strong></h3>
<p><strong>NBA Basketball</strong><br />
TNT, beginning at 7:30pm Live<br />
A rematch of last season’s Eastern Conference finals has Kyle Lowry and the Toronto Raptors on the road against Giannis Antetokounmpo and the Milwaukee Bucks. Then Jrue Holiday leads the New Orleans Pelicans into Los Angeles for a bout with LeBron James and the Lakers.</p>
<p><strong>The Conners: “Bad Dads and Grads”<br />
ABC, 8pm</strong><br />
Dan (John Goodman) starts to bond with his younger half-brother (guest star Noel Fisher), but he can’t get over the fact that their father paid for Ed Jr.’s college education, something he refused to do for Dan. Jackie (Laurie Metcalf) hits it off with a fun married couple (guest stars and real-life husband and wife Clark Gregg and Jennifer Grey), so much so that they “invite” her into their relationship.</p>
<p><strong>CBS News Democratic Primary Debate<br />
CBS, 8pm Live</strong><br />
CBS News and the Congressional Black Caucus Institute cohost the 10th Democratic presidential primary debate from the Gaillard Center in Charleston, S.C.</p>
<p><strong>Gordon Ramsay’s 24 Hours to Hell and Back<br />
FOX, 8pm<br />
Season Finale!</strong><br />
Gordon Ramsay travels to Arkansas in the two-part season finale. In Conway, Bear’s Den Pizza is struggling due to one owner’s drunken outbursts and another owner’s absenteeism. In Little Rock, the Korean-inspired South Boulevard restaurant is in decline because of the owner’s inexperience.</p>
<p><strong>The Curse of Oak Island: Drilling Down: “William Shatner Meets Oak Island”<br />
History, 8pm</strong><br />
<em>Star Trek</em> icon William Shatner joins the team in the war room and gets a firsthand look at how an obscure island off the coast of Nova Scotia has become a global phenomenon.</p>
<p><strong>Finding Your Roots: “Criminal Kind”<br />
PBS, 8pm</strong><br />
Henry Louis Gates Jr. explores the roots of actor Laura Linney and journalists Lisa Ling and Soledad O’Brien, telling them stories of tricksters, scoundrels and outright criminals who nevertheless laid the groundwork for their success.</p>
<p><strong>Vanderpump Rules: “Ex-Best Man, Ex-Best Friend”<br />
Bravo, 9pm</strong><br />
In the wake of their explosive fight, Jax kicks Sandoval out of his wedding party and considers disinviting him from Kentucky completely. Meanwhile, Ariana pushes Lala and Stassi away as she spirals into a dark place, Scheana sabotages Brett and Charli’s date, Brittany must figure out if Ariana is still her bridesmaid and Lisa Vanderpump receives some devastating news.</p>
<p><strong>This Is Us: “Clouds”<br />
NBC, 9pm</strong><br />
Kevin (Justin Hartley) spends the day with Rebecca (Mandy Moore). Toby (Chris Sullivan) makes a grand gesture. The Big Three get their report cards.</p>
<p><strong>American Masters: “Miles Davis: Birth of the Cool”<br />
PBS, 9pm</strong><br />
Discover the man behind the legend. With full access to the Miles Davis Estate, the film features never-before-seen footage, including studio outtakes from his recording sessions, rare photos and new interviews.</p>
<p><strong>New Amsterdam: “Double Blind”<br />
NBC, 10pm</strong><br />
When tasked with turning the opioid epidemic around, Max (Ryan Eggold) shuts down the ED and proposes a massive change. Meanwhile, Sharpe (Freema Agyeman) goes to great lengths to prove a point.</p>
<p><strong>Ink Master: “Sugar Rush”<br />
Paramount Network, 10pm</strong><br />
In the new episode “Sugar Rush,” artists are hungry for the win — and one bites off more than they can chew — when they create sweet, full-color food tattoos.</p>
<h3><strong>Wednesday, Feb. 26</strong></h3>
<p><strong>I Am Not Okay With This<br />
Netflix<br />
New Series!</strong><br />
This series based on Charles Forsman’s graphic novel comes from Jonathan Entwistle, the director/executive producer of <em>The End of the F***ing World</em>, and the producers of <em>Stranger Things</em>. It’s an irreverent origin story that follows Sydney (Sophia Lillis, <em>It</em>), who is navigating the trials and tribulations of high school all while dealing with her family, her budding sexuality and the mysterious superpowers just beginning to awaken deep within her.</p>
<p><strong>NBA Basketball<br />
ESPN, beginning at 7:30pm Live</strong><br />
Luka Dončić and the Dallas Mavericks head to San Antonio to take on LaMarcus Aldridge and the Spurs. In ESPN’s second game, Kemba Walker and the Boston Celtics are in Salt Lake City to battle Bojan Bogdanović and the Utah Jazz.</p>
<p><strong>The Real Housewives of New Jersey: “Family Reunion”<br />
Bravo, 8pm<br />
Season Finale!</strong><br />
Margaret and Teresa’s friendship faces the ultimate test. Shockingly, Joe Giudice leaves ICE for Italy, and Teresa and the girls arrive to see Joe. Teresa and Joe decide the future of their relationship.</p>
<p><strong>Riverdale: “Chapter Seventy-One: How to Get Away With Murder”<br />
The CW, 8pm</strong><br />
When a night in the woods goes horribly awry, Betty (Lili Reinhart), Archie (KJ Apa) and Veronica (Camila Mendes) are forced to confront what one of them may be capable of.</p>
<p><strong>The Masked Singer: “Mask-Matics: Group B Playoffs”<br />
FOX, 8pm</strong><br />
Gabriel Iglesias is a guest judge as Group B singers return for their playoff performances in the new episode “Mask-Matics: Group B Playoffs.”</p>
<p><strong>Chicago Med: “I Will Do No Harm”<br />
NBC, 8pm</strong><br />
Drs. Charles (Oliver Platt) and Manning (Torrey DeVitto) treat a patient who is fully invested in pretending to be someone other than himself. Noah (Roland Buck III) begins to doubt his abilities as a doctor. Drs. Marcel (Dominic Rains) and Choi (Brian Tee) are faced with a tough ethical decision. Dr. Halstead (Nick Gehlfuss) puts his faith in an addict.</p>
<p><strong>NHL Hockey<br />
NBCSN, beginning at 8pm Live</strong><br />
A <em>Wednesday Night Hockey</em> doubleheader has the Buffalo Sabres at the Colorado Avalanche, followed by the Pittsburgh Penguins at the L.A. Kings.</p>
<p><strong>SEAL Team: “Siege Protocol”<br />
CBS, 9pm<br />
New Episodes!</strong><br />
<em>SEAL Team</em> returns from winter break with a two-episode event titled “Siege Protocol.” Jason (David Boreanaz) and Bravo Team travel to Venezuela to extract a CIA agent being held hostage by that country’s special police force.</p>
<p><strong>LEGO Masters: “Movie Genres”<br />
FOX, 9pm</strong><br />
<em>The LEGO Movie </em>directors Christopher Miller and Phil Lord task the contestants with a building project straight out of Hollywood in the new episode “Movie Genres.”</p>
<p><strong>Chicago Fire: “Off the Grid”<br />
NBC, 9pm</strong><br />
In the first part of a two-show crossover event with <em>Chicago P.D.</em>, a series of teen opioid overdoses sees Severide (Taylor Kinney) partner with Sean Roman (guest star Brian Geraghty), but he begins to suspect there’s more to the story than his old friend is telling him. Casey (Jesse Spencer) tries to be there for Brett (Kara Killmer) as she considers her birth mother’s offer to meet.</p>
<p><strong>Chicago P.D.: “Burden of Truth”<br />
NBC, 10pm</strong><br />
In the conclusion of the crossover with <em>Chicago Fire</em>, Intelligence searches for the dealer who caused multiple overdoses and is connected to Roman’s (Brian Geraghty) missing sister. The case becomes a homicide investigation when they find the dealer’s dead body.</p>
<p><strong>Year of the Rabbit: “Brick Man”<br />
IFC, 10:30pm</strong><br />
In the new episode “Brick Man,” Detective Inspector Rabbit (Matt Berry) and his cohorts must capture a killer stalking the streets of London disguised as the Brick Man, a terrifying figure from urban folklore.</p>
<h3><strong>Thursday, Feb. 27</strong></h3>
<p><strong>Altered Carbon<br />
Netflix<br />
Season Premiere!</strong><br />
Season 2 of the sci-fi drama finds Takeshi Kovacs (Anthony Mackie), the lone surviving soldier out of a group of elite interstellar warriors, continuing his centuries-old quest to find his lost love Quellcrist Falconer (Renée Elise Goldsberry). After decades of planet-hopping, Kovacs finds himself recruited back to his home planet of Harlan’s World with the promise of finding Quell.</p>
<p><strong>Followers<br />
Netflix<br />
New Series!</strong><br />
This visually stunning series directed by Mika Ninagawa is set in Tokyo and juxtaposes the lives of two different women: Limi Nara (Miki Nakatani), a fashion photographer confident in her career and relationships, and Natsume Hyakuta (Elaiza Ikeda), an aspiring actress struggling to find her identity and self-confidence.</p>
<p><strong>College Basketball<br />
ESPN2 &amp; FS1, beginning at 7pm Live</strong><br />
The Indiana Hoosiers visit the Purdue Boilermakers for a Big Ten matchup on FS1. Then on ESPN2, the Oregon State Beavers are at the Oregon Ducks in a Pac-12 rivalry game.</p>
<p><strong>NHL Hockey: Dallas at Boston<br />
NBCSN, 7:30pm Live</strong><br />
Tyler Seguin and the Dallas Stars are in Boston to face off against Brad Marchand and the Bruins on NBCSN.</p>
<p><strong>Last Man Standing: “I’m With Cupid”<br />
FOX, 8pm</strong><br />
Mike (Tim Allen) sets Joe (returning guest star Jay Leno) up on a date with Cece (guest star Melissa Peterman) in the new episode “I’m With Cupid.”</p>
<p><strong>NBA Basketball<br />
TNT, beginning at 8pm Live</strong><br />
TNT’s Thursday night NBA twin bill features Damian Lillard’s Portland Trail Blazers at Domantas Sabonis’ Indiana Pacers and the L.A. Lakers at the Golden State Warriors.</p>
<p><strong>A Year in Music: “1984”<br />
AXS TV, 8:30pm</strong><br />
Downtown Julie Brown visits the musical year 1984 to examine the birth of the Video Music Awards, the landmark distribution of Bruce Springsteen’s <em>Born in the U.S.A.</em> on compact disc and Michael Jackson’s ascension to “King of Pop” in the wake of his legendary <em>Thriller</em> album.</p>
<p><strong>Outmatched: “Bullying”<br />
FOX, 8:30pm</strong><br />
In the new episode “Bullying,” Mike (Jason Biggs) and Kay (Maggie Lawson) look into a charter school for Marc (Jack Stanton) after he is brought into the principal’s office for bullying his teacher.</p>
<p><strong>Brooklyn Nine-Nine: “Debbie”<br />
NBC, 8:30pm</strong><br />
When cocaine and weapons are stolen from the evidence lock-up, the squad must investigate the Nine-Nine itself.</p>
<p><strong>Grey’s Anatomy: “Snowblind”<br />
ABC, 9pm</strong><br />
Meredith (Ellen Pompeo) and Carina (Stefania Spampinato) question DeLuca’s (Giacomo Gianniotti) uncharacteristic behavior when he volunteers to perform a life-threatening task during a blizzard. Meanwhile, Bailey (Chandra Wilson) tries to help Joey (guest star Noah Alexander Gerry) with his future, while Richard (James Pickens Jr.) trains a new intern at the hospital.</p>
<p><strong>Project Runway: “The Height of Avant-Garde Fashion”<br />
Bravo, 9pm<br />
</strong>With only one challenge left to make it to New York Fashion Week, the remaining designers must think big to create an avant-garde look that is anything but ordinary. In a fashion first, the runway begins with a season-long retrospective, outside and 16 stories high, at New York City’s dramatic Vessel. The stakes are as high as the runway, because in fashion, one day you’re in, and in this challenge, two will be out.</p>
<p><strong>Deputy: “10-8 Entitlements”<br />
FOX, 9pm</strong><br />
In the new episode “10-8 Entitlements,” the sheriff’s department uncovers a West Hollywood burglary ring with crooks competing against each other for bragging rights.</p>
<p><strong>Swamp People: “Friday the 13th”<br />
History, 9pm</strong><br />
Strange things are happening in the swamp on Friday the 13th. Daniel and Big Tee chase a bait-stealing monster called the Ghost. Jacob and Don hit a run of bad luck while Willie and his son brave the hazardous waters of the Graveyard. Brock and Aaron find a good luck charm.</p>
<p><strong>Will &amp; Grace: “Filthy Phil, Part 1”<br />
NBC, 9pm</strong><br />
Karen (Megan Mullally) introduces Will (Eric McCormack) and Grace (Debra Messing) to the new love of her life, Phil (guest star Joel McHale). But Will and Grace become increasingly suspicious that Phil has sinister intentions for their friend. When Miss Coco Peru (guest star Clinton Leupp) tells Jack (Sean Hayes) that she’s closing down her bar for good, Estefan (guest star Brian Jordan Alvarez) encourages Jack to become its new owner.</p>
<p><strong>Ghost Adventures<br />
Travel Channel, 9pm<br />
New Episodes!</strong><br />
New episodes of the paranormal investigation series return.</p>
<p><strong>Indebted: “Everybody’s Talking About Hot Goss”<br />
NBC, 9:30pm</strong><br />
Joanna (Jessy Hodges) has a new girlfriend who doesn’t like to gossip. This forces the family to take a long hard look at the way they communicate, because they love hot goss.</p>
<p><strong>Tommy: “19 Hour Day”<br />
CBS, 10pm</strong><br />
In the new episode “19 Hour Day,” Tommy (Edie Falco) must contend with a protest that turns violent at the same time a mudslide shuts down a major freeway.</p>
<p><strong>Law &amp; Order: Special Victims Unit: “Eternal Relief From Pain”<br />
NBC, 10pm</strong><br />
Rollins’ (Kelli Giddish) sister stirs up trouble and a possible SVU investigation when she reports a doctor who trades prescription painkillers for sex.</p>
<h3><strong>Friday, Feb. 28</strong></h3>
<p><strong>All the Bright Places<br />
Netflix<br />
Original Film!</strong><br />
Based on Jennifer Niven’s bestseller, this film tells the story of Violet (Elle Fanning) and Theodore (Justice Smith), who meet and change each other’s lives forever. The drama offers a human take on the experience of mental illness, its impact on relationships, and the beauty and lasting impact of young love.</p>
<p><strong>Queen Sono<br />
Netflix<br />
New Series!</strong><br />
In this South African crime drama — Netflix’s first original series from Africa — a highly trained spy (Pearl Thusi) must face changing relationships in her personal life while taking on her most dangerous mission yet.</p>
<p><strong>The Waltons: “The Heritage”<br />
MeTV, 12pm</strong><br />
An important message is shared in this Season 2 episode, where John receives an offer from a developer to buy their land. While the money would solve their financial hardships and pay for some of John-Boy’s schooling, would it be worth compromising his family’s heritage?</p>
<p><strong>Shark Tank<br />
ABC, 8pm<br />
New Episodes!</strong><br />
Shark Tank continues Season 11 with a return to Friday nights. In this new episode, a husband and wife duo from Los Angeles pitch their stylish weighted design that adds a constant but comfortable resistance to your workout. Entrepreneurs from Sunset Beach, Calif., try to get the Sharks to bite on their product that eliminates bland dog food and will get dogs excited to eat. Brothers from Portland, Oregon, seek an investment for their event space that features an American family-favorite game. Finally, entrepreneurs from New York City introduce their multipurpose hair and skin-softening product for the nether regions. Maria Sharapova guest judges.</p>
<p><strong>NBA Basketball<br />
ESPN, beginning at 8pm Live</strong><br />
Some of the NBA’s elite teams are in action tonight on ESPN as Chris Paul leads the Oklahoma City Thunder into Milwaukee to battle Giannis Antetokounmpo and the Bucks. In the second game, Jamal Murray and the Denver Nuggets are in Los Angeles to clash with Kawhi Leonard and the Clippers.</p>
<p><strong>Lincoln Rhyme: Hunt for the Bone Collector: “Requiem”<br />
NBC, 8pm</strong><br />
Lincoln (Russell Hornsby), Amelia (Arielle Kebbel) and the team are tasked with tracking down an anonymous bomber targeting a string of buildings all across Manhattan. Meanwhile, the marriage between the Bone Collector (Brian F. O’Byrne) and his wife, Danielle (Claire Coffee), reaches a terrifying crossroad.</p>
<p>&nbsp;</p>
	</div>
		<div id="text-771362228" class="mh-widget mh-posts-2 widget_text">			<div class="textwidget"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94"><img src="https://www.channelguidemag.com/wp-content/uploads/2017/08/CG-Ad_Save-66_728x90_Dolly.jpg" /></a></div>
		</div></article><div id="comments" class="mh-comments-wrap">
</div>
<nav class="mh-post-nav mh-row clearfix" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
<div class="mh-col-1-2 mh-post-nav-item mh-post-nav-prev">
<a href="https://www.channelguidemag.com/tv-news/2020/02/20/thursday-feb-20-grace-has-a-mishap-at-the-aquarium-on-will-grace/" rel="prev"><img width="80" height="60" src="https://www.channelguidemag.com/wp-content/uploads/2017/09/Will_Grace_0917_BB-80x60.jpg" class="attachment-mh-magazine-small size-mh-magazine-small wp-post-image" alt="" srcset="https://www.channelguidemag.com/wp-content/uploads/2017/09/Will_Grace_0917_BB-80x60.jpg 80w, https://www.channelguidemag.com/wp-content/uploads/2017/09/Will_Grace_0917_BB-326x245.jpg 326w" sizes="(max-width: 80px) 100vw, 80px" data-attachment-id="165906" data-permalink="https://www.channelguidemag.com/tv-news/2017/09/14/2017-fall-tv-preview-familiar-faces-in-new-places/will_grace_0917_bb/" data-orig-file="https://www.channelguidemag.com/wp-content/uploads/2017/09/Will_Grace_0917_BB.jpg" data-orig-size="1030,438" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;Will &amp; Grace: \u00a9 2017 NBCUniversal Media, LLC.&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Will_Grace_0917_BB" data-image-description="" data-medium-file="https://www.channelguidemag.com/wp-content/uploads/2017/09/Will_Grace_0917_BB-300x128.jpg" data-large-file="https://www.channelguidemag.com/wp-content/uploads/2017/09/Will_Grace_0917_BB-1024x435.jpg" /><span>Previous</span><p>Thursday, Feb. 20: Grace Has a Mishap at the Aquarium on &#8216;Will &#038; Grace&#8217;</p></a></div>
</nav>
		</div>
			<aside class="mh-widget-col-1 mh-sidebar" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><div id="search-2" class="mh-widget widget_search"><form role="search" method="get" class="search-form" action="https://www.channelguidemag.com/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></div><div id="text-771362232" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362225" class="mh-widget widget_text"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">Subscribe</span></h4>			<div class="textwidget"><p><center><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&amp;publ=CG&amp;key=IZX2Y94"><img src="https://www.channelguidemag.com/wp-content/uploads/2017/07/save-66.gif" /><br />
<img style="max-width: 250px;" src="https://f1a66fb47ceb2043c6d5-23982838d2415744fc67238fdcf4584f.ssl.cf2.rackcdn.com/cover0220-400.jpg" /></a></center><br />
<span style="display: block; font: 100% Montserrat; margin: 0 auto; max-width: 250px;">The most complete TV listings and best recommendations delivered right to your door — every month.</span></p>
</div>
		</div><div id="mh_magazine_custom_posts-10" class="mh-widget mh_magazine_custom_posts"><h4 class="mh-widget-title"><span class="mh-widget-title-inner">In This Issue</span></h4>			<ul class="mh-custom-posts-widget mh-custom-posts-no-image clearfix"> 						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-176955 post type-post status-publish format-standard has-post-thumbnail category-comedy category-interview category-archive category-preview tag-14391 tag-ifc">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2020/02/17/matt-berrys-year-of-the-rabbit-is-ripe-for-laughs/" title="Matt Berry&#8217;s &#8216;Year of the Rabbit&#8217; Is Ripe for Laughs">
										Matt Berry&#8217;s &#8216;Year of the Rabbit&#8217; Is Ripe for Laughs									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/02/">February 17, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/02/17/matt-berrys-year-of-the-rabbit-is-ripe-for-laughs/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-176783 post type-post status-publish format-standard has-post-thumbnail category-drama category-archive tag-14391 tag-own">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2020/02/11/own-cherish-the-day-preview/" title="&#8216;Cherish the Day&#8217; Is a Love Story That Explores the Big and Small Moments of a Relationship">
										&#8216;Cherish the Day&#8217; Is a Love Story That Explores the Big and Small Moments of a Relationship									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/02/">February 11, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/02/11/own-cherish-the-day-preview/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>						<li class="mh-custom-posts-item mh-custom-posts-small clearfix post-176824 post type-post status-publish format-standard has-post-thumbnail category-drama category-archive category-tv-news-program-updates tag-14391 tag-briarpatch tag-usa-network">
														<div class="mh-custom-posts-header">
								<div class="mh-custom-posts-small-title">
									<a href="https://www.channelguidemag.com/tv-news/2020/02/05/briarpatch-rosario-dawson-interview/" title="&#8216;Briarpatch&#8217;: USA Network&#8217;s Rosario Dawson-Led Drama Offers Pulpy Fun">
										&#8216;Briarpatch&#8217;: USA Network&#8217;s Rosario Dawson-Led Drama Offers Pulpy Fun									</a>
								</div>
								<div class="mh-meta entry-meta">
<span class="entry-meta-date updated"><i class="fa fa-clock-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/02/">February 5, 2020</a></span>
<span class="entry-meta-comments"><i class="fa fa-comment-o"></i><a href="https://www.channelguidemag.com/tv-news/2020/02/05/briarpatch-rosario-dawson-interview/#respond" class="mh-comment-count-link" >0</a></span>
</div>
							</div>
						</li>			</ul></div><div id="text-771362226" class="mh-widget widget_text">			<div class="textwidget"><div style="background-color:  #FF9245; font: 170% Montserrat; font-weight:bold; margin: 10px 0 0; padding: 5px 0; text-align: center;"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&publ=CG&key=IZX2Y94" id="order-button">ORDER NOW!</a></div></div>
		</div><div id="text-771362234" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="custom_html-5" class="widget_text mh-widget widget_custom_html"><div class="textwidget custom-html-widget"><iframe src="https://widgets.tvinsider.com/discover/widgets/display.cfm?widgetGUID=e76eae7a-3166-419a-9f01-b1f984cc35a5" style="max-width:300px;width:100%;height:462px;border:0;"></iframe></div></div>
<div id="wpp-6" class="mh-widget popular-posts">
<h4 class="mh-widget-title"><span class="mh-widget-title-inner">Popular Posts</span></h4>            <script type="text/javascript">
                document.addEventListener('DOMContentLoaded', function() {
                    var wpp_widget_container = document.getElementById('wpp-6');

                    if ( 'undefined' != typeof WordPressPopularPosts ) {
                        WordPressPopularPosts.get(
                            wpp_params.ajax_url + '/widget/6',
                            'is_single=176934',
                            function(response){
                                wpp_widget_container.innerHTML += JSON.parse(response).widget;

                                let sr = wpp_widget_container.querySelector('.popular-posts-sr');

                                if ( sr ) {
                                    WordPressPopularPosts.theme(sr);
                                }

                                var event = null;

                                if ( 'function' === typeof(Event) ) {
                                    event = new Event("wpp-onload", {"bubbles": true, "cancelable": false});
                                } /* Fallback for older browsers */
                                else {
                                    if ( document.createEvent ) {
                                        event = document.createEvent('Event');
                                        event.initEvent("wpp-onload", true, false);
                                    }
                                }

                                if ( event ) {
                                    wpp_widget_container.dispatchEvent(event);
                                }
                            }
                        );
                    }
                });
            </script>
            
</div>
<div id="text-771362236" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362192" class="mh-widget widget_text">			<div class="textwidget"><center><!-- Medium_Rectangle_300x250 -->
<div id='div-gpt-ad-1426776676899-3'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1426776676899-3'); });
</script>
</div></center>

</div>
		</div><div id="text-771362233" class="mh-widget widget_text">			<div class="textwidget"><hr /></div>
		</div><div id="text-771362223" class="mh-widget widget_text">			<div class="textwidget"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/classic-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#e8e8e8; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="https://channelguidemag.us4.list-manage.com/subscribe/post?u=a2d9de00dacb27b8907ecc15a&amp;id=6990079feb" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<h2 style="color: #f47d2a;">Email sign up!</h2>
Follow your favorite writers and/or get weekly updates to the best on TV.<br /><br />
<div class="mc-field-group">
	<label for="mce-EMAIL">Email Address  <span class="asterisk">*</span>
</label>
	<input type="email" value="" name="EMAIL" class="required email" id="mce-EMAIL">
</div>
<div class="mc-field-group input-group">
    <ul><li><input type="checkbox" value="1" name="group[2865][1]" id="mce-group[2865]-2865-0"><label for="mce-group[2865]-2865-0">5toWATCH Weekly eNewsletter</label></li>
    <li><input type="checkbox" value="131072" name="group[6821][131072]" id="mce-group[6821]-6821-0"><label for="mce-group[6821]-6821-0">Ryan Berenz posts</label></li>
<li><input type="checkbox" value="8388608" name="group[6821][8388608]" id="mce-group[6821]-6821-1"><label for="mce-group[6821]-6821-1">Kellie Freeze posts</label></li>
<li><input type="checkbox" value="262144" name="group[6821][262144]" id="mce-group[6821]-6821-2"><label for="mce-group[6821]-6821-2">Barb Oates posts</label></li>
<li><input type="checkbox" value="524288" name="group[6821][524288]" id="mce-group[6821]-6821-3"><label for="mce-group[6821]-6821-3">Jeff Pfeiffer posts</label></li>
</ul>
</div>
	<div id="mce-responses" class="clear">
		<div class="response" id="mce-error-response" style="display:none"></div>
		<div class="response" id="mce-success-response" style="display:none"></div>
	</div>    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_a2d9de00dacb27b8907ecc15a_6990079feb" tabindex="-1" value=""></div>
    <div class="clear"><input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button"></div>
    </div>
</form>
</div>
<script type='text/javascript' src='//s3.amazonaws.com/downloads.mailchimp.com/js/mc-validate.js'></script><script type='text/javascript'>(function($) {window.fnames = new Array(); window.ftypes = new Array();fnames[0]='EMAIL';ftypes[0]='email';fnames[1]='FNAME';ftypes[1]='text';fnames[2]='LNAME';ftypes[2]='text';fnames[6]='ADDRESS';ftypes[6]='address';fnames[7]='KEYCODE';ftypes[7]='text';fnames[3]='SUBID';ftypes[3]='text';fnames[4]='VERSION';ftypes[4]='text';fnames[5]='EXPISSUE';ftypes[5]='text';fnames[8]='EXPYEAR';ftypes[8]='text';fnames[9]='ACTIVEMO';ftypes[9]='number';fnames[10]='SFGNO';ftypes[10]='text';}(jQuery));var $mcj = jQuery.noConflict(true);</script>
<!--End mc_embed_signup--></div>
		</div>	</aside>	</div>
    </div>
<footer class="mh-footer" id="footer-override">
	<div class="mh-container mh-container-inner mh-footer-widgets mh-row clearfix">
					<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-1">
				<div id="text-771362230" class="mh-footer-widget widget_text">			<div class="textwidget"><img src="https://www.channelguidemag.com/wp-content/uploads/2016/06/CG-Big-Magazine_white-orange-500-1.png"></div>
		</div><div id="mh_magazine_social-3" class="mh-footer-widget mh_magazine_social">				<nav class="mh-social-icons mh-social-widget clearfix">
					<div class="menu-social-container"><ul id="menu-social-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151616"><a href="https://www.facebook.com/ChannelGuideMagazine/"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151617"><a href="https://www.twitter.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Twitter</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151618"><a href="https://www.pinterest.com/ChannelGuide"><i class="fa fa-mh-social"></i><span class="screen-reader-text">Pinterest</span></a></li>
</ul></div>				</nav></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-2">
				<div id="nav_menu-4" class="mh-footer-widget widget_nav_menu"><div class="menu-top-menu-footer-container"><ul id="menu-top-menu-footer" class="menu"><li id="menu-item-151599" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-151599"><a href="https://www.channelguidemag.com/tv-news/category/tv-best-bets/">TV Best Bets</a></li>
<li id="menu-item-151600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151600"><a href="/movies-tv/">Movies On TV</a></li>
<li id="menu-item-151601" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151601"><a href="/tv-listings/">TV Listings</a></li>
<li id="menu-item-151602" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151602"><a href="https://www.channelguidemag.com/tv-news/category/sports/">Sports</a></li>
<li id="menu-item-151603" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-151603"><a href="https://www.channelguidemag.com/tv-news/">TV News</a></li>
<li id="menu-item-151604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151604"><a href="https://www.channelguidemag.com/tv-news/category/binge-watching/">Binge Watching</a></li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-3">
				<div id="nav_menu-5" class="mh-footer-widget widget_nav_menu"><div class="menu-customer-service-container"><ul id="menu-customer-service-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-151605"><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&#038;publ=CG&#038;key=IZX2Y91">Subscribe</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151606"><a href="https://ssl.drgnetwork.com/ecom/TMS/app/live/subscriptions?org=TMS&#038;publ=CG&#038;key_code=IEHCGMG&#038;type=S">Give a Gift</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151607"><a href="https://ssl.drgnetwork.com/ecom/tms/cgi/subcustserv/start?org=TMS&#038;publ=CG">Renew/Customer Service</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151608"><a href="https://www.channelguidemag.com/frequently-asked-questions-about-channel-guide-magazine/">FAQs</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151609"><a href="https://www.channelguidemag.com/tv-news/category/archive/">Magazine Archive</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156378"><a href="https://www.channelguidemag.com/privacy-policy/">Privacy Policy</a></li>
</ul>
</li>
</ul></div></div>			</div>
							<div class="mh-col-1-4 mh-widget-col-1 mh-footer-area mh-footer-4">
				<div id="text-771362218" class="mh-footer-widget widget_text">			<div class="textwidget"><p><a href="https://ssl.drgnetwork.com/ecom/tms/app/live/promosub?org=tms&amp;publ=CG&amp;key=IZX2Y93"><img src="https://www.channelguidemag.com/wp-content/uploads/2017/07/CG-Ad_Save-66_300x250_Dolly.jpg" /></a></p>
</div>
		</div>			</div>
			</div>
</footer>
	<div class="mh-footer-mobile-nav"></div>
	<nav class="mh-footer-nav">
		<div class="mh-container mh-container-inner clearfix">
			<div class="menu-publications-container"><ul id="menu-publications" class="menu"><li id="menu-item-151610" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-151610"><a href="https://www.channelguidemag.com/">Channel Guide Magazine</a></li>
<li id="menu-item-151611" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151611"><a href="http://www.ondishmag.com">OnDISH Magazine</a></li>
<li id="menu-item-151612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151612"><a href="http://www.iwantmytvmagazine.com/">TV Weekly</a></li>
<li id="menu-item-151613" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151613"><a href="http://www.tvguidemagazine.com/">TV Guide</a></li>
<li id="menu-item-151614" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151614"><a href="http://www.view-mag.com/">VIEW Magazine</a></li>
<li id="menu-item-151615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-151615"><a href="http://www.remindmagazine.com/">REMIND Magazine</a></li>
</ul></div>		</div>
	</nav>
<div class="mh-copyright-wrap">
	<div class="mh-container mh-container-inner clearfix">
		<p class="mh-copyright">@ 2019 Channel Guide Magazine</p>
	</div>
</div>
<a href="#" class="mh-back-to-top"><i class="fa fa-chevron-up"></i></a>
</div><!-- .mh-container-outer -->
        <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
                <script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
        	<div style="display:none">
	</div>

	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/www.channelguidemag.com\/tv-news\/2020\/02\/21\/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc\/":176934};
	</script>
					<div id="sharing_email" style="display: none;">
		<form action="/tv-news/2020/02/21/friday-feb-21-fresh-off-the-boat-two-part-series-finale-on-abc/" method="post">
			<label for="target_email">Send to Email Address</label>
			<input type="email" name="target_email" id="target_email" value="" />

			
				<label for="source_name">Your Name</label>
				<input type="text" name="source_name" id="source_name" value="" />

				<label for="source_email">Your Email Address</label>
				<input type="email" name="source_email" id="source_email" value="" />

						<input type="text" id="jetpack-source_f_name" name="source_f_name" class="input" value="" size="25" autocomplete="off" title="This field is for validation and should not be changed" />
			
			<img style="float: right; display: none" class="loading" src="https://www.channelguidemag.com/wp-content/plugins/jetpack/modules/sharedaddy/images/loading.gif" alt="loading" width="16" height="16" />
			<input type="submit" value="Send Email" class="sharing_send" />
			<a rel="nofollow" href="#cancel" class="sharing_cancel" role="button">Cancel</a>

			<div class="errors errors-1" style="display: none;">
				Post was not sent - check your email addresses!			</div>

			<div class="errors errors-2" style="display: none;">
				Email check failed, please try again			</div>

			<div class="errors errors-3" style="display: none;">
				Sorry, your blog cannot share posts by email.			</div>
		</form>
	</div>
		<script type='text/javascript' src='https://www.channelguidemag.com/wp-includes/js/wp-embed.min.js?ver=992155a48e1b80f830c1d3baf8c7b15c'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.channelguidemag.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=8.2.2'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-202008.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.2',blog:'113259570',post:'176934',tz:'-6',srv:'www.channelguidemag.com'} ]);
	_stq.push([ 'clickTrackerInit', '113259570', '176934' ]);
</script>
</body>
</html>